# Top

**URL:** https://discuss.elastic.co/top.md?page=36&period=all

[Latest](https://discuss.elastic.co/latest.md) · [Categories](https://discuss.elastic.co/categories.md) · [Tags](https://discuss.elastic.co/tags.md)

**Page:** 37

---

## [ElasticSearch use too much Memory then cause sys cpu too high](https://discuss.elastic.co/t/elasticsearch-use-too-much-memory-then-cause-sys-cpu-too-high/63147)

<div class="topic-metadata">

**Author:** [@hadeslion](https://discuss.elastic.co/u/hadeslion)\
**Replies:** 13\
**Last updated:** [November 2, 2016, 9:40am UTC](https://discuss.elastic.co/t/elasticsearch-use-too-much-memory-then-cause-sys-cpu-too-high/63147 "2016-11-02T09:40:10Z")

</div>

I use ElasticSearch to store some datetime based data. Data of each day is stored as a index. The total storage of 75 is about 600GB. when ElasticSearch startup, the proccess's VIRT is up to 145GB. Then when I do lots of…

---

## [Elasticsearch reindex is not working](https://discuss.elastic.co/t/elasticsearch-reindex-is-not-working/89589)

<div class="topic-metadata">

**Author:** [@hello4usharath](https://discuss.elastic.co/u/hello4usharath)\
**Replies:** 16\
**Last updated:** [June 17, 2017, 7:21am UTC](https://discuss.elastic.co/t/elasticsearch-reindex-is-not-working/89589 "2017-06-17T07:21:33Z")

</div>

We have being trying to perform re indexing of existing to new index with change in mapping. But indexing is not happening properly. health status index uuid pri rep docs.count docs.delet…

---

## [Unable to read .gz files in logstash](https://discuss.elastic.co/t/unable-to-read-gz-files-in-logstash/136174)

<div class="topic-metadata">

**Author:** [@clash\_of\_clanss](https://discuss.elastic.co/u/clash_of_clanss)\
**Replies:** 12\
**Last updated:** [July 16, 2018, 1:11pm UTC](https://discuss.elastic.co/t/unable-to-read-gz-files-in-logstash/136174 "2018-07-16T13:11:40Z")

</div>

Hi, I am trying to read .gz files in logstash input plugin but I can't read gunzip files in logstash. When I try to read those log files it throws error message like this, A plugin had an unrecoverable error. Will rest…

---

## [Connection refused elasticsearch port 9200 on ubuntu 20.04](https://discuss.elastic.co/t/connection-refused-elasticsearch-port-9200-on-ubuntu-20-04/301335)

<div class="topic-metadata">

**Author:** [@danielbsilva2](https://discuss.elastic.co/u/danielbsilva2)\
**Replies:** 12\
**Last updated:** [April 3, 2022, 5:15pm UTC](https://discuss.elastic.co/t/connection-refused-elasticsearch-port-9200-on-ubuntu-20-04/301335 "2022-04-03T17:15:11Z")

</div>

good afternoon guys my English is not very good but I will try to explain myself I have a test server here at digitalocean with ubuntu 20.04 and I installed Elasticsearch for log collection on this same test server but …

---

## [Regarding Kibana : Calendar Visualization and Filtering](https://discuss.elastic.co/t/regarding-kibana-calendar-visualization-and-filtering/119920)

<div class="topic-metadata">

**Author:** [@vedularaghu](https://discuss.elastic.co/u/vedularaghu)\
**Replies:** 30\
**Last updated:** [May 27, 2022, 1:28pm UTC](https://discuss.elastic.co/t/regarding-kibana-calendar-visualization-and-filtering/119920 "2022-05-27T13:28:43Z")

</div>

Hello, I am a CS undergraduate student of CET, Bhubaneswar. I want to work on 'Kibana: Calendar Visualisation and Filtering' project. I have experience in full-stack development in Node JS , React JS. I have hands-on …

---

## [Mysql data mapping for Elasticseach](https://discuss.elastic.co/t/mysql-data-mapping-for-elasticseach/42239)

<div class="topic-metadata">

**Author:** [@Hilal](https://discuss.elastic.co/u/Hilal)\
**Replies:** 23\
**Last updated:** [March 10, 2016, 10:25am UTC](https://discuss.elastic.co/t/mysql-data-mapping-for-elasticseach/42239 "2016-03-10T10:25:00Z")

</div>

Hi, I am in the process of converting my queries from Mysql to Elasticsearch, and would like to know if my mapping makes sense. I've identified 4 common types of data that I want to store. tip : "tip" is my enum fi…

---

## [Logstash crashes after sometime and freezes the system](https://discuss.elastic.co/t/logstash-crashes-after-sometime-and-freezes-the-system/28848)

<div class="topic-metadata">

**Author:** [@imad](https://discuss.elastic.co/u/imad)\
**Replies:** 20\
**Last updated:** [September 14, 2015, 10:44pm UTC](https://discuss.elastic.co/t/logstash-crashes-after-sometime-and-freezes-the-system/28848 "2015-09-14T22:44:18Z")

</div>

I am using logstash to feed elasticsearch indices data from my couchdb. I have about 20 indices. At this time I have very simple setup. All my data is in different databases in couchDB, e.g., users has its own db, roles …

---

## [XML Input Issues](https://discuss.elastic.co/t/xml-input-issues/118751)

<div class="topic-metadata">

**Author:** [@wwalker](https://discuss.elastic.co/u/wwalker)\
**Replies:** 27\
**Last updated:** [March 12, 2018, 4:17am UTC](https://discuss.elastic.co/t/xml-input-issues/118751 "2018-03-12T04:17:45Z")

</div>

I posted a topic earlier about this but it got bogged down with craziness, hoping that is the reason there was limited assistance from the community. I am trying to ingest DMARC aggregate XML reports. Here is my pipeli…

---

## [Elasticsearch gets shut down automatically](https://discuss.elastic.co/t/elasticsearch-gets-shut-down-automatically/93114)

<div class="topic-metadata">

**Author:** [@utkgarg](https://discuss.elastic.co/u/utkgarg)\
**Replies:** 17\
**Last updated:** [July 14, 2017, 11:35am UTC](https://discuss.elastic.co/t/elasticsearch-gets-shut-down-automatically/93114 "2017-07-14T11:35:47Z")

</div>

I am running elasticsearch on a 2GB RAM server. But sometimes the elasticsearch server automatically gets shuts down. How can I sort this problem?

---

## [Kibana shows fields are not searchable and aggregatable](https://discuss.elastic.co/t/kibana-shows-fields-are-not-searchable-and-aggregatable/89148)

<div class="topic-metadata">

**Author:** [@CaptainFeng](https://discuss.elastic.co/u/CaptainFeng)\
**Replies:** 12\
**Last updated:** [June 16, 2017, 1:19am UTC](https://discuss.elastic.co/t/kibana-shows-fields-are-not-searchable-and-aggregatable/89148 "2017-06-16T01:19:27Z")

</div>

Hi All After upgrading from 2.x, all my fields(including raw) are not searchable and aggregatable. Please help me to figure out why this happens?

---

## [Date field saved as default timezone](https://discuss.elastic.co/t/date-field-saved-as-default-timezone/211143)

<div class="topic-metadata">

**Author:** [@elasticforme](https://discuss.elastic.co/u/elasticforme)\
**Replies:** 9\
**Last updated:** [December 20, 2019, 4:31pm UTC](https://discuss.elastic.co/t/date-field-saved-as-default-timezone/211143 "2019-12-20T16:31:10Z")

</div>

I am back at this. I am seating in CST time zone. most all my source are in CST time zone but all my date field is saved in Elasticsearch as GMT time zone. and my kibana (default setup as ) browser timezone is convert…

---

## [Controlling ES java client's internal connection pool](https://discuss.elastic.co/t/controlling-es-java-clients-internal-connection-pool/13609)

<div class="topic-metadata">

**Author:** [@peter2](https://discuss.elastic.co/u/peter2)\
**Replies:** 15\
**Last updated:** [September 26, 2013, 6:36pm UTC](https://discuss.elastic.co/t/controlling-es-java-clients-internal-connection-pool/13609 "2013-09-26T18:36:47Z")

</div>

So we use ES java client within Twitter Storm (a distributed processing system for streaming data). We use the ES client to perform searches based on data coming through the stream. Each JVM within this distributed …

---

## [Filebeats + nginx problem](https://discuss.elastic.co/t/filebeats-nginx-problem/141952)

<div class="topic-metadata">

**Author:** [@incls](https://discuss.elastic.co/u/incls)\
**Replies:** 11\
**Last updated:** [July 28, 2018, 11:49am UTC](https://discuss.elastic.co/t/filebeats-nginx-problem/141952 "2018-07-28T11:49:45Z")

</div>

Hello, Im new in ELK and i want run that concept: Nginx -\> logstash -\> Elastic -\> Kibana (Standard ELK) But when i try config all i have that problem: When i run: filebeat setup -e: 2018-07-27T13:58:10.146Z ERROR …

---

## [\[ERROR\]\[elasticsearch-service\] Unable to retrieve version information from Elasticsearch nodes. connect ETIMEDOUT](https://discuss.elastic.co/t/error-elasticsearch-service-unable-to-retrieve-version-information-from-elasticsearch-nodes-connect-etimedout/356120)

<div class="topic-metadata">

**Author:** [@Devanshu\_Rastogi](https://discuss.elastic.co/u/Devanshu_Rastogi)\
**Replies:** 12\
**Last updated:** [April 1, 2024, 6:18pm UTC](https://discuss.elastic.co/t/error-elasticsearch-service-unable-to-retrieve-version-information-from-elasticsearch-nodes-connect-etimedout/356120 "2024-04-01T18:18:19Z")

</div>

Hi I am new to Elasticsearch and kibana and today I ran into an error due to which my kibana is not starting. My kibana.yaml - # The Kibana server's name. This is used for display purposes. #server.name: "your-hostname…

---

## [Error from server (NotFound): services "quickstart-es-http" not found](https://discuss.elastic.co/t/error-from-server-notfound-services-quickstart-es-http-not-found/193658)

<div class="topic-metadata">

**Author:** [@alexus](https://discuss.elastic.co/u/alexus)\
**Replies:** 18\
**Last updated:** [August 26, 2019, 4:01pm UTC](https://discuss.elastic.co/t/error-from-server-notfound-services-quickstart-es-http-not-found/193658 "2019-08-26T16:01:05Z")

</div>

Hello World! I'm trying to follow: #### Request Elasticsearch access yet, running into following error: $ kubectl get service quickstart-es-http Error from server (NotFound): services "quickstart-es-http" not found $ …

---

## [Logstash.conf not found for after installing logstash](https://discuss.elastic.co/t/logstash-conf-not-found-for-after-installing-logstash/117004)

<div class="topic-metadata">

**Author:** [@SawyerFord](https://discuss.elastic.co/u/SawyerFord)\
**Replies:** 24\
**Last updated:** [January 29, 2018, 8:51pm UTC](https://discuss.elastic.co/t/logstash-conf-not-found-for-after-installing-logstash/117004 "2018-01-29T20:51:37Z")

</div>

I have installed the logstash with the below link but I am not able to find logstash.conf in my system at the paths /etc/logstash/cont.d /etc/init/ /etc/init.d/ https://www.elastic.co/guide/en/logstash/current/insta…

---

## [How to properly read and ingest XML file into Elastic](https://discuss.elastic.co/t/how-to-properly-read-and-ingest-xml-file-into-elastic/183582)

<div class="topic-metadata">

**Author:** [@edster](https://discuss.elastic.co/u/edster)\
**Replies:** 12\
**Last updated:** [May 31, 2019, 3:41pm UTC](https://discuss.elastic.co/t/how-to-properly-read-and-ingest-xml-file-into-elastic/183582 "2019-05-31T15:41:41Z")

</div>

Hello, I have been trying to ingest an XML file into Elastic using Logstash. I have been using Xpath, target, source in the XML filter options and gsub for mutate filter, however, I keep running into an Error parsing xm…

---

## [Yarn kbn bootstrap fails](https://discuss.elastic.co/t/yarn-kbn-bootstrap-fails/275337)

<div class="topic-metadata">

**Author:** [@Akhil2](https://discuss.elastic.co/u/Akhil2)\
**Replies:** 27\
**Last updated:** [July 8, 2021, 7:14pm UTC](https://discuss.elastic.co/t/yarn-kbn-bootstrap-fails/275337 "2021-07-08T19:14:17Z")

</div>

Hello everyone, I have been trying to run yarn kbn bootstrap but it keeps giving me following errors. E:\\Kibana-development\\kibana\>yarn kbn bootstrap --force-install yarn run v1.22.10 $ node scripts/kbn bootstrap --for…

---

## [How to prioritize exact match using nGram tokenizer? Solved, see solution](https://discuss.elastic.co/t/how-to-prioritize-exact-match-using-ngram-tokenizer-solved-see-solution/235823)

<div class="topic-metadata">

**Author:** [@buka\_bidzina](https://discuss.elastic.co/u/buka_bidzina)\
**Replies:** 10\
**Last updated:** [June 11, 2020, 12:16pm UTC](https://discuss.elastic.co/t/how-to-prioritize-exact-match-using-ngram-tokenizer-solved-see-solution/235823 "2020-06-11T12:16:23Z")

</div>

Hello All, I am wondering, how to rank an exact match higher than the ngram matches. For instance: If I search for asus It scores higher casual than asus or if I search for app it gives me first laptop and than it gi…

---

## [How to prevent empty lines](https://discuss.elastic.co/t/how-to-prevent-empty-lines/133490)

<div class="topic-metadata">

**Author:** [@npontes](https://discuss.elastic.co/u/npontes)\
**Replies:** 25\
**Last updated:** [June 1, 2018, 9:05am UTC](https://discuss.elastic.co/t/how-to-prevent-empty-lines/133490 "2018-06-01T09:05:28Z")

</div>

Hello, I'm currently using Logstash 2.1.1 to retrieve data from Elasticsearch 1.4.4 and put it on a CSV to be imported to a database. My problem is that there are lines where I only have commas (Like this: ",,,,,,,,,,")…

---

## [Logstash Poller Error - Concurrent:TimeoutError - logstash-5.0.0-beta1](https://discuss.elastic.co/t/logstash-poller-error-concurrent-timeouterror-logstash-5-0-0-beta1/62448)

<div class="topic-metadata">

**Author:** [@eli.keimig](https://discuss.elastic.co/u/eli.keimig)\
**Replies:** 14\
**Last updated:** [February 16, 2017, 5:55pm UTC](https://discuss.elastic.co/t/logstash-poller-error-concurrent-timeouterror-logstash-5-0-0-beta1/62448 "2017-02-16T17:55:44Z")

</div>

Getting this error in my logstash-plain.log. There doesn't seem to be an exact frequency from what I can tell - or exact replication steps. It is not affecting messages going the output filters. This logstash is installe…

---

## [Can't start Elasticsearch 5.5 service](https://discuss.elastic.co/t/cant-start-elasticsearch-5-5-service/92435)

<div class="topic-metadata">

**Author:** [@ChrisClark](https://discuss.elastic.co/u/ChrisClark)\
**Replies:** 9\
**Last updated:** [July 10, 2017, 12:18pm UTC](https://discuss.elastic.co/t/cant-start-elasticsearch-5-5-service/92435 "2017-07-10T12:18:09Z")

</div>

Hi, I've recently upgraded an Elasticsearch node from 5.4.3 to 5.5 using the windows msi but unfortunately the service will not start. The service manager returns an error stating that the application terminated unexpe…

---

## [Unable to get mysql performance in packetbeat](https://discuss.elastic.co/t/unable-to-get-mysql-performance-in-packetbeat/1450)

<div class="topic-metadata">

**Author:** [@Akhilesh\_Anb](https://discuss.elastic.co/u/Akhilesh_Anb)\
**Replies:** 23\
**Last updated:** [May 29, 2015, 3:04pm UTC](https://discuss.elastic.co/t/unable-to-get-mysql-performance-in-packetbeat/1450 "2015-05-29T15:04:11Z")

</div>

Im not getting the mysql performance in packetbeat. I'm getting http requests in packetbeat. I have done the tracing by "packetbeat -e -dump trace.pcap"... but the output for that command is nothing. I didnt get anything…

---

## [Exact match search with permutation of words](https://discuss.elastic.co/t/exact-match-search-with-permutation-of-words/165643)

<div class="topic-metadata">

**Author:** [@ankur\_singla](https://discuss.elastic.co/u/ankur_singla)\
**Replies:** 18\
**Last updated:** [February 20, 2019, 5:20pm UTC](https://discuss.elastic.co/t/exact-match-search-with-permutation-of-words/165643 "2019-02-20T17:20:57Z")

</div>

Hi guys I am kinda stuck with a problem in elasticsearch. I want to apply exact match search with a permutation of words. Suppose I have a doc with text "paper boat" & I want to apply exact search in such a way that it…

---

## [MasterNotDiscoveredException](https://discuss.elastic.co/t/masternotdiscoveredexception/12372)

<div class="topic-metadata">

**Author:** [@aash\_dhariya](https://discuss.elastic.co/u/aash_dhariya)\
**Replies:** 13\
**Last updated:** [June 13, 2013, 8:07am UTC](https://discuss.elastic.co/t/masternotdiscoveredexception/12372 "2013-06-13T08:07:28Z")

</div>

When I execute the following query: curl -XGET 'http://localhost:9200/development\_users/user/\_mapping' I get the following error: {"error":"MasterNotDiscoveredException\[waited for \[30s\]\]","status":503} Can anybod…

---

## [Automatic deleting the documents from indices](https://discuss.elastic.co/t/automatic-deleting-the-documents-from-indices/180097)

<div class="topic-metadata">

**Author:** [@Vikash\_Singh1](https://discuss.elastic.co/u/Vikash_Singh1)\
**Replies:** 28\
**Last updated:** [May 10, 2019, 4:40am UTC](https://discuss.elastic.co/t/automatic-deleting-the-documents-from-indices/180097 "2019-05-10T04:40:44Z")

</div>

Hi there!! Since I have started using ELK it make me more curious hence I keep on exploring and hence the doubts also increases rapidly. The biggest challenge in analysis is the size, Now I have an question is there anyw…

---

## [Create button do not appear](https://discuss.elastic.co/t/create-button-do-not-appear/25870)

<div class="topic-metadata">

**Author:** [@trungmv](https://discuss.elastic.co/u/trungmv)\
**Replies:** 16\
**Last updated:** [May 23, 2017, 2:47pm UTC](https://discuss.elastic.co/t/create-button-do-not-appear/25870 "2017-05-23T14:47:06Z")

</div>

Hello expert, I have a issue, no create button appear although i fill in the blank is logstash-\*. I install ELK via repo with the most latest version and on CentOS 6 final. Here is the log when elasticsearch and logst…

---

## [How to import mysql data into elastic search](https://discuss.elastic.co/t/how-to-import-mysql-data-into-elastic-search/152085)

<div class="topic-metadata">

**Author:** [@Nethaji](https://discuss.elastic.co/u/Nethaji)\
**Replies:** 13\
**Last updated:** [October 19, 2018, 5:38am UTC](https://discuss.elastic.co/t/how-to-import-mysql-data-into-elastic-search/152085 "2018-10-19T05:38:48Z")

</div>

hi, i need to know about how to import the mysql data into elasticsearch, can u people please explain about what are software required for kibana visualize. i'm not clearly understand about procedures, what are steps…

---

## [Elastic Observability vs OpenTelemetry: Are We Finally on the "Right" Path?](https://discuss.elastic.co/t/elastic-observability-vs-opentelemetry-are-we-finally-on-the-right-path/385880)

<div class="topic-metadata">

**Author:** [@nilsen](https://discuss.elastic.co/u/nilsen)\
**Replies:** 22\
**Last updated:** [August 20, 2026, 10:48am UTC](https://discuss.elastic.co/t/elastic-observability-vs-opentelemetry-are-we-finally-on-the-right-path/385880 "2026-08-20T10:48:12Z")

</div>

Context Our Elastic journey has been interesting and filled with trial and error. Around every corner we discover a different (and often better) way of doing the same thing, but it usually means redoing large parts of ou…

---

## [How to create a new field combining values of other field values](https://discuss.elastic.co/t/how-to-create-a-new-field-combining-values-of-other-field-values/238087)

<div class="topic-metadata">

**Author:** [@Matish\_Bhuyan](https://discuss.elastic.co/u/Matish_Bhuyan)\
**Replies:** 36\
**Last updated:** [July 10, 2020, 5:32am UTC](https://discuss.elastic.co/t/how-to-create-a-new-field-combining-values-of-other-field-values/238087 "2020-07-10T05:32:08Z")

</div>

Hi All, I am using elk version 7.2 I have two keywords 1- result 2 - service using the values of these keywords i want to create another field which will met the condition and keep the data according to the conditio…

---

## [ES used heap % grows slowly until system becomes unresponsive](https://discuss.elastic.co/t/es-used-heap-grows-slowly-until-system-becomes-unresponsive/27619)

<div class="topic-metadata">

**Author:** [@Alexander\_Vassilevsk](https://discuss.elastic.co/u/Alexander_Vassilevsk)\
**Replies:** 20\
**Last updated:** [August 21, 2015, 6:03pm UTC](https://discuss.elastic.co/t/es-used-heap-grows-slowly-until-system-becomes-unresponsive/27619 "2015-08-21T18:03:42Z")

</div>

How's it going guys/gals. I am running a production elasticsearch ( elasticsearch-1.5.0.jar ) cluster consisting of 6 nodes. One such node is a so-called "load-balancer" node ( lb.es ). It is not a data node, and all t…

---

## [I Have a Recovered cluster but unassigned can some one help](https://discuss.elastic.co/t/i-have-a-recovered-cluster-but-unassigned-can-some-one-help/94461)

<div class="topic-metadata">

**Author:** [@Danny\_Crossby](https://discuss.elastic.co/u/Danny_Crossby)\
**Replies:** 11\
**Last updated:** [July 27, 2017, 4:07pm UTC](https://discuss.elastic.co/t/i-have-a-recovered-cluster-but-unassigned-can-some-one-help/94461 "2017-07-27T16:07:20Z")

</div>

99abc 4 r UNASSIGNED CLUSTER\_RECOVERED 99abc 2 r UNASSIGNED CLUSTER\_RECOVERED 99abc 1 r UNASSIGNED CLUSTER\_RECOVERED 99abc 3 r UNASSIGNED CLUSTER\_RECOVERED 99abc 0 r UNASSIGNED CLUSTER\_RECOVERED

---

## [Can't start elasticsearch 8.5 with docker](https://discuss.elastic.co/t/cant-start-elasticsearch-8-5-with-docker/318029)

<div class="topic-metadata">

**Author:** [@FatNerd](https://discuss.elastic.co/u/FatNerd)\
**Replies:** 13\
**Last updated:** [December 5, 2022, 12:36am UTC](https://discuss.elastic.co/t/cant-start-elasticsearch-8-5-with-docker/318029 "2022-12-05T00:36:46Z")

</div>

I'm trying to execute the docker-compose.yml from this page Install Elasticsearch with Docker | Elasticsearch Guide \[8.5\] | Elastic In the .env file, I left everything to default except the two passwords Ther first se…

---

## [Can't write data to elasticsearch (cannot be changed from type \[date\] to \[text)](https://discuss.elastic.co/t/cant-write-data-to-elasticsearch-cannot-be-changed-from-type-date-to-text/330062)

<div class="topic-metadata">

**Author:** [@Indeed2000](https://discuss.elastic.co/u/Indeed2000)\
**Replies:** 21\
**Last updated:** [April 29, 2023, 2:59pm UTC](https://discuss.elastic.co/t/cant-write-data-to-elasticsearch-cannot-be-changed-from-type-date-to-text/330062 "2023-04-29T14:59:19Z")

</div>

Hi can't write data to elasticsearch vi logstash(http\_poller) here is the scenario: influxdb \> logstash(http\_poller) \> elasticsearch error that I get: "status"=\>400, "error"=\>{"type"=\>"illegal\_argument\_exception", "…

---

## [Logs time 6 hours behind local time](https://discuss.elastic.co/t/logs-time-6-hours-behind-local-time/169679)

<div class="topic-metadata">

**Author:** [@rugenl](https://discuss.elastic.co/u/rugenl)\
**Replies:** 31\
**Last updated:** [March 30, 2019, 4:40am UTC](https://discuss.elastic.co/t/logs-time-6-hours-behind-local-time/169679 "2019-03-30T04:40:44Z")

</div>

I just started investigating logs. I setup filebeat on my elastic cluster and enabled the elasticsearch and logstash modules. The data is there, but the log time is -6 hours from local. For example @timestamp is Febru…

---

## [Elastic search error in application, Error message - " An error occurred while requesting elastic search for data on index 'denmod\_y\_\*'](https://discuss.elastic.co/t/elastic-search-error-in-application-error-message-an-error-occurred-while-requesting-elastic-search-for-data-on-index-denmod-y/190261)

<div class="topic-metadata">

**Author:** [@Joseph\_Raj](https://discuss.elastic.co/u/Joseph_Raj)\
**Replies:** 26\
**Last updated:** [August 8, 2019, 9:10am UTC](https://discuss.elastic.co/t/elastic-search-error-in-application-error-message-an-error-occurred-while-requesting-elastic-search-for-data-on-index-denmod-y/190261 "2019-08-08T09:10:36Z")

</div>

Once the application runs & When Elasticsearch for data, it was unable to retrieve. It says error while searching the data. It has two types of error 1) All shards failed error 2) Index not found exception. We have re…

---

## [Search doesn't find the document that it should find when index is big?](https://discuss.elastic.co/t/search-doesnt-find-the-document-that-it-should-find-when-index-is-big/214386)

<div class="topic-metadata">

**Author:** [@aqiank](https://discuss.elastic.co/u/aqiank)\
**Replies:** 28\
**Last updated:** [January 20, 2020, 9:49am UTC](https://discuss.elastic.co/t/search-doesnt-find-the-document-that-it-should-find-when-index-is-big/214386 "2020-01-20T09:49:31Z")

</div>

Hi, I have a problem with Elasticsearch 6.8 (I also tried with 5.6 and 2.4 since we are upgrading) where it can't find the document that I want when the index has over 800K documents but when I create another index with …

---

## [Duplicate logs](https://discuss.elastic.co/t/duplicate-logs/134610)

<div class="topic-metadata">

**Author:** [@Honda\_fred\_elk](https://discuss.elastic.co/u/Honda_fred_elk)\
**Replies:** 13\
**Last updated:** [June 12, 2018, 4:41pm UTC](https://discuss.elastic.co/t/duplicate-logs/134610 "2018-06-12T16:41:12Z")

</div>

Hello, I have ELK version 6.2.2. Configured and working.. I have installed ELK in two nodes. I observed that Kibana started showing duplicate logs... as in the picture.. \[Duplicate1\] \[Duplicate2\] Below is my Logsta…

---

## [ERROR pipeline/output.go:121 Failed to publish events: temporary bulk send failure](https://discuss.elastic.co/t/error-pipeline-output-go-121-failed-to-publish-events-temporary-bulk-send-failure/169361)

<div class="topic-metadata">

**Author:** [@Sharad\_Ananth](https://discuss.elastic.co/u/Sharad_Ananth)\
**Replies:** 13\
**Last updated:** [February 22, 2019, 12:23pm UTC](https://discuss.elastic.co/t/error-pipeline-output-go-121-failed-to-publish-events-temporary-bulk-send-failure/169361 "2019-02-22T12:23:48Z")

</div>

I am getting the error whenever I try ingesting data into elasticsearch using filebeat. 2019-02-21T07:57:02.190Z INFO elasticsearch/client.go:721 Connected to Elasticsearch version 6.5.4 2019-02-21T07:57:0…

---

## [Logstash not reading config file when ran as a service](https://discuss.elastic.co/t/logstash-not-reading-config-file-when-ran-as-a-service/83605)

<div class="topic-metadata">

**Author:** [@runatyr](https://discuss.elastic.co/u/runatyr)\
**Replies:** 19\
**Last updated:** [April 26, 2017, 2:40pm UTC](https://discuss.elastic.co/t/logstash-not-reading-config-file-when-ran-as-a-service/83605 "2017-04-26T14:40:21Z")

</div>

Hello again all. Thank you so much for your help on my previous question. Hopefully this is my last (lol almost got that out with a straight face) When I run the command line on my redhat box ./logstash -f /usr/share…

---

## [Mapping ip address to geolocation](https://discuss.elastic.co/t/mapping-ip-address-to-geolocation/197136)

<div class="topic-metadata">

**Author:** [@gr1sha](https://discuss.elastic.co/u/gr1sha)\
**Replies:** 11\
**Last updated:** [August 30, 2019, 3:34pm UTC](https://discuss.elastic.co/t/mapping-ip-address-to-geolocation/197136 "2019-08-30T15:34:10Z")

</div>

Hi there. I am trying to create a region map so that I can see the activity of users from different countries. I have an ip address field in my index and what I am trying to do is map it to geoip location to get fields l…

---

## [Error java.lang.NoSuchMethodError: org.elasticsearch.search.SearchHits.getTotalHits()](https://discuss.elastic.co/t/error-java-lang-nosuchmethoderror-org-elasticsearch-search-searchhits-gettotalhits/226592)

<div class="topic-metadata">

**Author:** [@ajnfde3](https://discuss.elastic.co/u/ajnfde3)\
**Replies:** 20\
**Last updated:** [April 25, 2020, 4:33pm UTC](https://discuss.elastic.co/t/error-java-lang-nosuchmethoderror-org-elasticsearch-search-searchhits-gettotalhits/226592 "2020-04-25T16:33:58Z")

</div>

Hello guys, I know this topic has already been opened but I couldn't see any solution. I am using spring boot 2.2.6 with ES 7.6.2, spring data commons 2.2.6. I defined my repository like this: public interface Collabor…

---

## [Conditional scripted field with if else](https://discuss.elastic.co/t/conditional-scripted-field-with-if-else/261646)

<div class="topic-metadata">

**Author:** [@Rakesh\_Rayabarapu](https://discuss.elastic.co/u/Rakesh_Rayabarapu)\
**Replies:** 11\
**Last updated:** [January 21, 2021, 11:20am UTC](https://discuss.elastic.co/t/conditional-scripted-field-with-if-else/261646 "2021-01-21T11:20:55Z")

</div>

Hello Team, I am new to this tool, Could you please help me to fix this painless script. I am trying get new scripted field with \[ResTime\] value when \[Region\] is "APJ" else blank. if (doc\['Region'\].value == 'APJ') { …

---

## ["codebase property already set" when running ESIntegTestCase](https://discuss.elastic.co/t/codebase-property-already-set-when-running-esintegtestcase/135659)

<div class="topic-metadata">

**Author:** [@ndtreviv](https://discuss.elastic.co/u/ndtreviv)\
**Replies:** 32\
**Last updated:** [June 15, 2018, 12:08pm UTC](https://discuss.elastic.co/t/codebase-property-already-set-when-running-esintegtestcase/135659 "2018-06-15T12:08:26Z")

</div>

We're attempting an upgrade to ES 6.2. Previously, we'd integration tested code by using NodeBuilder and running up a local ES node. I'd rather swap this out for the ESIntegTestCase usage if possible. However, when I t…

---

## [SearchResponse as JSON](https://discuss.elastic.co/t/searchresponse-as-json/320475)

<div class="topic-metadata">

**Author:** [@divadpoc](https://discuss.elastic.co/u/divadpoc)\
**Replies:** 19\
**Last updated:** [December 7, 2022, 7:29pm UTC](https://discuss.elastic.co/t/searchresponse-as-json/320475 "2022-12-07T19:29:07Z")

</div>

Hi, I'm using version 8.5.1 w/ the Java client. I'm looking for a way to get the SearchResponse as JSON, or at least the same output I'd get when executing the query in Kibana. Thanks for any hints.

---

## [How to aggregate based on latest value?](https://discuss.elastic.co/t/how-to-aggregate-based-on-latest-value/140737)

<div class="topic-metadata">

**Author:** [@tpraizler](https://discuss.elastic.co/u/tpraizler)\
**Replies:** 16\
**Last updated:** [July 24, 2018, 11:13am UTC](https://discuss.elastic.co/t/how-to-aggregate-based-on-latest-value/140737 "2018-07-24T11:13:19Z")

</div>

Hi, I am trying to understand if I can do the following aggregation. Let's say I have the following documents: { "\_id": "auy6a25C7ofiYFJ1f", "my\_id": 1, "type": "A" "timestamp": "2018-10-27 10:00" }, { "\_id": "l…

---

## [How to reduce terms\_memory\_in\_bytes? Help Help Help](https://discuss.elastic.co/t/how-to-reduce-terms-memory-in-bytes-help-help-help/49135)

<div class="topic-metadata">

**Author:** [@liusy](https://discuss.elastic.co/u/liusy)\
**Replies:** 19\
**Last updated:** [May 9, 2016, 5:31am UTC](https://discuss.elastic.co/t/how-to-reduce-terms-memory-in-bytes-help-help-help/49135 "2016-05-09T05:31:07Z")

</div>

"segments" : { "count" : 11954, "memory\_in\_bytes" : 12613933974, "terms\_memory\_in\_bytes" : 10524364098, "stored\_fields\_memory\_in\_bytes" : 2057138120, "term\_vectors\_memory…

---

## [Wildcard and slashes](https://discuss.elastic.co/t/wildcard-and-slashes/7088)

<div class="topic-metadata">

**Author:** [@chimingc](https://discuss.elastic.co/u/chimingc)\
**Replies:** 9\
**Last updated:** [March 26, 2012, 4:18am UTC](https://discuss.elastic.co/t/wildcard-and-slashes/7088 "2012-03-26T04:18:27Z")

</div>

I've indexed this: "24/account". I understand that it's been tokenized into "24" and "account", which is not a problem for me. However, when I query "24/a\*", it finds no match. Then I tried the following case…

---

## [Elasticsearch remote clusters not connecting](https://discuss.elastic.co/t/elasticsearch-remote-clusters-not-connecting/220975)

<div class="topic-metadata">

**Author:** [@Eyal\_Even](https://discuss.elastic.co/u/Eyal_Even)\
**Replies:** 11\
**Last updated:** [March 25, 2020, 9:04am UTC](https://discuss.elastic.co/t/elasticsearch-remote-clusters-not-connecting/220975 "2020-03-25T09:04:23Z")

</div>

Hello everyone, Due to a recent interest in my workplace, I've been trying to connect 2 of my clusters for DR purposes, but no matter what I do, the 2 clusters will just not connect, at all. At first, I tried connectin…

---

## [Remote Transport Exception in 5.1.1 w/JDK 1.8.0\_111](https://discuss.elastic.co/t/remote-transport-exception-in-5-1-1-w-jdk-1-8-0-111/69607)

<div class="topic-metadata">

**Author:** [@ben-10](https://discuss.elastic.co/u/ben-10)\
**Replies:** 20\
**Last updated:** [December 21, 2016, 11:28pm UTC](https://discuss.elastic.co/t/remote-transport-exception-in-5-1-1-w-jdk-1-8-0-111/69607 "2016-12-21T23:28:29Z")

</div>

Noticing that nodes in my cluster will sporadically lose connection to the cluster briefly before re-establishing connection. This is causing a lot of wasted overhead on shard allocation. Searching Google, this appears t…

[Previous page](https://discuss.elastic.co/top.md?page=35&per_page=50&period=all)

[Next page](https://discuss.elastic.co/top.md?page=37&per_page=50&period=all)
