# Top

**URL:** https://discuss.elastic.co/top.md?page=4&period=all

[Latest](https://discuss.elastic.co/latest.md) · [Categories](https://discuss.elastic.co/categories.md) · [Tags](https://discuss.elastic.co/tags.md)

**Page:** 5

---

## [Pipelines.yml ignored on logstash running as a service](https://discuss.elastic.co/t/pipelines-yml-ignored-on-logstash-running-as-a-service/107828)

<div class="topic-metadata">

**Author:** [@dorj1234](https://discuss.elastic.co/u/dorj1234)\
**Replies:** 17\
**Last updated:** [January 8, 2018, 6:24am UTC](https://discuss.elastic.co/t/pipelines-yml-ignored-on-logstash-running-as-a-service/107828 "2018-01-08T06:24:15Z")

</div>

First, I saw and tried the solution mentioned here and commented out path.config from /etc/logstash/logstash.yml Looks like when I run logstash from command line all works well, but I need the logstash service to run. i…

---

## [Can't load kibana on 5601](https://discuss.elastic.co/t/cant-load-kibana-on-5601/41886)

<div class="topic-metadata">

**Author:** [@babeesh](https://discuss.elastic.co/u/babeesh)\
**Replies:** 9\
**Last updated:** [November 23, 2016, 12:47am UTC](https://discuss.elastic.co/t/cant-load-kibana-on-5601/41886 "2016-11-23T00:47:18Z")

</div>

I have installed Elasticsearch, Logstash, Kibana and Nginx following this guide, https://www.digitalocean.com/community/tutorials/how-to-install-elasticsearch-logstash-and-kibana-elk-stack-on-ubuntu-14-04 Elasticsea…

---

## [Problem converting latitude and longitude into a geo point for Kibana](https://discuss.elastic.co/t/problem-converting-latitude-and-longitude-into-a-geo-point-for-kibana/52856)

<div class="topic-metadata">

**Author:** [@storri](https://discuss.elastic.co/u/storri)\
**Replies:** 14\
**Last updated:** [December 13, 2016, 3:58pm UTC](https://discuss.elastic.co/t/problem-converting-latitude-and-longitude-into-a-geo-point-for-kibana/52856 "2016-12-13T15:58:24Z")

</div>

I am having difficulty getting Logstash (2.2.4) to convert two parsed values, longitude and latitude, into a geo point for Kibana. The documentation for Elasticsearch presents an example for Geo Points where you make som…

---

## [\[solved\] Multiple logstash config file](https://discuss.elastic.co/t/solved-multiple-logstash-config-file/51692)

<div class="topic-metadata">

**Author:** [@Prateek\_Kshtriya](https://discuss.elastic.co/u/Prateek_Kshtriya)\
**Replies:** 9\
**Last updated:** [June 15, 2016, 5:39am UTC](https://discuss.elastic.co/t/solved-multiple-logstash-config-file/51692 "2016-06-15T05:39:10Z")

</div>

Hi All , Please suggest how to use multiple logstash config file at a time on single command line or as a service. Problem Statement- I have multiple logstash config file(As there is differet data configured in each …

---

## [ElasticSearch with SSL?](https://discuss.elastic.co/t/elasticsearch-with-ssl/205278)

<div class="topic-metadata">

**Author:** [@xemyleex](https://discuss.elastic.co/u/xemyleex)\
**Replies:** 11\
**Last updated:** [October 31, 2019, 11:42am UTC](https://discuss.elastic.co/t/elasticsearch-with-ssl/205278 "2019-10-31T11:42:39Z")

</div>

Hello, I am trying to configure elasticsearch with SSL, but I get these error, I followed this tutorial: https://www.elastic.co/guide/en/elasticsearch/reference/current/configuring-tls.html So I created the Certificat…

---

## [Index lifecycle error - illegal\_argument\_exception: index.lifecycle.rollover\_alias](https://discuss.elastic.co/t/index-lifecycle-error-illegal-argument-exception-index-lifecycle-rollover-alias/207900)

<div class="topic-metadata">

**Author:** [@BALA\_BALA](https://discuss.elastic.co/u/BALA_BALA)\
**Replies:** 9\
**Last updated:** [December 12, 2019, 8:16pm UTC](https://discuss.elastic.co/t/index-lifecycle-error-illegal-argument-exception-index-lifecycle-rollover-alias/207900 "2019-12-12T20:16:47Z")

</div>

Hello Team, Could you please help me with sorting out the following error while implementing ILM? Referred link https://www.elastic.co/guide/en/elasticsearch/reference/7.4/getting-started-index-lifecycle-management.ht…

---

## [5.0 - Comparing dates in painless](https://discuss.elastic.co/t/5-0-comparing-dates-in-painless/63943)

<div class="topic-metadata">

**Author:** [@niemyjski](https://discuss.elastic.co/u/niemyjski)\
**Replies:** 19\
**Last updated:** [January 3, 2017, 8:40pm UTC](https://discuss.elastic.co/t/5-0-comparing-dates-in-painless/63943 "2017-01-03T20:40:29Z")

</div>

I'm upgrading from groovy to painless and it's not so painless so far. I wanted to post this here as I think this would be a pretty common scenario and I'm having trouble with dates (gotta love dates). Ideas? PUT /tes…

---

## [Curl: (7) Failed connect to localhost:9200; Connection refused](https://discuss.elastic.co/t/curl-7-failed-connect-to-localhost-9200-connection-refused/88146)

<div class="topic-metadata">

**Author:** [@amilus](https://discuss.elastic.co/u/amilus)\
**Replies:** 14\
**Last updated:** [June 4, 2017, 6:24pm UTC](https://discuss.elastic.co/t/curl-7-failed-connect-to-localhost-9200-connection-refused/88146 "2017-06-04T18:24:08Z")

</div>

Hello i tried to run elasticsearch but it doesn't seem to work a,d i don't know why, i haven't changed anything and it used to work. when i run curl -X GET 'http://localhost:9200' i get the error curl: (7) Failed connec…

---

## [Export to csv/excel from kibana](https://discuss.elastic.co/t/export-to-csv-excel-from-kibana/39237)

<div class="topic-metadata">

**Author:** [@jsp08](https://discuss.elastic.co/u/jsp08)\
**Replies:** 15\
**Last updated:** [May 20, 2021, 9:58am UTC](https://discuss.elastic.co/t/export-to-csv-excel-from-kibana/39237 "2021-05-20T09:58:46Z")

</div>

I have the dashboard with the graphs working without any issue. One of the requirements for my project is the ability to download the file(csv/excel). In kibana the only option i saw for downloading the file is by click…

---

## [2022: The Year in Review](https://discuss.elastic.co/t/2022-the-year-in-review/322272)

<div class="topic-metadata">

**Author:** [@system](https://discuss.elastic.co/u/system)\
**Replies:** 21\
**Last updated:** [January 3, 2023, 9:06am UTC](https://discuss.elastic.co/t/2022-the-year-in-review/322272 "2023-01-03T09:06:23Z")

</div>

2022's Top Users Most Time Reading User Hours Read …

---

## [Ransom attack on Elasticsearch cluster?](https://discuss.elastic.co/t/ransom-attack-on-elasticsearch-cluster/71310)

<div class="topic-metadata">

**Author:** [@Youxu](https://discuss.elastic.co/u/Youxu)\
**Replies:** 24\
**Last updated:** [January 26, 2017, 6:48pm UTC](https://discuss.elastic.co/t/ransom-attack-on-elasticsearch-cluster/71310 "2017-01-26T18:48:47Z")

</div>

Today I found that all indices on our Test ES cluster was removed and one new index "warning" was created there. And I found following text from the raw index data: SEND 0.2 BTC TO THIS WALLET: 1DAsGY4Kt1a4LCTPMH5vm5…

---

## [Kibana:not able to open Kibana page in my web browser](https://discuss.elastic.co/t/kibana-not-able-to-open-kibana-page-in-my-web-browser/37130)

<div class="topic-metadata">

**Author:** [@Lokesh\_Kumar](https://discuss.elastic.co/u/Lokesh_Kumar)\
**Replies:** 20\
**Last updated:** [February 4, 2016, 5:30am UTC](https://discuss.elastic.co/t/kibana-not-able-to-open-kibana-page-in-my-web-browser/37130 "2016-02-04T05:30:24Z")

</div>

Hi, I am not able to open Kibana page in my web browser. Earlier i was able to seen Kibana page in my browser, later i have deleted kibana and logstash service through command "sc delete logstash/kibana" and re-insta…

---

## [Will filebeat handle properly the underlying log file rotation?](https://discuss.elastic.co/t/will-filebeat-handle-properly-the-underlying-log-file-rotation/56119)

<div class="topic-metadata">

**Author:** [@zoplex](https://discuss.elastic.co/u/zoplex)\
**Replies:** 11\
**Last updated:** [July 25, 2016, 4:48pm UTC](https://discuss.elastic.co/t/will-filebeat-handle-properly-the-underlying-log-file-rotation/56119 "2016-07-25T16:48:14Z")

</div>

If filebeat monitors mysqld.log file (MySQL log file) and that file gets rotated out - renamed into mysql.log.1, and new mysqld.log is created - will filebeat continue to read new mysql.d, assuming filebeat.yml has liste…

---

## [Logstash jdbc document\_id =\> "%{uid}" problem](https://discuss.elastic.co/t/logstash-jdbc-document-id-uid-problem/35174)

<div class="topic-metadata">

**Author:** [@Marcin\_Kubica](https://discuss.elastic.co/u/Marcin_Kubica)\
**Replies:** 11\
**Last updated:** [January 21, 2016, 5:59am UTC](https://discuss.elastic.co/t/logstash-jdbc-document-id-uid-problem/35174 "2016-01-21T05:59:19Z")

</div>

Hi Logstash newbie here :smile: Using logstash 2.0.0 and elastic 2.0.0 I'm trying to follow https://www.elastic.co/blog/logstash-jdbc-input-plugin and MySQL driver. I'm setting in config The data is being read ok-i…

---

## [Delete old data from an Index](https://discuss.elastic.co/t/delete-old-data-from-an-index/92412)

<div class="topic-metadata">

**Author:** [@elastic-fan](https://discuss.elastic.co/u/elastic-fan)\
**Replies:** 11\
**Last updated:** [July 10, 2017, 4:42pm UTC](https://discuss.elastic.co/t/delete-old-data-from-an-index/92412 "2017-07-10T16:42:32Z")

</div>

Hello, How can i delete the old data from an index, if i create an index everyday i am facing some problems wrt shards performance , so i have only one index and i would like to delete old data. please let me kno…

---

## [Weird Filebeat init script issue](https://discuss.elastic.co/t/weird-filebeat-init-script-issue/35486)

<div class="topic-metadata">

**Author:** [@jderieg](https://discuss.elastic.co/u/jderieg)\
**Replies:** 38\
**Last updated:** [May 13, 2017, 6:39am UTC](https://discuss.elastic.co/t/weird-filebeat-init-script-issue/35486 "2017-05-13T06:39:09Z")

</div>

I'm trying to get filebeat to install via Saltstack, or even just a remote bash script over ssh, which seems to work great, up until I need to restart the filebeat service. With either method, the script just hangs exec…

---

## [Logstash could not be started because there is already another instance](https://discuss.elastic.co/t/logstash-could-not-be-started-because-there-is-already-another-instance/171306)

<div class="topic-metadata">

**Author:** [@muralasandeep](https://discuss.elastic.co/u/muralasandeep)\
**Replies:** 10\
**Last updated:** [March 13, 2019, 3:44pm UTC](https://discuss.elastic.co/t/logstash-could-not-be-started-because-there-is-already-another-instance/171306 "2019-03-13T15:44:09Z")

</div>

Hi every one , This is Sandeep, i am new at Logstash and i got one error when i run the Logstash confi file that is \[2019-03-07T18:09:12,677\]\[FATAL\]\[logstash.runner \] Logstash could not be started because the…

---

## [How to resolve Dangling indices error on each Index](https://discuss.elastic.co/t/how-to-resolve-dangling-indices-error-on-each-index/130609)

<div class="topic-metadata">

**Author:** [@PinkiMondal](https://discuss.elastic.co/u/PinkiMondal)\
**Replies:** 10\
**Last updated:** [May 9, 2018, 9:56am UTC](https://discuss.elastic.co/t/how-to-resolve-dangling-indices-error-on-each-index/130609 "2018-05-09T09:56:11Z")

</div>

Hi All, I am getting "can not be imported as a dangling index, as index with same name already exists in cluster metadata" message for each index Please help how to resolve it

---

## [Index a new document](https://discuss.elastic.co/t/index-a-new-document/35281)

<div class="topic-metadata">

**Author:** [@gn00342691](https://discuss.elastic.co/u/gn00342691)\
**Replies:** 13\
**Last updated:** [April 4, 2017, 10:30am UTC](https://discuss.elastic.co/t/index-a-new-document/35281 "2017-04-04T10:30:31Z")

</div>

Hi All, I am trying to index a document into the customer index using the below command as suggested in the elasticsearch guide: curl -XPUT localhost:9200/customer/external/1?Gibbon -d '{ "name": "John Doe"}' But we…

---

## [Grok timestamp help](https://discuss.elastic.co/t/grok-timestamp-help/103723)

<div class="topic-metadata">

**Author:** [@pope843](https://discuss.elastic.co/u/pope843)\
**Replies:** 16\
**Last updated:** [October 29, 2017, 11:53pm UTC](https://discuss.elastic.co/t/grok-timestamp-help/103723 "2017-10-29T23:53:05Z")

</div>

Hello, Need help pls, whats the grok format for this kind of timestamp? also i would like to add the current date(e.g YYYY-MM-DD). to it 04:38:30.793UTC My logs is like this. sample log is like this: 05:08:33.351UTC…

---

## [Dashboard error: Could not locate that index-pattern although it exists](https://discuss.elastic.co/t/dashboard-error-could-not-locate-that-index-pattern-although-it-exists/112876)

<div class="topic-metadata">

**Author:** [@andig](https://discuss.elastic.co/u/andig)\
**Replies:** 13\
**Last updated:** [October 14, 2019, 1:26pm UTC](https://discuss.elastic.co/t/dashboard-error-could-not-locate-that-index-pattern-although-it-exists/112876 "2019-10-14T13:26:16Z")

</div>

Running ES 6.0 with Kibana and Metricbeat of the same version I'm getting Could not locate that index-pattern (id: metricbeat-\*), click here to re-create it in the Metricbeat Host dashboard. This only happens for the N…

---

## [How to remove duplicate values in ealstic search](https://discuss.elastic.co/t/how-to-remove-duplicate-values-in-ealstic-search/112226)

<div class="topic-metadata">

**Author:** [@narasiman1986](https://discuss.elastic.co/u/narasiman1986)\
**Replies:** 26\
**Last updated:** [July 26, 2018, 8:00pm UTC](https://discuss.elastic.co/t/how-to-remove-duplicate-values-in-ealstic-search/112226 "2018-07-26T20:00:13Z")

</div>

i am using elastic search 5.6.4 GET /clinicaldata/\_search { "query": { "match" : { "mrdno" : "112627" } } } in that mrdno 112627 have duplicate of 75 records. when run in the above shows ouput as follows { "t…

---

## [Elasticsearch Network Bind for Public & Private](https://discuss.elastic.co/t/elasticsearch-network-bind-for-public-private/83644)

<div class="topic-metadata">

**Author:** [@ninjada](https://discuss.elastic.co/u/ninjada)\
**Replies:** 9\
**Last updated:** [April 27, 2017, 2:56am UTC](https://discuss.elastic.co/t/elasticsearch-network-bind-for-public-private/83644 "2017-04-27T02:56:23Z")

</div>

Hello, I previously had a small ELK version 2.x stack deployment for a staging & qa environment, all 3 services running on a single node. Also had elasticsearch contactable locally by logstash & kibana eg. localhost & …

---

## [Date filter in logstash.conf not parsing the date while grok parses it by timestamp\_iso8601](https://discuss.elastic.co/t/date-filter-in-logstash-conf-not-parsing-the-date-while-grok-parses-it-by-timestamp-iso8601/30104)

<div class="topic-metadata">

**Author:** [@bubu.senapati](https://discuss.elastic.co/u/bubu.senapati)\
**Replies:** 20\
**Last updated:** [March 23, 2017, 1:31pm UTC](https://discuss.elastic.co/t/date-filter-in-logstash-conf-not-parsing-the-date-while-grok-parses-it-by-timestamp-iso8601/30104 "2017-03-23T13:31:23Z")

</div>

I have a date field in a logfile that follows as 2015-09-26 03:45:12:051-0400. I want to parse it which i am successfully able to do by using TIMESTAMP\_ISO8601 grok pattern. But the result is a string field which is succ…

---

## [Failed to process cluster event Exception](https://discuss.elastic.co/t/failed-to-process-cluster-event-exception/103451)

<div class="topic-metadata">

**Author:** [@Pradeep\_Gowda](https://discuss.elastic.co/u/Pradeep_Gowda)\
**Replies:** 31\
**Last updated:** [October 19, 2017, 11:17am UTC](https://discuss.elastic.co/t/failed-to-process-cluster-event-exception/103451 "2017-10-19T11:17:56Z")

</div>

Currently, I am running Elasticsearch in cluster mode and there are 3 nodes. Approximately I have around 15000 indices. Each node has 64GB memory and 16 core CPU. My logs are flooded with below message whenever I try to…

---

## [Create request for last 15 min](https://discuss.elastic.co/t/create-request-for-last-15-min/2650)

<div class="topic-metadata">

**Author:** [@Smasell](https://discuss.elastic.co/u/Smasell)\
**Replies:** 9\
**Last updated:** [June 15, 2015, 3:34pm UTC](https://discuss.elastic.co/t/create-request-for-last-15-min/2650 "2015-06-15T15:34:09Z")

</div>

Hi community!!! I want to create a request that transmits me all the documents for last 15min. Any advice will be highly appreciated!!!

---

## [Logstash won't create index in ES](https://discuss.elastic.co/t/logstash-wont-create-index-in-es/24051)

<div class="topic-metadata">

**Author:** [@bluethundr](https://discuss.elastic.co/u/bluethundr)\
**Replies:** 25\
**Last updated:** [October 20, 2015, 8:28pm UTC](https://discuss.elastic.co/t/logstash-wont-create-index-in-es/24051 "2015-10-20T20:28:23Z")

</div>

Hello, I followed this tutorial from Digial Ocean on how to install an ELK stack on a CentOS 7 machine. Digital Ocean ELK Setup It seemed pretty good, and got me as far as having an initial Elastic Search node wo…

---

## [Filebeat is not shipping the log data to Elasticsearch](https://discuss.elastic.co/t/filebeat-is-not-shipping-the-log-data-to-elasticsearch/120690)

<div class="topic-metadata">

**Author:** [@t.d.garland100](https://discuss.elastic.co/u/t.d.garland100)\
**Replies:** 18\
**Last updated:** [March 13, 2018, 3:28pm UTC](https://discuss.elastic.co/t/filebeat-is-not-shipping-the-log-data-to-elasticsearch/120690 "2018-03-13T15:28:56Z")

</div>

I am following the use case for Machine Learning for Elastic Stack found at the link below: Suspicious Login Activity My system: Ubuntu 16.04, Elastic Stack 5.6.7 (Elasticsearch, Kibana and Filebeat) with X-Pack and I…

---

## [Localhost:9200 - Can’t reach this page](https://discuss.elastic.co/t/localhost-9200-can-t-reach-this-page/171199)

<div class="topic-metadata">

**Author:** [@gpadvorac](https://discuss.elastic.co/u/gpadvorac)\
**Replies:** 18\
**Last updated:** [March 14, 2019, 3:52am UTC](https://discuss.elastic.co/t/localhost-9200-can-t-reach-this-page/171199 "2019-03-14T03:52:51Z")

</div>

I'm new to Elasticsearch and just installed it on my dev pc. after the installation I tried to open it but get the following error: Can’t reach this page •Make sure the web address http://localhost:9200 is correct I …

---

## [How to download data from an elasticsearch index](https://discuss.elastic.co/t/how-to-download-data-from-an-elasticsearch-index/269354)

<div class="topic-metadata">

**Author:** [@Juan\_David\_Jaramillo](https://discuss.elastic.co/u/Juan_David_Jaramillo)\
**Replies:** 12\
**Last updated:** [April 16, 2021, 8:29pm UTC](https://discuss.elastic.co/t/how-to-download-data-from-an-elasticsearch-index/269354 "2021-04-16T20:29:12Z")

</div>

Hi, guy's How can i download all the data of an index in elasticsearch? it downloads the CSV but it does not show all the data, I need to download the whole index, please help me?

---

## [Elasticsearch 7, 3 nodes cluster setup, 1 failed to join](https://discuss.elastic.co/t/elasticsearch-7-3-nodes-cluster-setup-1-failed-to-join/179296)

<div class="topic-metadata">

**Author:** [@rozzaaq](https://discuss.elastic.co/u/rozzaaq)\
**Replies:** 13\
**Last updated:** [May 31, 2019, 8:43am UTC](https://discuss.elastic.co/t/elasticsearch-7-3-nodes-cluster-setup-1-failed-to-join/179296 "2019-05-31T08:43:08Z")

</div>

I tried to configure a cluster with 3 nodes on GCP. 2 nodes join the same cluster (same UUID), 1 nodes fail to join. Here's my nodes configuration: cluster.name: rdy-elastic node.name: rdy-elastic2 network…

---

## [How to correctly use local JSON for Vega and Kibana?](https://discuss.elastic.co/t/how-to-correctly-use-local-json-for-vega-and-kibana/120253)

<div class="topic-metadata">

**Author:** [@Koen\_Wouters](https://discuss.elastic.co/u/Koen_Wouters)\
**Replies:** 19\
**Last updated:** [February 23, 2018, 12:05am UTC](https://discuss.elastic.co/t/how-to-correctly-use-local-json-for-vega-and-kibana/120253 "2018-02-23T00:05:40Z")

</div>

HI, I'm experimenting a bit with the new Vega plugin for 6.2, but while it works pretty fine with external JSON files it fails when I try to achieve the same with a local stored JSON file. I've tried with the treemap de…

---

## [Exception in thread "main" java.nio.file.AccessDeniedException](https://discuss.elastic.co/t/exception-in-thread-main-java-nio-file-accessdeniedexception/165497)

<div class="topic-metadata">

**Author:** [@sahil\_ahmed](https://discuss.elastic.co/u/sahil_ahmed)\
**Replies:** 17\
**Last updated:** [February 17, 2019, 2:40pm UTC](https://discuss.elastic.co/t/exception-in-thread-main-java-nio-file-accessdeniedexception/165497 "2019-02-17T14:40:57Z")

</div>

I get this error when i tried to run elasticsearch. Exception in thread "main" java.nio.file.AccessDeniedException: /home/supportdev/elasticsearch-6.5.4/config/jvm.options at sun.nio.fs.UnixException.translateToIOExcep…

---

## [Kibana 4.1 metric visualization round decimal value](https://discuss.elastic.co/t/kibana-4-1-metric-visualization-round-decimal-value/24098)

<div class="topic-metadata">

**Author:** [@rajeshchinnam1985](https://discuss.elastic.co/u/rajeshchinnam1985)\
**Replies:** 22\
**Last updated:** [May 5, 2020, 10:23pm UTC](https://discuss.elastic.co/t/kibana-4-1-metric-visualization-round-decimal-value/24098 "2020-05-05T22:23:19Z")

</div>

Thanks in advance.. I am using kibana 4.1 and trying to create a metric visualization which returning me a value of 135.649 how can I round off this value 135.65 How can I do this

---

## [Elasticsearch cluster of 4 nodes has "master not discovered exception"](https://discuss.elastic.co/t/elasticsearch-cluster-of-4-nodes-has-master-not-discovered-exception/124984)

<div class="topic-metadata">

**Author:** [@minidan](https://discuss.elastic.co/u/minidan)\
**Replies:** 17\
**Last updated:** [April 20, 2018, 9:38am UTC](https://discuss.elastic.co/t/elasticsearch-cluster-of-4-nodes-has-master-not-discovered-exception/124984 "2018-04-20T09:38:37Z")

</div>

Hi, I had an error last week, seemed to be RAM in Java that parked my install on the first node (where Kibana role was installed). Ever since then I cannot get the cluster back operational. When it is all restarted, al…

---

## [Kibana xpack missing authentication token for REST request](https://discuss.elastic.co/t/kibana-xpack-missing-authentication-token-for-rest-request/101238)

<div class="topic-metadata">

**Author:** [@lask001](https://discuss.elastic.co/u/lask001)\
**Replies:** 10\
**Last updated:** [September 22, 2017, 5:00pm UTC](https://discuss.elastic.co/t/kibana-xpack-missing-authentication-token-for-rest-request/101238 "2017-09-22T17:00:39Z")

</div>

I'm getting peppered with this message pretty much non-stop and haven't been able to figure out what's causing my issue, could someone point me in the right direction? I believe this is causing my overall problem, which …

---

## [Conflicts with existing mapping](https://discuss.elastic.co/t/conflicts-with-existing-mapping/119727)

<div class="topic-metadata">

**Author:** [@aneesh](https://discuss.elastic.co/u/aneesh)\
**Replies:** 23\
**Last updated:** [February 16, 2018, 9:38am UTC](https://discuss.elastic.co/t/conflicts-with-existing-mapping/119727 "2018-02-16T09:38:06Z")

</div>

Hi while doing PutMappuing i am getting following error "Mapper for \[uUserId\] conflicts with existing mapping in other types:\\n\[mapper \[uUserId\] has different \[analyzer\], mapper \[uUserId\] is used by multiple types. Set…

---

## [How to search non indexed field in elasticsearch](https://discuss.elastic.co/t/how-to-search-non-indexed-field-in-elasticsearch/20594)

<div class="topic-metadata">

**Author:** [@Ramky](https://discuss.elastic.co/u/Ramky)\
**Replies:** 9\
**Last updated:** [November 11, 2014, 4:42am UTC](https://discuss.elastic.co/t/how-to-search-non-indexed-field-in-elasticsearch/20594 "2014-11-11T04:42:33Z")

</div>

I have 10 fields inserted into elasticsearch out of which 5 fields are indexed. Is it possible to search on non indexed field? Thanks in advance. Regards Rama Krishna P -- You received this message becau…

---

## [Import CSV File as input in logstash and the output data to elasticsearch](https://discuss.elastic.co/t/import-csv-file-as-input-in-logstash-and-the-output-data-to-elasticsearch/82873)

<div class="topic-metadata">

**Author:** [@zegdene](https://discuss.elastic.co/u/zegdene)\
**Replies:** 9\
**Last updated:** [April 21, 2017, 5:21am UTC](https://discuss.elastic.co/t/import-csv-file-as-input-in-logstash-and-the-output-data-to-elasticsearch/82873 "2017-04-21T05:21:45Z")

</div>

Hi, I'm new in elasticsearch, i install elasticsearch, logstash and kibana, i need to import a CSV file as input in logstash and pass the outuput data to elasticsearch, I create the index in elasticsearch , in kibana i…

---

## [Elasticsearch output - index name pattern](https://discuss.elastic.co/t/elasticsearch-output-index-name-pattern/36428)

<div class="topic-metadata">

**Author:** [@zombie101](https://discuss.elastic.co/u/zombie101)\
**Replies:** 9\
**Last updated:** [January 11, 2017, 4:34am UTC](https://discuss.elastic.co/t/elasticsearch-output-index-name-pattern/36428 "2017-01-11T04:34:22Z")

</div>

The elasticsearch output takes a setting for the index name, with a default of 'logstash-YYYY.MM.dd'. Where does the 'YYYY.MM.dd' come from? Are there other options, such as time (e.g. HHmmss), week of year, day of yea…

---

## [Location \[\*\*\*\*\] doesn't match any of the locations specified by path.repo because this setting is empty](https://discuss.elastic.co/t/location-doesnt-match-any-of-the-locations-specified-by-path-repo-because-this-setting-is-empty/38579)

<div class="topic-metadata">

**Author:** [@marcmga](https://discuss.elastic.co/u/marcmga)\
**Replies:** 14\
**Last updated:** [January 8, 2016, 12:38pm UTC](https://discuss.elastic.co/t/location-doesnt-match-any-of-the-locations-specified-by-path-repo-because-this-setting-is-empty/38579 "2016-01-08T12:38:33Z")

</div>

Hello there, I'm trying to make backups of nodes in my elasticsearch. I've folowed Snapshot module | Elasticsearch Guide \[8.11\] | Elastic However, i'm not able to make it works, it seems to be a problem with repo.path …

---

## [ELK curl: (7) Failed to connect to localhost port 9200: Connection refused](https://discuss.elastic.co/t/elk-curl-7-failed-to-connect-to-localhost-port-9200-connection-refused/184500)

<div class="topic-metadata">

**Author:** [@Yuna\_YU](https://discuss.elastic.co/u/Yuna_YU)\
**Replies:** 14\
**Last updated:** [June 6, 2019, 7:44am UTC](https://discuss.elastic.co/t/elk-curl-7-failed-to-connect-to-localhost-port-9200-connection-refused/184500 "2019-06-06T07:44:56Z")

</div>

Hi There, I met some problem while installing elk on 3 different server on Google cloud Platform. First, I build 2 servers based on Debian GNU/Linux 9 (stretch), after installing elasticsearch and kibana respectively, …

---

## [Logstash json parse error](https://discuss.elastic.co/t/logstash-json-parse-error/74000)

<div class="topic-metadata">

**Author:** [@mattgolding](https://discuss.elastic.co/u/mattgolding)\
**Replies:** 15\
**Last updated:** [February 13, 2017, 11:14pm UTC](https://discuss.elastic.co/t/logstash-json-parse-error/74000 "2017-02-13T23:14:55Z")

</div>

I have a problem trying to parse a log file with backslashes in it. I have tried a number of escape options using the gsub() method although without any luck. I am not a ruby coder so its possible i am doing something …

---

## [Elasticsearch - Binding to Public IP](https://discuss.elastic.co/t/elasticsearch-binding-to-public-ip/45668)

<div class="topic-metadata">

**Author:** [@Sameer\_Dharur](https://discuss.elastic.co/u/Sameer_Dharur)\
**Replies:** 12\
**Last updated:** [March 29, 2016, 3:24pm UTC](https://discuss.elastic.co/t/elasticsearch-binding-to-public-ip/45668 "2016-03-29T15:24:08Z")

</div>

Hello! I wish to make the Elasticsearch running on my localhost open to public access (within my college). Therefore I wish to bind it to an IP address of my choice. However, I followed the instructions on this link ht…

---

## [Elasticsearch stopped working](https://discuss.elastic.co/t/elasticsearch-stopped-working/128501)

<div class="topic-metadata">

**Author:** [@rahulnama](https://discuss.elastic.co/u/rahulnama)\
**Replies:** 13\
**Last updated:** [April 20, 2018, 6:38am UTC](https://discuss.elastic.co/t/elasticsearch-stopped-working/128501 "2018-04-20T06:38:34Z")

</div>

Hello Team Unfortunately, my elasticsearch stopped working. and I'm not sure what to do. Please have a look at my logs org.elasticsearch.action.NoShardAvailableActionException: No shard available for \[get \[.kibana\]\[doc…

---

## [Exception caught on transport layer (es6.4.2)](https://discuss.elastic.co/t/exception-caught-on-transport-layer-es6-4-2/163924)

<div class="topic-metadata">

**Author:** [@aparent](https://discuss.elastic.co/u/aparent)\
**Replies:** 45\
**Last updated:** [January 17, 2019, 10:59am UTC](https://discuss.elastic.co/t/exception-caught-on-transport-layer-es6-4-2/163924 "2019-01-17T10:59:33Z")

</div>

Hi ! I'm trying to reach a cluster (ES6.4.2) with SSl enabled. I'm using the java low-level API and the TransportClient. I can read/write on the cluster when SSL is disabled, but not when it is on. I don't know which…

---

## [How to delete elasticsearch logs?](https://discuss.elastic.co/t/how-to-delete-elasticsearch-logs/301666)

<div class="topic-metadata">

**Author:** [@danielbsilva2](https://discuss.elastic.co/u/danielbsilva2)\
**Replies:** 16\
**Last updated:** [April 6, 2022, 8:02pm UTC](https://discuss.elastic.co/t/how-to-delete-elasticsearch-logs/301666 "2022-04-06T20:02:29Z")

</div>

good afternoon folks how do i delete my indexes in Elasticsearch? I need to delete the logs generated in Elasticsearch from an application I have here and leave the logs from the last 3 days, I've looked here on the fo…

---

## [Filtering in Kibana](https://discuss.elastic.co/t/filtering-in-kibana/73005)

<div class="topic-metadata">

**Author:** [@OucemaBellagha](https://discuss.elastic.co/u/OucemaBellagha)\
**Replies:** 13\
**Last updated:** [January 31, 2017, 9:42am UTC](https://discuss.elastic.co/t/filtering-in-kibana/73005 "2017-01-31T09:42:29Z")

</div>

Hi folks, I'm having a weird filtering result with Kibana, so I want to filter my output using NOT messsage: ABC which shows nothing. But when I do the opposite way messsage: ABC kibana shows the output of messages c…

---

## [Elastic Cloud Kibana Index Lifecycle Policies is not working](https://discuss.elastic.co/t/elastic-cloud-kibana-index-lifecycle-policies-is-not-working/178232)

<div class="topic-metadata">

**Author:** [@Robin\_Guo](https://discuss.elastic.co/u/Robin_Guo)\
**Replies:** 11\
**Last updated:** [April 24, 2019, 5:51pm UTC](https://discuss.elastic.co/t/elastic-cloud-kibana-index-lifecycle-policies-is-not-working/178232 "2019-04-24T17:51:41Z")

</div>

Dear Elastic team members， Today I did an Index Lifecycle policies on index metricbeat-2019 on Kibana. But it's not working. Before I posted the issue here, I want to talk about a little bit of backgrounds of use case…

---

## [KQL to filter for documents where a field exists and its value is less than a fixed number?](https://discuss.elastic.co/t/kql-to-filter-for-documents-where-a-field-exists-and-its-value-is-less-than-a-fixed-number/262385)

<div class="topic-metadata">

**Author:** [@GrahamHannington](https://discuss.elastic.co/u/GrahamHannington)\
**Replies:** 20\
**Last updated:** [February 5, 2021, 9:45pm UTC](https://discuss.elastic.co/t/kql-to-filter-for-documents-where-a-field-exists-and-its-value-is-less-than-a-fixed-number/262385 "2021-02-05T21:45:16Z")

</div>

In Kibana 7.7.1, is it possible to specify a KQL filter that selects only the documents where both of the following conditions are true: Field XYZ exists The value of field XYZ (the same field) is less than some fixed …

[Previous page](https://discuss.elastic.co/top.md?page=3&per_page=50&period=all)

[Next page](https://discuss.elastic.co/top.md?page=5&per_page=50&period=all)
