# Top

**URL:** https://discuss.elastic.co/top.md?page=48&period=all

[Latest](https://discuss.elastic.co/latest.md) · [Categories](https://discuss.elastic.co/categories.md) · [Tags](https://discuss.elastic.co/tags.md)

**Page:** 49

---

## [Exist Elasticsearch ingest pipeline if specific field exists](https://discuss.elastic.co/t/exist-elasticsearch-ingest-pipeline-if-specific-field-exists/298563)

<div class="topic-metadata">

**Author:** [@DougR](https://discuss.elastic.co/u/DougR)\
**Replies:** 12\
**Last updated:** [March 2, 2022, 2:30pm UTC](https://discuss.elastic.co/t/exist-elasticsearch-ingest-pipeline-if-specific-field-exists/298563 "2022-03-02T14:30:22Z")

</div>

In an Elasticsearch Ingest Pipeline, how can I validate whether a specific field exists, and exit the pipeline immediately without processing if it does?

---

## [Logstash convert Nil values into a number](https://discuss.elastic.co/t/logstash-convert-nil-values-into-a-number/104271)

<div class="topic-metadata">

**Author:** [@Pinheiro](https://discuss.elastic.co/u/Pinheiro)\
**Replies:** 10\
**Last updated:** [October 20, 2017, 8:46am UTC](https://discuss.elastic.co/t/logstash-convert-nil-values-into-a-number/104271 "2017-10-20T08:46:11Z")

</div>

Hello everyone, I'm trying to find the fields that are empty and change them for a value. I want to do something like the next expression, but Logstash can not find the nil value. Does anyone have a suggestion for find…

---

## [How to reset password user elastic](https://discuss.elastic.co/t/how-to-reset-password-user-elastic/324735)

<div class="topic-metadata">

**Author:** [@gugurigon](https://discuss.elastic.co/u/gugurigon)\
**Replies:** 10\
**Last updated:** [February 7, 2023, 5:21am UTC](https://discuss.elastic.co/t/how-to-reset-password-user-elastic/324735 "2023-02-07T05:21:23Z")

</div>

I can't access the elasticsearch to retrieve the information of the cluster. The elasticsearch is run on docker with version 7.x.

---

## [Stuck in loading Kibana...!](https://discuss.elastic.co/t/stuck-in-loading-kibana/247875)

<div class="topic-metadata">

**Author:** [@Farid\_N](https://discuss.elastic.co/u/Farid_N)\
**Replies:** 15\
**Last updated:** [September 29, 2020, 9:51am UTC](https://discuss.elastic.co/t/stuck-in-loading-kibana/247875 "2020-09-29T09:51:59Z")

</div>

Hello When I start the Kibana service (bin/kibana) it stuck somewhere which the last line is: \[warning\]\[plugins\]\[reporting\] Enabling the Chromium sandbox provides an additional layer of protection. And also I can\`t ac…

---

## [Elasticsearch snapshot repository fails validation](https://discuss.elastic.co/t/elasticsearch-snapshot-repository-fails-validation/279638)

<div class="topic-metadata">

**Author:** [@amfournda](https://discuss.elastic.co/u/amfournda)\
**Replies:** 24\
**Last updated:** [July 27, 2021, 8:07pm UTC](https://discuss.elastic.co/t/elasticsearch-snapshot-repository-fails-validation/279638 "2021-07-27T20:07:53Z")

</div>

I have a three node Elasticsearch cluster with a shared NFS volume. I have set a path.repo value in elasticsearch.yml and restarted elasticsearch (one node at a time, my cluster needs to stay up). I have confirmed all th…

---

## [Dev tools error](https://discuss.elastic.co/t/dev-tools-error/124484)

<div class="topic-metadata">

**Author:** [@Kamal\_Raj](https://discuss.elastic.co/u/Kamal_Raj)\
**Replies:** 17\
**Last updated:** [March 20, 2018, 1:38pm UTC](https://discuss.elastic.co/t/dev-tools-error/124484 "2018-03-20T13:38:24Z")

</div>

When trying to execute GET /\_search { "query": { "match\_all": {} } } Getting error Failed to connect to Console's backend. Please check the Kibana server is up and running Confirmed that my Kibana server is up …

---

## [Logstash Logging setting to output rubydebug info for running service](https://discuss.elastic.co/t/logstash-logging-setting-to-output-rubydebug-info-for-running-service/288435)

<div class="topic-metadata">

**Author:** [@teebu](https://discuss.elastic.co/u/teebu)\
**Replies:** 11\
**Last updated:** [November 5, 2021, 2:23am UTC](https://discuss.elastic.co/t/logstash-logging-setting-to-output-rubydebug-info-for-running-service/288435 "2021-11-05T02:23:28Z")

</div>

I'm using the default settings. When I run LS as a service, the logging in the plain.log file doesn't have any of the rubydebug output. When I run it with the -f flag, I see all the output normally. What setting file d…

---

## [Kibana 6.2.3 Restarts Constantly](https://discuss.elastic.co/t/kibana-6-2-3-restarts-constantly/129172)

<div class="topic-metadata">

**Author:** [@rcoundon](https://discuss.elastic.co/u/rcoundon)\
**Replies:** 22\
**Last updated:** [April 25, 2018, 7:17am UTC](https://discuss.elastic.co/t/kibana-6-2-3-restarts-constantly/129172 "2018-04-25T07:17:06Z")

</div>

I have ElasticSearch and Kibana 6.2.3 installed on Ubuntu 16.04 ElasticSearch is working, I can see my indexes and data via the ReST API. When I try to start Kibana as a service I get the following entry repeated (with…

---

## [Unable to start packetbeat](https://discuss.elastic.co/t/unable-to-start-packetbeat/25676)

<div class="topic-metadata">

**Author:** [@Pradeep\_Gowda](https://discuss.elastic.co/u/Pradeep_Gowda)\
**Replies:** 15\
**Last updated:** [September 15, 2015, 2:53pm UTC](https://discuss.elastic.co/t/unable-to-start-packetbeat/25676 "2015-09-15T14:53:45Z")

</div>

I am unable to start packetbeat and getting below error /packetbeat: error while loading shared libraries: libpcap.so.0.8: cannot open shared object file: No such file or directory but I am using different version of…

---

## [Logstash failing with "ERROR::EMFILE- Too many open files"](https://discuss.elastic.co/t/logstash-failing-with-error-emfile-too-many-open-files/190715)

<div class="topic-metadata">

**Author:** [@Laddu\_ps](https://discuss.elastic.co/u/Laddu_ps)\
**Replies:** 15\
**Last updated:** [August 8, 2019, 5:39am UTC](https://discuss.elastic.co/t/logstash-failing-with-error-emfile-too-many-open-files/190715 "2019-08-08T05:39:31Z")

</div>

Hi. I'm having issues running logstash withi large sets of data. I'm trying to push data to Elasticsearch via Logstash Where both the applications are hosted on CENTOS servers. I'm trying to send 1000 files per minute (e…

---

## [PKI authentication in logstash Elastic Search Output not working](https://discuss.elastic.co/t/pki-authentication-in-logstash-elastic-search-output-not-working/32738)

<div class="topic-metadata">

**Author:** [@soodlikesjava](https://discuss.elastic.co/u/soodlikesjava)\
**Replies:** 21\
**Last updated:** [November 23, 2015, 8:06pm UTC](https://discuss.elastic.co/t/pki-authentication-in-logstash-elastic-search-output-not-working/32738 "2015-11-23T20:06:31Z")

</div>

Hi all, I am trying to achieve PKI auth in Logstash elastic search output plugin using shield trail license .Below are my configs Logstash : output { elasticsearch { cluster =\> "abc" …

---

## [Kibana server is not ready yet](https://discuss.elastic.co/t/kibana-server-is-not-ready-yet/351607)

<div class="topic-metadata">

**Author:** [@rash4ford](https://discuss.elastic.co/u/rash4ford)\
**Replies:** 9\
**Last updated:** [March 5, 2024, 8:20am UTC](https://discuss.elastic.co/t/kibana-server-is-not-ready-yet/351607 "2024-03-05T08:20:05Z")

</div>

I'm new to Elasticsearch and i'm having issue try to get your elastic searc working. I'm getting Kibana server is not ready yet. I have checked services on both kibana and Elasticsearch working fine. I have colect the l…

---

## [How to send windows 2012 r2 log file to logstash](https://discuss.elastic.co/t/how-to-send-windows-2012-r2-log-file-to-logstash/28708)

<div class="topic-metadata">

**Author:** [@Kaufusihm](https://discuss.elastic.co/u/Kaufusihm)\
**Replies:** 17\
**Last updated:** [September 14, 2015, 10:09pm UTC](https://discuss.elastic.co/t/how-to-send-windows-2012-r2-log-file-to-logstash/28708 "2015-09-14T22:09:13Z")

</div>

I currently have a logstash server, Elasticsearch server, and kibana server. I am able to send logstash local data using stdin from LS to my ES instance and I can interact with Kibana, but now I am trying to use a window…

---

## [Agent "Unhealthy". "Error while dialing open \\\\\\.\\\\pipe\\\\elastic-agent-\[...\]"](https://discuss.elastic.co/t/agent-unhealthy-error-while-dialing-open-pipe-elastic-agent/285814)

<div class="topic-metadata">

**Author:** [@maof97](https://discuss.elastic.co/u/maof97)\
**Replies:** 9\
**Last updated:** [November 4, 2021, 9:30pm UTC](https://discuss.elastic.co/t/agent-unhealthy-error-while-dialing-open-pipe-elastic-agent/285814 "2021-11-04T21:30:51Z")

</div>

I've upgraded ELK to 7.15 and had some errors starting up Kibana so I made the mistake to delete the .kibana index (someone wrote it somewhere). So at the end I had to basically set up everything new. Now I have also up…

---

## [Distinct search using Java API](https://discuss.elastic.co/t/distinct-search-using-java-api/272978)

<div class="topic-metadata">

**Author:** [@MinwooKim](https://discuss.elastic.co/u/MinwooKim)\
**Replies:** 22\
**Last updated:** [May 21, 2021, 9:07am UTC](https://discuss.elastic.co/t/distinct-search-using-java-api/272978 "2021-05-21T09:07:09Z")

</div>

Inquiry with Java API. Is there any method to configure a search for distinct data? SearchSourceBuilder searchSourceBuilder = new SearchSourceBuilder(); BoolQueryBuilder queryBuilder = QueryBuilders.boolQuery()…

---

## [Logstash 2.2.0 throughput slower than 2.1.1](https://discuss.elastic.co/t/logstash-2-2-0-throughput-slower-than-2-1-1/41650)

<div class="topic-metadata">

**Author:** [@tinle](https://discuss.elastic.co/u/tinle)\
**Replies:** 18\
**Last updated:** [March 8, 2016, 9:14pm UTC](https://discuss.elastic.co/t/logstash-2-2-0-throughput-slower-than-2-1-1/41650 "2016-03-08T21:14:05Z")

</div>

I wonder if anyone notices similar problem. I tested updating from 2.1.1 to 2.2.0 and immediate get these warnings in the logs {:timestamp=\>"2016-02-12T01:14:13.718000+0000", :message=\>"retrying failed action with re…

---

## [Need help with searching text with special characters](https://discuss.elastic.co/t/need-help-with-searching-text-with-special-characters/223172)

<div class="topic-metadata">

**Author:** [@Lisahtwy](https://discuss.elastic.co/u/Lisahtwy)\
**Replies:** 10\
**Last updated:** [March 26, 2020, 3:02pm UTC](https://discuss.elastic.co/t/need-help-with-searching-text-with-special-characters/223172 "2020-03-26T15:02:30Z")

</div>

Hi, I have created index for my files in a server using FsCrawler and using elastcsearch\_dsl&python program to match query. It is working fine for any text / numbers. But I need to search text with special characters s…

---

## [Logstash to elastic output SSL](https://discuss.elastic.co/t/logstash-to-elastic-output-ssl/116703)

<div class="topic-metadata">

**Author:** [@elasticus](https://discuss.elastic.co/u/elasticus)\
**Replies:** 10\
**Last updated:** [January 24, 2018, 10:26pm UTC](https://discuss.elastic.co/t/logstash-to-elastic-output-ssl/116703 "2018-01-24T22:26:57Z")

</div>

I have configured SSL for all ELASTIC cluster nodes Blowed if I can find any reliable information regarding how to subsequently configure the logstash output plugin once I restart my ES cluster with ssl enabled. I 'thi…

---

## [Elasticsearch high latency](https://discuss.elastic.co/t/elasticsearch-high-latency/328911)

<div class="topic-metadata">

**Author:** [@jaykb77](https://discuss.elastic.co/u/jaykb77)\
**Replies:** 15\
**Last updated:** [May 11, 2023, 7:49am UTC](https://discuss.elastic.co/t/elasticsearch-high-latency/328911 "2023-05-11T07:49:47Z")

</div>

Hi all, We noticed some high request latency for searches on our elasticsearch cluster(7.17) and while checking the metrics, it was seen that there was spike in search\_fetch\_time for many indices which were configured 1…

---

## [Fatal Error after upgrading from 5.4.2 to 5.5.0](https://discuss.elastic.co/t/fatal-error-after-upgrading-from-5-4-2-to-5-5-0/92351)

<div class="topic-metadata">

**Author:** [@smlbiobot](https://discuss.elastic.co/u/smlbiobot)\
**Replies:** 18\
**Last updated:** [July 25, 2017, 1:28am UTC](https://discuss.elastic.co/t/fatal-error-after-upgrading-from-5-4-2-to-5-5-0/92351 "2017-07-25T01:28:37Z")

</div>

After upgrading from 5.4.2 to 5.5.0, I have received a fatal error when pointing browser to http://localhost:5901 What could be the cause of this and how would I fix this? Uncaught TypeError: Cannot read property 're…

---

## [Index cleanup](https://discuss.elastic.co/t/index-cleanup/215476)

<div class="topic-metadata">

**Author:** [@andymcinnes](https://discuss.elastic.co/u/andymcinnes)\
**Replies:** 19\
**Last updated:** [January 30, 2020, 5:28pm UTC](https://discuss.elastic.co/t/index-cleanup/215476 "2020-01-30T17:28:55Z")

</div>

Hi, I've got Serilog pumping logs in to elastic search from various applications, using the Serilog ElasticSearch Sink. I use a daily indexing pattern per environment and serilog manages the initial creation of these in…

---

## [Anyone tried installing beats with managed AWS ES?](https://discuss.elastic.co/t/anyone-tried-installing-beats-with-managed-aws-es/43146)

<div class="topic-metadata">

**Author:** [@piyush](https://discuss.elastic.co/u/piyush)\
**Replies:** 10\
**Last updated:** [August 24, 2016, 2:33pm UTC](https://discuss.elastic.co/t/anyone-tried-installing-beats-with-managed-aws-es/43146 "2016-08-24T14:33:15Z")

</div>

Filebeat & Topbeat are getting connection error while trying to connect AWS ES. The logs says, it's adding port (9200) to the host address whereas managed ES endpoint doesn't have a port.

---

## [How to stop duplicate entries using elasticsearch plugin](https://discuss.elastic.co/t/how-to-stop-duplicate-entries-using-elasticsearch-plugin/87880)

<div class="topic-metadata">

**Author:** [@Matthew\_Byrne](https://discuss.elastic.co/u/Matthew_Byrne)\
**Replies:** 9\
**Last updated:** [June 1, 2017, 1:44pm UTC](https://discuss.elastic.co/t/how-to-stop-duplicate-entries-using-elasticsearch-plugin/87880 "2017-06-01T13:44:00Z")

</div>

Morning all. Im trying to use the elasticsearch plugin to pull data from an existing elasticsearch instance. Both are running older versions of Elasticsearch, and thus im running an older version of logstash (1.5). I've …

---

## [How to setup a single node cluster for Elasticsearch 8.3 on Windows 10 on a laptop?](https://discuss.elastic.co/t/how-to-setup-a-single-node-cluster-for-elasticsearch-8-3-on-windows-10-on-a-laptop/312530)

<div class="topic-metadata">

**Author:** [@JamesD\_7](https://discuss.elastic.co/u/JamesD_7)\
**Replies:** 13\
**Last updated:** [August 25, 2022, 12:54am UTC](https://discuss.elastic.co/t/how-to-setup-a-single-node-cluster-for-elasticsearch-8-3-on-windows-10-on-a-laptop/312530 "2022-08-25T00:54:07Z")

</div>

Hello All, I downloaded Elasticsearch 8.3 and Kibana 8.3 and I've run into lots of questions and issues about setting up a simple configuration to read a small CSV file. After running into some errors I started chang…

---

## [Instant crash on startup](https://discuss.elastic.co/t/instant-crash-on-startup/6273)

<div class="topic-metadata">

**Author:** [@mrblue](https://discuss.elastic.co/u/mrblue)\
**Replies:** 14\
**Last updated:** [July 4, 2012, 6:15pm UTC](https://discuss.elastic.co/t/instant-crash-on-startup/6273 "2012-07-04T18:15:33Z")

</div>

Hi, when i try to start elasticsearch on my managed server, it goes like this: \[2012-01-03 18:59:25,364\]\[INFO \]\[node \] \[Tom Thumb\] {0.18.6}\[23920\]: initializing ... \[2012-01-03 18:59:25,373…

---

## [Elasticsearch Java exception. Kibana Unable to fetch mapping. Do you have indices matching the pattern](https://discuss.elastic.co/t/elasticsearch-java-exception-kibana-unable-to-fetch-mapping-do-you-have-indices-matching-the-pattern/33478)

<div class="topic-metadata">

**Author:** [@pradeepreddy3](https://discuss.elastic.co/u/pradeepreddy3)\
**Replies:** 13\
**Last updated:** [August 23, 2016, 8:22am UTC](https://discuss.elastic.co/t/elasticsearch-java-exception-kibana-unable-to-fetch-mapping-do-you-have-indices-matching-the-pattern/33478 "2016-08-23T08:22:12Z")

</div>

I have setup with Kibana 2.0.0 Logstash 2.0.0, ElasticSearch 2.0.0 and logstash-forwarder 0.4.0. I don't see any error messages for Logstash-forwarder, Logstash, Kibana. On Kibana UI I see message as "Unable t…

---

## [Cannot Start kibana](https://discuss.elastic.co/t/cannot-start-kibana/57517)

<div class="topic-metadata">

**Author:** [@sv2c](https://discuss.elastic.co/u/sv2c)\
**Replies:** 24\
**Last updated:** [August 11, 2016, 3:32pm UTC](https://discuss.elastic.co/t/cannot-start-kibana/57517 "2016-08-11T15:32:23Z")

</div>

Elasticsearch: 1.7.4 Kibana: 4.1.0 kibana {"name":"Kibana","hostname":"Goble004","pid":10872,"level":50,"err":{"message":"Request Timeout after 5000ms","name":"Error","stack":"Error: Request Timeout after 5000ms\\n …

---

## [Node Discovery in elasticsearch on amazon EC2](https://discuss.elastic.co/t/node-discovery-in-elasticsearch-on-amazon-ec2/36490)

<div class="topic-metadata">

**Author:** [@siddharth\_gupta](https://discuss.elastic.co/u/siddharth_gupta)\
**Replies:** 16\
**Last updated:** [February 20, 2016, 2:47pm UTC](https://discuss.elastic.co/t/node-discovery-in-elasticsearch-on-amazon-ec2/36490 "2016-02-20T14:47:01Z")

</div>

Hello, I was using elastic search 1.7.0 on amzon EC2 and everything was working fine. The nodes were able to discover each other and joined together. But when I switched to elasticsearch 2.1.0 things have been diff…

---

## [ES rejecting bulk messages when writing to indices with 40 shards](https://discuss.elastic.co/t/es-rejecting-bulk-messages-when-writing-to-indices-with-40-shards/169234)

<div class="topic-metadata">

**Author:** [@antcas](https://discuss.elastic.co/u/antcas)\
**Replies:** 11\
**Last updated:** [February 22, 2019, 10:41am UTC](https://discuss.elastic.co/t/es-rejecting-bulk-messages-when-writing-to-indices-with-40-shards/169234 "2019-02-22T10:41:44Z")

</div>

Hi all. tl;dr: We had a weird issue in our ES cluster (v6.5.1) this week: bulk messages were being rejected when ES was writing to an index with 40 shards, and the problem was solved by creating a new index with only 5…

---

## [Python - Delete all docs from a type](https://discuss.elastic.co/t/python-delete-all-docs-from-a-type/121170)

<div class="topic-metadata">

**Author:** [@jaisharma](https://discuss.elastic.co/u/jaisharma)\
**Replies:** 11\
**Last updated:** [March 8, 2018, 11:00am UTC](https://discuss.elastic.co/t/python-delete-all-docs-from-a-type/121170 "2018-03-08T11:00:13Z")

</div>

Elasticsearch version: 2.4.1 I'm using es python client and want to delete all documents matching a particular type. Currently i'm using helpers.scan to get all matching \_id followed by issuing a bulk delete request lik…

---

## [Sum to 0 when values are too small](https://discuss.elastic.co/t/sum-to-0-when-values-are-too-small/27331)

<div class="topic-metadata">

**Author:** [@Gilles](https://discuss.elastic.co/u/Gilles)\
**Replies:** 17\
**Last updated:** [September 1, 2015, 2:52am UTC](https://discuss.elastic.co/t/sum-to-0-when-values-are-too-small/27331 "2015-09-01T02:52:14Z")

</div>

Hello, Is there a minimum value to have a non null sum? I have a field with numeric values in the 10\*\*-2 but all my graphs charts are at 0 Thanks

---

## [Elasticsearch-6.2.2 installation issue](https://discuss.elastic.co/t/elasticsearch-6-2-2-installation-issue/125700)

<div class="topic-metadata">

**Author:** [@sureshboiina](https://discuss.elastic.co/u/sureshboiina)\
**Replies:** 10\
**Last updated:** [March 28, 2018, 7:14am UTC](https://discuss.elastic.co/t/elasticsearch-6-2-2-installation-issue/125700 "2018-03-28T07:14:06Z")

</div>

hi, Installed elasicsearch-6.2.2 When running using sudo service elasticsearch start elasticsearch is not starting and even not getting log files aslo so, went to messages and see there find Mar 27 12:34:54 RFG-LOG…

---

## [Script Aggregations Significant Performance Degradation in 2.2.0](https://discuss.elastic.co/t/script-aggregations-significant-performance-degradation-in-2-2-0/43183)

<div class="topic-metadata">

**Author:** [@fwen](https://discuss.elastic.co/u/fwen)\
**Replies:** 15\
**Last updated:** [June 2, 2016, 2:36am UTC](https://discuss.elastic.co/t/script-aggregations-significant-performance-degradation-in-2-2-0/43183 "2016-06-02T02:36:29Z")

</div>

Hi All, We have recently upgraded to 2.2.0 from 1.7.3, and have seen very high performance degradation for our queries with script aggregation fields. A sample query that takes about 5.8 seconds in 1.7.3 takes 86 seco…

---

## [ES write performance](https://discuss.elastic.co/t/es-write-performance/14152)

<div class="topic-metadata">

**Author:** [@Mauro\_Farracha](https://discuss.elastic.co/u/Mauro_Farracha)\
**Replies:** 33\
**Last updated:** [October 29, 2013, 8:05pm UTC](https://discuss.elastic.co/t/es-write-performance/14152 "2013-10-29T20:05:27Z")

</div>

Hi, I wrote a python script using elasticsearch-py and another using pyes, configured my bulk-size to be 5000 records (tested with more without improvement), one node only, no refresh interval, no replicas, thrift…

---

## [HTM / Logstasg Configuration / Pipeline Config](https://discuss.elastic.co/t/htm-logstasg-configuration-pipeline-config/146244)

<div class="topic-metadata">

**Author:** [@robegome](https://discuss.elastic.co/u/robegome)\
**Replies:** 31\
**Last updated:** [September 4, 2018, 6:38pm UTC](https://discuss.elastic.co/t/htm-logstasg-configuration-pipeline-config/146244 "2018-09-04T18:38:00Z")

</div>

Hello everyone, I would like to know if there are some place (thread) to create a pipeline (.conf file) to get the input/filter and output from a HTM file or if using filebeat I could get some view in Kibana... I am new…

---

## [Filebeat use insane memory](https://discuss.elastic.co/t/filebeat-use-insane-memory/79209)

<div class="topic-metadata">

**Author:** [@ginger](https://discuss.elastic.co/u/ginger)\
**Replies:** 20\
**Last updated:** [April 5, 2017, 1:01am UTC](https://discuss.elastic.co/t/filebeat-use-insane-memory/79209 "2017-04-05T01:01:53Z")

</div>

I've noticed the same problem as follows: Filebeat Version: 5.0.0 My data flow is: filebeat(5 machines) -\> ES(2 machines and cpu becomes bottleneck) My steps to repro: Kill filebeat first Remove index DELETE /index…

---

## [Elastic going down - failed to execute watch \_logstash\_version\_mismatch](https://discuss.elastic.co/t/elastic-going-down-failed-to-execute-watch-logstash-version-mismatch/118235)

<div class="topic-metadata">

**Author:** [@umapada](https://discuss.elastic.co/u/umapada)\
**Replies:** 10\
**Last updated:** [February 3, 2018, 1:54pm UTC](https://discuss.elastic.co/t/elastic-going-down-failed-to-execute-watch-logstash-version-mismatch/118235 "2018-02-03T13:54:51Z")

</div>

I have 3 node cluster, deployed in AWS. The elastic service going down now and then with following exception. I am using 3 node(each of 3 node acting as data, master, ingest). Using 6.1.2 version elastic, kibana and x-…

---

## [Plugin issue with SPI and classpath](https://discuss.elastic.co/t/plugin-issue-with-spi-and-classpath/27674)

<div class="topic-metadata">

**Author:** [@renaud1](https://discuss.elastic.co/u/renaud1)\
**Replies:** 11\
**Last updated:** [September 26, 2015, 8:16pm UTC](https://discuss.elastic.co/t/plugin-issue-with-spi-and-classpath/27674 "2015-09-26T20:16:23Z")

</div>

Hi, we have developed a plugin (siren) for elasticsearch that adds a new posting format. The last version of the plugin was released for elasticsearch 1.3.x. Today we are trying to upgrade it for elasticsearch 1.7.x, an…

---

## [Error=13, Permission denied](https://discuss.elastic.co/t/error-13-permission-denied/140056)

<div class="topic-metadata">

**Author:** [@guenter.platzerworld](https://discuss.elastic.co/u/guenter.platzerworld)\
**Replies:** 9\
**Last updated:** [August 17, 2018, 5:31am UTC](https://discuss.elastic.co/t/error-13-permission-denied/140056 "2018-08-17T05:31:25Z")

</div>

Hi, in ELK-Stack 6.3.x i get following Error: \[2018-07-15T13:37:00,885\]\[WARN \]\[o.e.b.ElasticsearchUncaughtExceptionHandler\] \[zebra-log-node-1\] uncaught exception in thread \[main\] org.elasticsearch.bootstrap.StartupExc…

---

## [Setup ELK 5.0 but Metribeat Not Working](https://discuss.elastic.co/t/setup-elk-5-0-but-metribeat-not-working/64076)

<div class="topic-metadata">

**Author:** [@elJoeyJojo](https://discuss.elastic.co/u/elJoeyJojo)\
**Replies:** 10\
**Last updated:** [October 27, 2016, 7:32pm UTC](https://discuss.elastic.co/t/setup-elk-5-0-but-metribeat-not-working/64076 "2016-10-27T19:32:22Z")

</div>

Hello, I have just installed a new ELK 5.0 Server on Ubuntu 15.04. Kibana/Elasticsearch/Logstash 5.0 I am able to login to Kibana and for a few minutes I saw some logs coming in but then they stopped. At the moment it'…

---

## [Json array splitting in logstash](https://discuss.elastic.co/t/json-array-splitting-in-logstash/82139)

<div class="topic-metadata">

**Author:** [@Shweta](https://discuss.elastic.co/u/Shweta)\
**Replies:** 10\
**Last updated:** [April 13, 2017, 8:18am UTC](https://discuss.elastic.co/t/json-array-splitting-in-logstash/82139 "2017-04-13T08:18:28Z")

</div>

Hi, We have following kind of logs in json files. {"info":{"tstmp":1.2,"from":"avshdd","hostid":"jahgcjha","log":{"version":"jhasgc","id":"jsadh","jobname":"xzcj","lognm":{"class":"jscjks","msg":\[{"users":"kjdfk","c…

---

## [Failed to complete action: delete\_indices. \<class 'KeyError'\>: 'indices'](https://discuss.elastic.co/t/failed-to-complete-action-delete-indices-class-keyerror-indices/211151)

<div class="topic-metadata">

**Author:** [@vt.gerard](https://discuss.elastic.co/u/vt.gerard)\
**Replies:** 15\
**Last updated:** [December 12, 2019, 12:18pm UTC](https://discuss.elastic.co/t/failed-to-complete-action-delete-indices-class-keyerror-indices/211151 "2019-12-12T12:18:38Z")

</div>

Hello. First of all thanks to the community who helped me so far with the forum and documentation, to use Elasticsearch & co. I now use Curator as well and I have quite a severe issue I can't resolve. Elasticsearch: 6.…

---

## [Compile Source Code](https://discuss.elastic.co/t/compile-source-code/135484)

<div class="topic-metadata">

**Author:** [@Mojtaba\_Motamed](https://discuss.elastic.co/u/Mojtaba_Motamed)\
**Replies:** 18\
**Last updated:** [June 27, 2018, 7:33am UTC](https://discuss.elastic.co/t/compile-source-code/135484 "2018-06-27T07:33:38Z")

</div>

Is there any way to compile source code of kibana( from github)

---

## [Issues pushing kubernetes ingress-nginx logs using filebeat deamonset pods](https://discuss.elastic.co/t/issues-pushing-kubernetes-ingress-nginx-logs-using-filebeat-deamonset-pods/206923)

<div class="topic-metadata">

**Author:** [@Siva\_Krishna](https://discuss.elastic.co/u/Siva_Krishna)\
**Replies:** 19\
**Last updated:** [January 7, 2020, 8:40am UTC](https://discuss.elastic.co/t/issues-pushing-kubernetes-ingress-nginx-logs-using-filebeat-deamonset-pods/206923 "2020-01-07T08:40:23Z")

</div>

Hello all, We're facing issues pushing kubernetes ingress-nginx logs using filebeat deamonset pods. using filebeat v6.2.4, 6.3.0, & 6.4.0. please let us know if this is the correct configs to push only ingress-nginx p…

---

## [Log Timezone Question](https://discuss.elastic.co/t/log-timezone-question/211160)

<div class="topic-metadata">

**Author:** [@ElkLogs](https://discuss.elastic.co/u/ElkLogs)\
**Replies:** 12\
**Last updated:** [December 13, 2019, 6:53am UTC](https://discuss.elastic.co/t/log-timezone-question/211160 "2019-12-13T06:53:33Z")

</div>

I have been searching through the threads, but I haven't been able to fins a solution. Essentially, I have a log source that ships logs in UTC. I need to adjust them for my timezone, but changing the zone in the logstash…

---

## [Filebeat Multiline Patterns not working for us](https://discuss.elastic.co/t/filebeat-multiline-patterns-not-working-for-us/153594)

<div class="topic-metadata">

**Author:** [@vishnuduttpv](https://discuss.elastic.co/u/vishnuduttpv)\
**Replies:** 10\
**Last updated:** [October 31, 2018, 10:13am UTC](https://discuss.elastic.co/t/filebeat-multiline-patterns-not-working-for-us/153594 "2018-10-31T10:13:50Z")

</div>

I wish to parse the tomcat logs. But I am facing problem in multiline handling in Filebeat. The logs are not parsed as per the requirement. Getting grokparse failures. Upon checking, I could see that the line starts does…

---

## [JSON API: CamelCase or '\_'?](https://discuss.elastic.co/t/json-api-camelcase-or--/2887)

<div class="topic-metadata">

**Author:** [@kimchy](https://discuss.elastic.co/u/kimchy)\
**Replies:** 15\
**Last updated:** [April 4, 2010, 3:28pm UTC](https://discuss.elastic.co/t/json-api-camelcase-or--/2887 "2010-04-04T15:28:31Z")

</div>

Hi, I was just wondering (yet again) if the decision I made for the JSON based REST Api to use CamelCase make sense or not. The other option, of course is to use '\_' to separate words. What do you think? As a…

---

## [Default.path.data issue when path.data is changed in elasticsearch](https://discuss.elastic.co/t/default-path-data-issue-when-path-data-is-changed-in-elasticsearch/107288)

<div class="topic-metadata">

**Author:** [@amruth](https://discuss.elastic.co/u/amruth)\
**Replies:** 13\
**Last updated:** [November 28, 2017, 5:47pm UTC](https://discuss.elastic.co/t/default-path-data-issue-when-path-data-is-changed-in-elasticsearch/107288 "2017-11-28T17:47:34Z")

</div>

Hi, I am getting the following error when I change path.data to /opt/elk, java.lang.IllegalStateException: detected index data in default.path.data \[/var/lib/elasticsearch\] where there should not be any; check the logs…

---

## [Sending Event Logs and Log Files](https://discuss.elastic.co/t/sending-event-logs-and-log-files/142860)

<div class="topic-metadata">

**Author:** [@Badb0y](https://discuss.elastic.co/u/Badb0y)\
**Replies:** 14\
**Last updated:** [August 22, 2018, 8:51am UTC](https://discuss.elastic.co/t/sending-event-logs-and-log-files/142860 "2018-08-22T08:51:16Z")

</div>

Is there anybody can help me, how to configure the winlogbeat to send these logs? define BASEDIR D:\\sdfdsfs\\LogFiles\\zip\_archive File '%BASEDIR%\\www.vvv.com\\u\*.log' Module im\_file File '%BASEDI…

---

## [Set y axis extents](https://discuss.elastic.co/t/set-y-axis-extents/85016)

<div class="topic-metadata">

**Author:** [@Padmavathy](https://discuss.elastic.co/u/Padmavathy)\
**Replies:** 12\
**Last updated:** [May 31, 2017, 9:51am UTC](https://discuss.elastic.co/t/set-y-axis-extents/85016 "2017-05-31T09:51:54Z")

</div>

I am using Kibana 5.Is there a way to set ymax and ymin for time of format HH:mm:ss

[Previous page](https://discuss.elastic.co/top.md?page=47&per_page=50&period=all)

[Next page](https://discuss.elastic.co/top.md?page=49&per_page=50&period=all)
