# Top

**URL:** https://discuss.elastic.co/top.md?page=5&period=all

[Latest](https://discuss.elastic.co/latest.md) · [Categories](https://discuss.elastic.co/categories.md) · [Tags](https://discuss.elastic.co/tags.md)

**Page:** 6

---

## [Filebeat - ERR Failed to publish events caused by: EOF](https://discuss.elastic.co/t/filebeat-err-failed-to-publish-events-caused-by-eof/65105)

<div class="topic-metadata">

**Author:** [@alexus](https://discuss.elastic.co/u/alexus)\
**Replies:** 16\
**Last updated:** [November 22, 2016, 6:33pm UTC](https://discuss.elastic.co/t/filebeat-err-failed-to-publish-events-caused-by-eof/65105 "2016-11-22T18:33:58Z")

</div>

I'm using Elasticsearch, Logstash, Kibana (ELK) Docker image (elk-docker) @ following environment: # cat /etc/redhat-release CentOS Linux release 7.2.1511 (Core) # uname -a Linux X 3.10.0-327.36.3.el7.x86\_64 #1 SMP Mo…

---

## [Elasticsearch High CPU Usage - GC Not Working](https://discuss.elastic.co/t/elasticsearch-high-cpu-usage-gc-not-working/53816)

<div class="topic-metadata">

**Author:** [@Michael\_Sander](https://discuss.elastic.co/u/Michael_Sander)\
**Replies:** 25\
**Last updated:** [December 1, 2016, 7:21am UTC](https://discuss.elastic.co/t/elasticsearch-high-cpu-usage-gc-not-working/53816 "2016-12-01T07:21:19Z")

</div>

I am running a 5 node ES 1.7.5 cluster and have been running into the same issue for the past few weeks: after running perfectly smoothly for about a week, the nodes start using 100% CPU and become unresponsive. I normal…

---

## [What does "No search context found for id ..." mean?](https://discuss.elastic.co/t/what-does-no-search-context-found-for-id-mean/103316)

<div class="topic-metadata">

**Author:** [@TimWard](https://discuss.elastic.co/u/TimWard)\
**Replies:** 10\
**Last updated:** [October 13, 2017, 3:53pm UTC](https://discuss.elastic.co/t/what-does-no-search-context-found-for-id-mean/103316 "2017-10-13T15:53:24Z")

</div>

From Python driver. If I search for this message I find various detailed discussions, but they all seem to assume I'm starting from knowing a lot more than I do. So, starting from nothing at all, what does this message …

---

## [Too many dynamic script compilations within one minute](https://discuss.elastic.co/t/too-many-dynamic-script-compilations-within-one-minute/128956)

<div class="topic-metadata">

**Author:** [@idmanish](https://discuss.elastic.co/u/idmanish)\
**Replies:** 15\
**Last updated:** [April 30, 2018, 3:47am UTC](https://discuss.elastic.co/t/too-many-dynamic-script-compilations-within-one-minute/128956 "2018-04-30T03:47:06Z")

</div>

I am facing "max\_compilations\_per\_minute" error. TransportError(500, '{"error":{"root\_cause":\[{"type":"circuit\_breaking\_exception","reason":"\[script\] Too many dynamic script compilations within one minute, max: \[15/min\]…

---

## [3 nodes in the cluster, 2 data and 1 master - why if one fails it takes the whole cluster down?](https://discuss.elastic.co/t/3-nodes-in-the-cluster-2-data-and-1-master-why-if-one-fails-it-takes-the-whole-cluster-down/267165)

<div class="topic-metadata">

**Author:** [@lamp123432](https://discuss.elastic.co/u/lamp123432)\
**Replies:** 14\
**Last updated:** [March 15, 2021, 3:27am UTC](https://discuss.elastic.co/t/3-nodes-in-the-cluster-2-data-and-1-master-why-if-one-fails-it-takes-the-whole-cluster-down/267165 "2021-03-15T03:27:24Z")

</div>

Hello, I have 3 nodes; 2 data nodes and 1 master node. When one of the data nodes fails, the whole cluster stops processing data, nothing is shown in Kibana anymore, even though a data node is working and receiving data…

---

## [Logstash gsub remove string/characters](https://discuss.elastic.co/t/logstash-gsub-remove-string-characters/100852)

<div class="topic-metadata">

**Author:** [@tharu85](https://discuss.elastic.co/u/tharu85)\
**Replies:** 15\
**Last updated:** [September 20, 2017, 3:49am UTC](https://discuss.elastic.co/t/logstash-gsub-remove-string-characters/100852 "2017-09-20T03:49:57Z")

</div>

In my log file, I need to remove a defined characters from the RAW log. my RAW log sample as below. Sep 18 150942 db\[27414\]: category=\\"Event\\" subcategory=\\"System\\".... Sep 18 151043 db\[27464\]: category=\\"Event…

---

## [Invalid internal transport message format (ff,f4,ff,fd)](https://discuss.elastic.co/t/invalid-internal-transport-message-format-ff-f4-ff-fd/34586)

<div class="topic-metadata">

**Author:** [@vladmiller](https://discuss.elastic.co/u/vladmiller)\
**Replies:** 13\
**Last updated:** [December 7, 2015, 1:16pm UTC](https://discuss.elastic.co/t/invalid-internal-transport-message-format-ff-f4-ff-fd/34586 "2015-12-07T13:16:37Z")

</div>

Hello, so I'm trying to configure ES on AWS EB service. I have two nodes and one of the nodes fails with the following message {"error":{"root\_cause":\[{"type":"master\_not\_discovered\_exception","reason":"waited for \[30s…

---

## [Unable to access Kibana on http://MYDOMAIN.com:5601](https://discuss.elastic.co/t/unable-to-access-kibana-on-http-mydomain-com-5601/107145)

<div class="topic-metadata">

**Author:** [@quitr](https://discuss.elastic.co/u/quitr)\
**Replies:** 16\
**Last updated:** [November 10, 2017, 10:56am UTC](https://discuss.elastic.co/t/unable-to-access-kibana-on-http-mydomain-com-5601/107145 "2017-11-10T10:56:36Z")

</div>

I am new to the ELK Stack. I have installed all the components (filebeat, logstash, elasticsearch and kibana), and all services are running. I am able to test elasticsearch by running curl localhost:9200. However I am u…

---

## [Logstash not seeing conf files in conf.d dir](https://discuss.elastic.co/t/logstash-not-seeing-conf-files-in-conf-d-dir/75931)

<div class="topic-metadata">

**Author:** [@tgdesrochers](https://discuss.elastic.co/u/tgdesrochers)\
**Replies:** 35\
**Last updated:** [February 22, 2017, 6:26pm UTC](https://discuss.elastic.co/t/logstash-not-seeing-conf-files-in-conf-d-dir/75931 "2017-02-22T18:26:02Z")

</div>

I am not new to logstash but I am to 5.X My issue is with files in the /etc/logstash/conf.d directory. When I created my configuration file in this directory and start logstash as a daemon it does nothing. When I sta…

---

## [Missing documents after bulk indexing](https://discuss.elastic.co/t/missing-documents-after-bulk-indexing/11987)

<div class="topic-metadata">

**Author:** [@Mao\_Ye](https://discuss.elastic.co/u/Mao_Ye)\
**Replies:** 12\
**Last updated:** [October 11, 2014, 10:53am UTC](https://discuss.elastic.co/t/missing-documents-after-bulk-indexing/11987 "2014-10-11T10:53:06Z")

</div>

Hi, I am using elasticsearch-0.90.0.jar, and wonderdog (https://github.com/infochimps-labs/wonderdog) to do bulk index. There are 247465 documents for indexing into elastic search. However, I notice that after …

---

## [Multiple Elasticsearch Indices in Logstash output](https://discuss.elastic.co/t/multiple-elasticsearch-indices-in-logstash-output/26607)

<div class="topic-metadata">

**Author:** [@shadowman13](https://discuss.elastic.co/u/shadowman13)\
**Replies:** 11\
**Last updated:** [April 22, 2016, 8:55am UTC](https://discuss.elastic.co/t/multiple-elasticsearch-indices-in-logstash-output/26607 "2016-04-22T08:55:13Z")

</div>

Hi all, Currently I'm using Elasticsearch auto clear index script which find all the indexes with format logstash-%{+YYYY.MM.dd} and clear all the indices older than 10 days, but for some reason I need to exclude a spe…

---

## [Elasticsearch 5.6.3 upgrade to 6.0 Node will not start "failed to read local state"](https://discuss.elastic.co/t/elasticsearch-5-6-3-upgrade-to-6-0-node-will-not-start-failed-to-read-local-state/108252)

<div class="topic-metadata">

**Author:** [@kwslavens](https://discuss.elastic.co/u/kwslavens)\
**Replies:** 33\
**Last updated:** [November 28, 2017, 9:44am UTC](https://discuss.elastic.co/t/elasticsearch-5-6-3-upgrade-to-6-0-node-will-not-start-failed-to-read-local-state/108252 "2017-11-28T09:44:12Z")

</div>

We've updated our Dev system and our monitoring stack to 6.0 with minimal issues. When we attempt to update production node they refuse to start. Attempted the upgrade on two nodes now. Both nodes result in the same erro…

---

## [Kibana login page](https://discuss.elastic.co/t/kibana-login-page/138421)

<div class="topic-metadata">

**Author:** [@Preethi](https://discuss.elastic.co/u/Preethi)\
**Replies:** 15\
**Last updated:** [July 16, 2018, 3:35am UTC](https://discuss.elastic.co/t/kibana-login-page/138421 "2018-07-16T03:35:12Z")

</div>

Hi, Referred the video in this URL to set up the login account for Kibana UI(Version 6.3.0). https://www.elastic.co/webinars/getting-started-kibana I installed Kibana 6.3.0, but not X-pack separately. Since its not re…

---

## [Filebeat - received an event - has different character encoding](https://discuss.elastic.co/t/filebeat-received-an-event-has-different-character-encoding/40510)

<div class="topic-metadata">

**Author:** [@j123](https://discuss.elastic.co/u/j123)\
**Replies:** 20\
**Last updated:** [March 21, 2016, 11:21am UTC](https://discuss.elastic.co/t/filebeat-received-an-event-has-different-character-encoding/40510 "2016-03-21T11:21:28Z")

</div>

Hello, I am using filebeat (Linux box) to send logs to ELK - logstash., It is not sending UTF-8 (Linux) encoding. Looks like hexa-decimal. Help please. error message in logstash.log: {:timestamp=\>"2016-01-29T11:47…

---

## [Convert Elasticsearch Date/Time field from UTC To Local Time?](https://discuss.elastic.co/t/convert-elasticsearch-date-time-field-from-utc-to-local-time/283441)

<div class="topic-metadata">

**Author:** [@padamrai](https://discuss.elastic.co/u/padamrai)\
**Replies:** 9\
**Last updated:** [September 6, 2021, 1:11pm UTC](https://discuss.elastic.co/t/convert-elasticsearch-date-time-field-from-utc-to-local-time/283441 "2021-09-06T13:11:52Z")

</div>

I am getting 12 Hours difference in Date. I want to set that date format to local time that is GMT+5. And I have set kibana default time period to Browser. Any one can help me how to set is as local time.

---

## [Logstash start up issues](https://discuss.elastic.co/t/logstash-start-up-issues/98734)

<div class="topic-metadata">

**Author:** [@hburnswell](https://discuss.elastic.co/u/hburnswell)\
**Replies:** 15\
**Last updated:** [September 7, 2017, 9:03pm UTC](https://discuss.elastic.co/t/logstash-start-up-issues/98734 "2017-09-07T21:03:49Z")

</div>

Hi All, I just set up a 3 node Elasticsearch and Logstash environment using the repos on RHEL 7: logstash-5.5.2-1.noarch elasticsearch-5.5.2-1.noarch I initially installed the X-Pack for ES and Kibana but then remove…

---

## [Network.host or http.host - documentation problem?](https://discuss.elastic.co/t/network-host-or-http-host-documentation-problem/64179)

<div class="topic-metadata">

**Author:** [@tsmori](https://discuss.elastic.co/u/tsmori)\
**Replies:** 28\
**Last updated:** [November 27, 2020, 5:01pm UTC](https://discuss.elastic.co/t/network-host-or-http-host-documentation-problem/64179 "2020-11-27T17:01:04Z")

</div>

The default works fine, however it's only binding to localhost. I want to be able to bind elasticsearch to a non-loopback IP. Docs say this is possible, but setting 0.0.0.0 or the actual adapater IP results in the follo…

---

## [LogStash not sending data to ElasticSearch](https://discuss.elastic.co/t/logstash-not-sending-data-to-elasticsearch/44791)

<div class="topic-metadata">

**Author:** [@Sameer\_Panicker](https://discuss.elastic.co/u/Sameer_Panicker)\
**Replies:** 20\
**Last updated:** [March 29, 2016, 4:20am UTC](https://discuss.elastic.co/t/logstash-not-sending-data-to-elasticsearch/44791 "2016-03-29T04:20:49Z")

</div>

This is my logstash conf - input { file { path =\> "C:\\LogStash Logs\*" } } output { elasticsearch { hosts =\> \["localhost:9200"\] } stdout { codec =\> rubydebug } } ES is working fine. What ever fi…

---

## [Elasticsearch warning at startup (exception caught on transport layer)](https://discuss.elastic.co/t/elasticsearch-warning-at-startup-exception-caught-on-transport-layer/35768)

<div class="topic-metadata">

**Author:** [@razvan.dani](https://discuss.elastic.co/u/razvan.dani)\
**Replies:** 17\
**Last updated:** [March 14, 2017, 7:49pm UTC](https://discuss.elastic.co/t/elasticsearch-warning-at-startup-exception-caught-on-transport-layer/35768 "2017-03-14T19:49:36Z")

</div>

I am using Elasticsearch 2.1.0 and at the startup i get this warning (which seems more like an error really): \[2015-11-27 16:33:25,460\]\[WARN \]\[transport.netty \] \[node-1\] exception c aught on transport layer \[\[…

---

## [Set timeout](https://discuss.elastic.co/t/set-timeout/213551)

<div class="topic-metadata">

**Author:** [@rihad](https://discuss.elastic.co/u/rihad)\
**Replies:** 16\
**Last updated:** [January 8, 2020, 6:42am UTC](https://discuss.elastic.co/t/set-timeout/213551 "2020-01-08T06:42:59Z")

</div>

Hi, how can I set timeout in elasticsearch.yml? https://www.elastic.co/guide/en/elasticsearch/reference/current/cluster-health.html#cluster-health-api-query-params I tried these: timeout: 60, query.timeout, Query.timeou…

---

## [How to get data more than 10000 in elasticsearch](https://discuss.elastic.co/t/how-to-get-data-more-than-10000-in-elasticsearch/107869)

<div class="topic-metadata">

**Author:** [@kanchan](https://discuss.elastic.co/u/kanchan)\
**Replies:** 26\
**Last updated:** [December 20, 2017, 2:27pm UTC](https://discuss.elastic.co/t/how-to-get-data-more-than-10000-in-elasticsearch/107869 "2017-12-20T14:27:13Z")

</div>

Hi Team, I am trying to fetch data using rest client in java side, but not able to fetch more than 10000 and even if i am trying to fetch data less then 10000 like 5000 or 7000 it is taking too much time. please let me…

---

## [Apply Boosting Based on a Field Value](https://discuss.elastic.co/t/apply-boosting-based-on-a-field-value/156673)

<div class="topic-metadata">

**Author:** [@maryam\_abdullah](https://discuss.elastic.co/u/maryam_abdullah)\
**Replies:** 25\
**Last updated:** [November 21, 2018, 9:36am UTC](https://discuss.elastic.co/t/apply-boosting-based-on-a-field-value/156673 "2018-11-21T09:36:30Z")

</div>

Hey, While searching, is it possible to boost the score by a number calculated from the field value, e.g. the field value divided by a particular number? Meaning that the boost value is dependent on a field value of the…

---

## [Invalid Frame Type, received: 1](https://discuss.elastic.co/t/invalid-frame-type-received-1/65493)

<div class="topic-metadata">

**Author:** [@ironbeast](https://discuss.elastic.co/u/ironbeast)\
**Replies:** 19\
**Last updated:** [January 3, 2017, 8:04am UTC](https://discuss.elastic.co/t/invalid-frame-type-received-1/65493 "2017-01-03T08:04:33Z")

</div>

Hello, I installed the complete 5.0 stack (filebeat/logstash/elasticsearch/kibana). But I have following error in my logs continuously showing up: \[2016-11-09T14:17:34,982\]\[ERROR\]\[org.logstash.beats.BeatsHandler\] Excep…

---

## [Python SSL Error](https://discuss.elastic.co/t/python-ssl-error/189407)

<div class="topic-metadata">

**Author:** [@adwaitjoshi](https://discuss.elastic.co/u/adwaitjoshi)\
**Replies:** 12\
**Last updated:** [July 17, 2019, 12:38am UTC](https://discuss.elastic.co/t/python-ssl-error/189407 "2019-07-17T00:38:28Z")

</div>

I am trying to use the following code import elasticsearch es = elasticsearch.Elasticsearch(es\_protocol+'://'+es\_host+':'+es\_port,http\_auth=(\_user,\_pass),verify\_certs=None) es.indices.create(index=index\_name, ignore=4…

---

## [Problem with cluster.max\_shards\_per\_node setting](https://discuss.elastic.co/t/problem-with-cluster-max-shards-per-node-setting/190933)

<div class="topic-metadata">

**Author:** [@ness1602](https://discuss.elastic.co/u/ness1602)\
**Replies:** 10\
**Last updated:** [July 19, 2019, 7:18am UTC](https://discuss.elastic.co/t/problem-with-cluster-max-shards-per-node-setting/190933 "2019-07-19T07:18:57Z")

</div>

Hi,i have a problem with testing ES 7.2(or any 7.x) and configuration for cluster.max\_shards\_per\_node. When i set it to lets say 30000 in elasticsearch.yml(Centos6), i think ES somehow overrides that with default settin…

---

## [How to apply different filter for different column in a single Kibana visualisation (Data Table)?](https://discuss.elastic.co/t/how-to-apply-different-filter-for-different-column-in-a-single-kibana-visualisation-data-table/58817)

<div class="topic-metadata">

**Author:** [@pramod\_kumar](https://discuss.elastic.co/u/pramod_kumar)\
**Replies:** 13\
**Last updated:** [August 24, 2016, 8:07pm UTC](https://discuss.elastic.co/t/how-to-apply-different-filter-for-different-column-in-a-single-kibana-visualisation-data-table/58817 "2016-08-24T20:07:33Z")

</div>

Hi All, I have created 2 index say a-b-middletier and a-b-database upon that i have created a kibana visualisation (Data Table) by merging these 2 indexes say a-b-\*\*\*. i would like to see the counts w.r.t middletier a…

---

## [MIB OID Translation](https://discuss.elastic.co/t/mib-oid-translation/29710)

<div class="topic-metadata">

**Author:** [@tom\_jonge](https://discuss.elastic.co/u/tom_jonge)\
**Replies:** 32\
**Last updated:** [January 22, 2020, 3:13am UTC](https://discuss.elastic.co/t/mib-oid-translation/29710 "2020-01-22T03:13:37Z")

</div>

Dear logstash, /opt/logstash/vendor/bundle/jruby/1.9/gems/snmp-1.2.0/data/ruby/snmp/mibs containts a venerable treasure trove of pre-converted YAML MIBs. However I have run into an issue: From Kibana: RFC1155-SMI::…

---

## [How to access kibana from remote machines](https://discuss.elastic.co/t/how-to-access-kibana-from-remote-machines/98487)

<div class="topic-metadata">

**Author:** [@SandhyaRani](https://discuss.elastic.co/u/SandhyaRani)\
**Replies:** 13\
**Last updated:** [September 6, 2017, 12:03pm UTC](https://discuss.elastic.co/t/how-to-access-kibana-from-remote-machines/98487 "2017-09-06T12:03:31Z")

</div>

Hi there! I have elasticsearch,logstash, and kibana on my local machine. I wanted to access kibana from remote machines. Its working fine on localhost. In kibana.yml file I tried few ways: server.host: “0.0.0.0” — t…

---

## [Is my Data being received by Elasticsearch?](https://discuss.elastic.co/t/is-my-data-being-received-by-elasticsearch/84123)

<div class="topic-metadata">

**Author:** [@sweath](https://discuss.elastic.co/u/sweath)\
**Replies:** 17\
**Last updated:** [May 5, 2017, 2:56pm UTC](https://discuss.elastic.co/t/is-my-data-being-received-by-elasticsearch/84123 "2017-05-05T14:56:07Z")

</div>

I'm quite new to this ELK stack stuff, and have reached my limit on searching for an answer, but I have the issue where I'm attempting to index some logs that I'm assuming have been sent over through logstash, but I'm ge…

---

## [5 of 30 shards failed in Elastic 5.5.1](https://discuss.elastic.co/t/5-of-30-shards-failed-in-elastic-5-5-1/162373)

<div class="topic-metadata">

**Author:** [@carrolp](https://discuss.elastic.co/u/carrolp)\
**Replies:** 14\
**Last updated:** [January 2, 2019, 6:06pm UTC](https://discuss.elastic.co/t/5-of-30-shards-failed-in-elastic-5-5-1/162373 "2019-01-02T18:06:37Z")

</div>

My project is hitting a '5 of 30 shards failed' error when searching from Kibana. This is very similar to these postings: https://discuss.elastic.co/t/courier-fetch-3-out-of-33-shards-failed/122094 https://discuss…

---

## [Official apt repository (451 Unavailable For Legal Reasons)](https://discuss.elastic.co/t/official-apt-repository-451-unavailable-for-legal-reasons/232494)

<div class="topic-metadata">

**Author:** [@vdt\_mik](https://discuss.elastic.co/u/vdt_mik)\
**Replies:** 74\
**Last updated:** [July 13, 2020, 12:21pm UTC](https://discuss.elastic.co/t/official-apt-repository-451-unavailable-for-legal-reasons/232494 "2020-07-13T12:21:20Z")

</div>

Hi! I faced this problem in my VM on the DigitalOcean(Europe region). I tried to do an apt update in my Debian 9 VM. But I recieved this message: Ign:1 http://deb.debian.org/debian stretch InRelease Hit:2 http://securi…

---

## [Insert the json into elastic using java](https://discuss.elastic.co/t/insert-the-json-into-elastic-using-java/140674)

<div class="topic-metadata">

**Author:** [@srinivasthouti](https://discuss.elastic.co/u/srinivasthouti)\
**Replies:** 29\
**Last updated:** [July 27, 2018, 7:52am UTC](https://discuss.elastic.co/t/insert-the-json-into-elastic-using-java/140674 "2018-07-27T07:52:52Z")

</div>

hi i am having below json obect i need to push this data into elasticserach index i already creadted index in elastic ,can any one help me in this . "data" { "counter":"0", "create\_ts":"12-12-2018", "email":"sriniv…

---

## [Elaticsearch failed to start after installing x-pack](https://discuss.elastic.co/t/elaticsearch-failed-to-start-after-installing-x-pack/74807)

<div class="topic-metadata">

**Author:** [@yoavb](https://discuss.elastic.co/u/yoavb)\
**Replies:** 12\
**Last updated:** [February 26, 2017, 8:21am UTC](https://discuss.elastic.co/t/elaticsearch-failed-to-start-after-installing-x-pack/74807 "2017-02-26T08:21:40Z")

</div>

I have manually installed x-pack version 5.1.1 After installation Elasticsearch failed to start . Status before installation - curl -XGET 'localhost:9200/?pretty' { "name" : "5gvYWYb", "cluster\_name" : "elasticsear…

---

## [Filters in logstash for sending the logs to elastic search index](https://discuss.elastic.co/t/filters-in-logstash-for-sending-the-logs-to-elastic-search-index/69343)

<div class="topic-metadata">

**Author:** [@Makra](https://discuss.elastic.co/u/Makra)\
**Replies:** 22\
**Last updated:** [December 28, 2016, 7:00pm UTC](https://discuss.elastic.co/t/filters-in-logstash-for-sending-the-logs-to-elastic-search-index/69343 "2016-12-28T19:00:41Z")

</div>

Hi I have configured syslog-ng which in turn receiving syslogs from different sources/devices like Windows, Linux, firewall devices etc. in port no 514. Syslog-ng is then forwarding all syslogs to Logstash server in…

---

## [Run Kibana as service on CentOS](https://discuss.elastic.co/t/run-kibana-as-service-on-centos/23971)

<div class="topic-metadata">

**Author:** [@MattStibbs](https://discuss.elastic.co/u/MattStibbs)\
**Replies:** 16\
**Last updated:** [November 24, 2016, 8:42pm UTC](https://discuss.elastic.co/t/run-kibana-as-service-on-centos/23971 "2016-11-24T20:42:51Z")

</div>

Hi there, I am trying to get Kibana up and running on Centos. Following the instructions on the elastic site, I can successfully download the files and run in the console. But is there any guidance anywhere that help…

---

## [Failed to obtain node locks, tried \[\[/usr/share/elasticsearch/data\]\] with lock id \[0\]](https://discuss.elastic.co/t/failed-to-obtain-node-locks-tried-usr-share-elasticsearch-data-with-lock-id-0/205706)

<div class="topic-metadata">

**Author:** [@Benni](https://discuss.elastic.co/u/Benni)\
**Replies:** 10\
**Last updated:** [November 1, 2019, 7:54am UTC](https://discuss.elastic.co/t/failed-to-obtain-node-locks-tried-usr-share-elasticsearch-data-with-lock-id-0/205706 "2019-11-01T07:54:44Z")

</div>

Hello, I have already found many approaches for this error. Unfortunately none of them helped me to solve my problem. It seems to be an old friend of Elasticsearch. org.elasticsearch.bootstrap.StartupException: java.lan…

---

## [Multiple Logstash Instance in one machine](https://discuss.elastic.co/t/multiple-logstash-instance-in-one-machine/96717)

<div class="topic-metadata">

**Author:** [@jogoinar10](https://discuss.elastic.co/u/jogoinar10)\
**Replies:** 17\
**Last updated:** [August 23, 2017, 11:52am UTC](https://discuss.elastic.co/t/multiple-logstash-instance-in-one-machine/96717 "2017-08-23T11:52:48Z")

</div>

How can I setup multiple logstash instance in one machine? My idea is to gather logs and then forward the data to two elasticsearch host machine as well. If you’ll ask why not to config in just single logstash with 2 e…

---

## [Login is currently disabled because the license could not be determined. Please check that Elasticsearch has the X-Pack plugin installed and is reachable, then refresh this page](https://discuss.elastic.co/t/login-is-currently-disabled-because-the-license-could-not-be-determined-please-check-that-elasticsearch-has-the-x-pack-plugin-installed-and-is-reachable-then-refresh-this-page/101148)

<div class="topic-metadata">

**Author:** [@hackilberry](https://discuss.elastic.co/u/hackilberry)\
**Replies:** 31\
**Last updated:** [October 20, 2017, 6:09am UTC](https://discuss.elastic.co/t/login-is-currently-disabled-because-the-license-could-not-be-determined-please-check-that-elasticsearch-has-the-x-pack-plugin-installed-and-is-reachable-then-refresh-this-page/101148 "2017-10-20T06:09:05Z")

</div>

Hi, This was raised here in the past, yet I couldn't find the answer for my use case: I installed Logstash (5.6.0), ElasticSearch (5.6.0) and Kibana (5.6.0) in the same machine. I was able to access Kibana and play a l…

---

## [Shield error. Authorization problem. \[Even admin unable to access\]](https://discuss.elastic.co/t/shield-error-authorization-problem-even-admin-unable-to-access/29751)

<div class="topic-metadata">

**Author:** [@pranavburnwal](https://discuss.elastic.co/u/pranavburnwal)\
**Replies:** 13\
**Last updated:** [January 21, 2016, 3:54pm UTC](https://discuss.elastic.co/t/shield-error-authorization-problem-even-admin-unable-to-access/29751 "2016-01-21T15:54:25Z")

</div>

Hi all, Today I was trying out ES-beta2. Gave a fresh extract. Installed shield and license. Then edited the configs of ES. All the roles and role mappings with elasticsearch config. \[BTW I am using LDAP backend\] The…

---

## [Kibana already started but the status is not running](https://discuss.elastic.co/t/kibana-already-started-but-the-status-is-not-running/42667)

<div class="topic-metadata">

**Author:** [@fadzhli](https://discuss.elastic.co/u/fadzhli)\
**Replies:** 23\
**Last updated:** [May 1, 2017, 2:53pm UTC](https://discuss.elastic.co/t/kibana-already-started-but-the-status-is-not-running/42667 "2017-05-01T14:53:20Z")

</div>

I'm just updated my Kibana to 4.4 and I have encounter some problems: \[fadzhli@elk ~\]$ sudo service kibana start chown: invalid user: 'kibana:root' kibana started \[fadzhli@elk ~\]$ sudo service kibana status \[sudo\] pa…

---

## [How to reindex data in Elasticsearch without actually changing index names?](https://discuss.elastic.co/t/how-to-reindex-data-in-elasticsearch-without-actually-changing-index-names/104034)

<div class="topic-metadata">

**Author:** [@amruth](https://discuss.elastic.co/u/amruth)\
**Replies:** 12\
**Last updated:** [October 19, 2017, 2:12pm UTC](https://discuss.elastic.co/t/how-to-reindex-data-in-elasticsearch-without-actually-changing-index-names/104034 "2017-10-19T14:12:58Z")

</div>

Hi, I am trying to reindex data in Elasticsearch without actually changing index names. I am ingesting data to indices based on monthly index names(index-%{+YYYY.MM}). I've seen concept of using aliases, but I am not su…

---

## [ERROR: no\_shard\_available\_action\_exception](https://discuss.elastic.co/t/error-no-shard-available-action-exception/316950)

<div class="topic-metadata">

**Author:** [@hjsroldan](https://discuss.elastic.co/u/hjsroldan)\
**Replies:** 11\
**Last updated:** [October 19, 2022, 8:44am UTC](https://discuss.elastic.co/t/error-no-shard-available-action-exception/316950 "2022-10-19T08:44:42Z")

</div>

Hi, Does someone know how to fix this issue "no\_shard\_available\_action\_exception". Encountered this error after I restore my cluster, index was restored but the documents was not restored. Kindly see the error below: '…

---

## [Out Of Sync Replica](https://discuss.elastic.co/t/out-of-sync-replica/126588)

<div class="topic-metadata">

**Author:** [@Evesy](https://discuss.elastic.co/u/Evesy)\
**Replies:** 40\
**Last updated:** [May 17, 2018, 4:12pm UTC](https://discuss.elastic.co/t/out-of-sync-replica/126588 "2018-05-17T16:12:02Z")

</div>

Hi, We've been getting a few errors recently due to 'out of sync replicas' which is affecting certain cluster operations. The issues seem to tie in with an upgrade from 6.1.2 to 6.2.3 however could be completely unrelat…

---

## [Unable to fetch mapping. Do you have indices matching the pattern?](https://discuss.elastic.co/t/unable-to-fetch-mapping-do-you-have-indices-matching-the-pattern/73791)

<div class="topic-metadata">

**Author:** [@timmy8ken](https://discuss.elastic.co/u/timmy8ken)\
**Replies:** 19\
**Last updated:** [March 8, 2017, 8:56am UTC](https://discuss.elastic.co/t/unable-to-fetch-mapping-do-you-have-indices-matching-the-pattern/73791 "2017-03-08T08:56:08Z")

</div>

Hello Elastic Forum, I know that this question has been asked many times before, however I am pretty sure that I have logstash successfully creating an index, but I am still getting the error. Hopefully someone can see …

---

## [Connectivity issues to Elasticsearch via tcp\\9200](https://discuss.elastic.co/t/connectivity-issues-to-elasticsearch-via-tcp-9200/191900)

<div class="topic-metadata">

**Author:** [@littlejob](https://discuss.elastic.co/u/littlejob)\
**Replies:** 17\
**Last updated:** [July 25, 2019, 6:40pm UTC](https://discuss.elastic.co/t/connectivity-issues-to-elasticsearch-via-tcp-9200/191900 "2019-07-25T18:40:55Z")

</div>

Testing out winlogbeat to send syslogs to elastic instance with a kibana front end. kibana status page shows all things are green two network options set in elasticsearch.yml are: network.host: 127.0.0.1 http.port:…

---

## [\[ConnectionError\]: connect ECONNREFUSED 127.0.0.1:9200"} and Server is not ready](https://discuss.elastic.co/t/connectionerror-connect-econnrefused-127-0-0-1-9200-and-server-is-not-ready/271776)

<div class="topic-metadata">

**Author:** [@LombardoAndrea195](https://discuss.elastic.co/u/LombardoAndrea195)\
**Replies:** 11\
**Last updated:** [April 30, 2021, 3:49pm UTC](https://discuss.elastic.co/t/connectionerror-connect-econnrefused-127-0-0-1-9200-and-server-is-not-ready/271776 "2021-04-30T15:49:48Z")

</div>

After lunching docker-compose file I've this problem issue. In case I try to see the dashborad on loclahost:5601 there's a response ("Kibana server is not ready yet"). What's the real problem? I'm able to query informati…

---

## [2021: The Year in Review](https://discuss.elastic.co/t/2021-the-year-in-review/293492)

<div class="topic-metadata">

**Author:** [@system](https://discuss.elastic.co/u/system)\
**Replies:** 23\
**Last updated:** [January 5, 2022, 4:53am UTC](https://discuss.elastic.co/t/2021-the-year-in-review/293492 "2022-01-05T04:53:17Z")

</div>

2021's Top Users Most Time Reading User Hours Read …

---

## [Failed to start Filebeat sends log files to Logstash or directly to Elasticsearch](https://discuss.elastic.co/t/failed-to-start-filebeat-sends-log-files-to-logstash-or-directly-to-elasticsearch/276176)

<div class="topic-metadata">

**Author:** [@Akanksha\_Pandey](https://discuss.elastic.co/u/Akanksha_Pandey)\
**Replies:** 23\
**Last updated:** [June 23, 2021, 7:04am UTC](https://discuss.elastic.co/t/failed-to-start-filebeat-sends-log-files-to-logstash-or-directly-to-elasticsearch/276176 "2021-06-23T07:04:51Z")

</div>

Hi, I have installed native Filebeat and configured filebeat.yml accordingley but when I start the service it gives the below error: Jun 16 10:16:03 picktrack-1b systemd\[1\]: filebeat.service: Service hold-off time ove…

---

## ["Elasticsearch Unreachable: \[http://localhost:9200/\]\[Manticore::ClientProtocolException\] localhost:9200 failed to respond"}](https://discuss.elastic.co/t/elasticsearch-unreachable-http-localhost-9200-manticore-clientprotocolexception-localhost-9200-failed-to-respond/325897)

<div class="topic-metadata">

**Author:** [@Matt\_Johnston](https://discuss.elastic.co/u/Matt_Johnston)\
**Replies:** 10\
**Last updated:** [February 19, 2023, 7:20pm UTC](https://discuss.elastic.co/t/elasticsearch-unreachable-http-localhost-9200-manticore-clientprotocolexception-localhost-9200-failed-to-respond/325897 "2023-02-19T19:20:51Z")

</div>

Hi. I'm trying to follow the "Parsing Logs with Logstash" (Tutorial), and I am having trouble when I try to connect my pipeline to Elasticsearch. My first-pipeline.conf file looks like this: input { beats { …

---

## [Error: Could not find or load main class org.elasticsearch.tools.JavaVersionChecker](https://discuss.elastic.co/t/error-could-not-find-or-load-main-class-org-elasticsearch-tools-javaversionchecker/82213)

<div class="topic-metadata">

**Author:** [@Xceasar](https://discuss.elastic.co/u/Xceasar)\
**Replies:** 13\
**Last updated:** [May 6, 2017, 6:30pm UTC](https://discuss.elastic.co/t/error-could-not-find-or-load-main-class-org-elasticsearch-tools-javaversionchecker/82213 "2017-05-06T18:30:23Z")

</div>

i tried to install elasticsearch 5.3 inside my docker, after adding a new user elsearch with following commands: groupadd elsearch useradd elsearch -g elsearch -p elasticsearch chown -R elsearch:elsearch /roo…

[Previous page](https://discuss.elastic.co/top.md?page=4&per_page=50&period=all)

[Next page](https://discuss.elastic.co/top.md?page=6&per_page=50&period=all)
