# Top

**URL:** https://discuss.elastic.co/top.md?page=52&period=all

[Latest](https://discuss.elastic.co/latest.md) · [Categories](https://discuss.elastic.co/categories.md) · [Tags](https://discuss.elastic.co/tags.md)

**Page:** 53

---

## [How to craft watches for delta change anomalies?](https://discuss.elastic.co/t/how-to-craft-watches-for-delta-change-anomalies/27707)

<div class="topic-metadata">

**Author:** [@jchen2000](https://discuss.elastic.co/u/jchen2000)\
**Replies:** 11\
**Last updated:** [July 19, 2017, 2:55am UTC](https://discuss.elastic.co/t/how-to-craft-watches-for-delta-change-anomalies/27707 "2017-07-19T02:55:07Z")

</div>

I think this has been asked before by somebody but without answers. Basically the question is how to define a watch that can detect delta change anomalies in indices. Say, the frequency of document additions changes fro…

---

## [SAML SSO with WSO2 and Kibana](https://discuss.elastic.co/t/saml-sso-with-wso2-and-kibana/152482)

<div class="topic-metadata">

**Author:** [@subhomoy.mukherjee](https://discuss.elastic.co/u/subhomoy.mukherjee)\
**Replies:** 24\
**Last updated:** [October 30, 2018, 12:37pm UTC](https://discuss.elastic.co/t/saml-sso-with-wso2-and-kibana/152482 "2018-10-30T12:37:12Z")

</div>

Hello, I am new to Kibana and trying to work with WSO2 IS and Kibana for SSO. I want to embed Kibana dashboard in to my application (say appx) and using SAML SSO I want to achieve the following: Login to appx Goto das…

---

## [Issue in exporting Dashboard and visualizations](https://discuss.elastic.co/t/issue-in-exporting-dashboard-and-visualizations/116277)

<div class="topic-metadata">

**Author:** [@kabali12345](https://discuss.elastic.co/u/kabali12345)\
**Replies:** 44\
**Last updated:** [February 7, 2018, 9:33am UTC](https://discuss.elastic.co/t/issue-in-exporting-dashboard-and-visualizations/116277 "2018-02-07T09:33:25Z")

</div>

Hi all... can anyone help on this how can we export a dashboard and its related visualizations at a time. i appreciate the quick response. Thanks in advance.

---

## [I'm facing "NoNodeAvailableException" but doesn't now what I'm doing wrong!](https://discuss.elastic.co/t/im-facing-nonodeavailableexception-but-doesnt-now-what-im-doing-wrong/102806)

<div class="topic-metadata">

**Author:** [@sebF](https://discuss.elastic.co/u/sebF)\
**Replies:** 10\
**Last updated:** [October 6, 2017, 7:29am UTC](https://discuss.elastic.co/t/im-facing-nonodeavailableexception-but-doesnt-now-what-im-doing-wrong/102806 "2017-10-06T07:29:03Z")

</div>

Hi I create new topic because I did not find a solution to my pb in the other threads. My pb is that I face the following error when I try to perform a search query on elasticsearch thanks a java client: InetSocketAd…

---

## [Unassigned Shards with allocation\_status deciders\_no](https://discuss.elastic.co/t/unassigned-shards-with-allocation-status-deciders-no/83236)

<div class="topic-metadata">

**Author:** [@jspooner](https://discuss.elastic.co/u/jspooner)\
**Replies:** 14\
**Last updated:** [April 21, 2017, 6:57pm UTC](https://discuss.elastic.co/t/unassigned-shards-with-allocation-status-deciders-no/83236 "2017-04-21T18:57:15Z")

</div>

I'm restoring my data from S3 to a different cluster and some of my indexes are stuck in the UNASSIGNED state with an allocation\_status of deciders\_no. 1. Verify Snapshot It appears to be valid and some of the indexe…

---

## [LogStash does not appear to be receiving files from FileBeat](https://discuss.elastic.co/t/logstash-does-not-appear-to-be-receiving-files-from-filebeat/68485)

<div class="topic-metadata">

**Author:** [@Airn5475](https://discuss.elastic.co/u/Airn5475)\
**Replies:** 12\
**Last updated:** [December 13, 2016, 6:32am UTC](https://discuss.elastic.co/t/logstash-does-not-appear-to-be-receiving-files-from-filebeat/68485 "2016-12-13T06:32:43Z")

</div>

I am new to Filebeats and LogStash and am feeling overwhelmed. My goal is to take .json files in through Filebeats to LogStash and finally onto Elasticsearch. I am currently working on my local dev machine running Wind…

---

## [How to add first row first column value as a field in to other rows' documents of a csv file in logstash filters?](https://discuss.elastic.co/t/how-to-add-first-row-first-column-value-as-a-field-in-to-other-rows-documents-of-a-csv-file-in-logstash-filters/243806)

<div class="topic-metadata">

**Author:** [@DSMilestone](https://discuss.elastic.co/u/DSMilestone)\
**Replies:** 40\
**Last updated:** [September 6, 2020, 4:25am UTC](https://discuss.elastic.co/t/how-to-add-first-row-first-column-value-as-a-field-in-to-other-rows-documents-of-a-csv-file-in-logstash-filters/243806 "2020-09-06T04:25:00Z")

</div>

I was trying out logstash pipeline config file, in order to add the first row first column value to other documents as a new field. But I got no where! My csv file is, Suite/Test/Step Name,Browser,Description,Tag,Start…

---

## [Can i doing mathematical calculation in elasticsearch?](https://discuss.elastic.co/t/can-i-doing-mathematical-calculation-in-elasticsearch/126862)

<div class="topic-metadata">

**Author:** [@Fatemeh](https://discuss.elastic.co/u/Fatemeh)\
**Replies:** 18\
**Last updated:** [April 11, 2018, 6:42am UTC](https://discuss.elastic.co/t/can-i-doing-mathematical-calculation-in-elasticsearch/126862 "2018-04-11T06:42:41Z")

</div>

Hello, I am very new in Elastic search, my question is : can i do the mathematical calculations within elasticsearch like in Excel? I will be very happy if someone could help me

---

## [Logstash does not create index and doesn't give out any errors. Help](https://discuss.elastic.co/t/logstash-does-not-create-index-and-doesnt-give-out-any-errors-help/43630)

<div class="topic-metadata">

**Author:** [@MRamakri](https://discuss.elastic.co/u/MRamakri)\
**Replies:** 10\
**Last updated:** [March 8, 2016, 8:41pm UTC](https://discuss.elastic.co/t/logstash-does-not-create-index-and-doesnt-give-out-any-errors-help/43630 "2016-03-08T20:41:17Z")

</div>

Hi everyone, I'm new to Elasticsearch. I've been playing with Logstash, and I was able to create a couple of indexes using logstash. Now suddenly, it's not creating any indices. Whenever I run a conf file, it says star…

---

## [Metricbeat Unable to Connect to ElasticSearch, DNS Lookup Failed?](https://discuss.elastic.co/t/metricbeat-unable-to-connect-to-elasticsearch-dns-lookup-failed/154387)

<div class="topic-metadata">

**Author:** [@dlimantoro](https://discuss.elastic.co/u/dlimantoro)\
**Replies:** 10\
**Last updated:** [November 23, 2018, 1:31am UTC](https://discuss.elastic.co/t/metricbeat-unable-to-connect-to-elasticsearch-dns-lookup-failed/154387 "2018-11-23T01:31:43Z")

</div>

Hi, I have a server that hosts the elasticsearch (call it server A, it's located at 10.150.160.145) and my metricbeat is deployed to many servers on the same network. 9 out of 10 manages to send its metricbeat data to se…

---

## [Search multiple values for a single field](https://discuss.elastic.co/t/search-multiple-values-for-a-single-field/268327)

<div class="topic-metadata">

**Author:** [@subham\_p](https://discuss.elastic.co/u/subham_p)\
**Replies:** 12\
**Last updated:** [March 31, 2021, 11:52am UTC](https://discuss.elastic.co/t/search-multiple-values-for-a-single-field/268327 "2021-03-31T11:52:42Z")

</div>

Hii.. All , I am pretty new in elk search, I want to find out multiple values for a single field (diseases:” fever,covid\_19”) with in a must with wildcard condition here the data is like this Diseases: “fever, headache…

---

## [Centralizing Business Events : RFC for log4j2 appenders for Elasticsearch](https://discuss.elastic.co/t/centralizing-business-events-rfc-for-log4j2-appenders-for-elasticsearch/28250)

<div class="topic-metadata">

**Author:** [@Jeff\_Contour](https://discuss.elastic.co/u/Jeff_Contour)\
**Replies:** 11\
**Last updated:** [September 1, 2015, 7:24am UTC](https://discuss.elastic.co/t/centralizing-business-events-rfc-for-log4j2-appenders-for-elasticsearch/28250 "2015-09-01T07:24:15Z")

</div>

Centralizing Business events is a very common need that could be handled much more easily and this is the subject of this "Request For Comments". I tried to make it as short as possible. \[wink\] As opposed to a technica…

---

## [Optimal shards: 1 or number of nodes? Considerations](https://discuss.elastic.co/t/optimal-shards-1-or-number-of-nodes-considerations/141976)

<div class="topic-metadata">

**Author:** [@cdekker](https://discuss.elastic.co/u/cdekker)\
**Replies:** 9\
**Last updated:** [August 1, 2018, 2:20pm UTC](https://discuss.elastic.co/t/optimal-shards-1-or-number-of-nodes-considerations/141976 "2018-08-01T14:20:55Z")

</div>

The question of optimal number of shards per index has been asked before and it is almost always dependent on use-case. However, I am wondering what some of the considerations should be. Imagine the following setup: E…

---

## [Indexing large pdf document](https://discuss.elastic.co/t/indexing-large-pdf-document/22917)

<div class="topic-metadata">

**Author:** [@Jakko\_Sikkar](https://discuss.elastic.co/u/Jakko_Sikkar)\
**Replies:** 9\
**Last updated:** [August 18, 2016, 10:21am UTC](https://discuss.elastic.co/t/indexing-large-pdf-document/22917 "2016-08-18T10:21:22Z")

</div>

Hi, I'm trying to index big document with ES and Mapper Attachment plugin (https://github.com/elastic/elasticsearch-mapper-attachments). Document has 719 pages, but after indexing I can search phrases only up to p…

---

## [Syslogs from fortigate](https://discuss.elastic.co/t/syslogs-from-fortigate/141405)

<div class="topic-metadata">

**Author:** [@Marcos\_Felix](https://discuss.elastic.co/u/Marcos_Felix)\
**Replies:** 15\
**Last updated:** [July 26, 2018, 11:10am UTC](https://discuss.elastic.co/t/syslogs-from-fortigate/141405 "2018-07-26T11:10:13Z")

</div>

Hello, I just configured fortigate to send all the syslogs to logstash This is my logstash config file: filter { udp { port =\> 514 { if \[type\] == "SYSLOG" { grok { patterns\_dir =\> \["/etc/logstash…

---

## [Can we give parent/child relation ship between different indexes](https://discuss.elastic.co/t/can-we-give-parent-child-relation-ship-between-different-indexes/25872)

<div class="topic-metadata">

**Author:** [@anusha6](https://discuss.elastic.co/u/anusha6)\
**Replies:** 10\
**Last updated:** [July 20, 2015, 9:01am UTC](https://discuss.elastic.co/t/can-we-give-parent-child-relation-ship-between-different-indexes/25872 "2015-07-20T09:01:20Z")

</div>

Hi, I would like to give parent/ child relationship between three different indexes, where indexes are index1, index2, index3 with different types in those indexes.. May I know is it possible???

---

## [How to automatically set the server date/time when adding data?](https://discuss.elastic.co/t/how-to-automatically-set-the-server-date-time-when-adding-data/296708)

<div class="topic-metadata">

**Author:** [@vmassol](https://discuss.elastic.co/u/vmassol)\
**Replies:** 15\
**Last updated:** [February 10, 2022, 6:14pm UTC](https://discuss.elastic.co/t/how-to-automatically-set-the-server-date-time-when-adding-data/296708 "2022-02-10T18:14:13Z")

</div>

Hi there, In old ES versions, I was using the \_timestamp field but it's been removed and it's now recommended to set the date on the client side. However, I'm surprised to not find any easy way to continue to set it on …

---

## [The request for this panel failed. The aggregations key is missing](https://discuss.elastic.co/t/the-request-for-this-panel-failed-the-aggregations-key-is-missing/159575)

<div class="topic-metadata">

**Author:** [@ggoodenough](https://discuss.elastic.co/u/ggoodenough)\
**Replies:** 9\
**Last updated:** [December 14, 2018, 6:14pm UTC](https://discuss.elastic.co/t/the-request-for-this-panel-failed-the-aggregations-key-is-missing/159575 "2018-12-14T18:14:55Z")

</div>

So I'm running into this problem that a few others on this board have had problems with in the past. I'm somewhat confused about the problem so maybe someone could spend a minute or two to help understand the issue or po…

---

## [JDBC SQLite integration with logstash](https://discuss.elastic.co/t/jdbc-sqlite-integration-with-logstash/90801)

<div class="topic-metadata">

**Author:** [@floxtrott](https://discuss.elastic.co/u/floxtrott)\
**Replies:** 17\
**Last updated:** [June 28, 2017, 8:30am UTC](https://discuss.elastic.co/t/jdbc-sqlite-integration-with-logstash/90801 "2017-06-28T08:30:24Z")

</div>

Hi there, I have a bunch of SQlite files with multiple tables each that I want to integrate into ES. All of ES is installed on Debian using the deb packages. Integration is done using JDBC with the following input conf…

---

## [Heap Errors on ES 5.2.0](https://discuss.elastic.co/t/heap-errors-on-es-5-2-0/87213)

<div class="topic-metadata">

**Author:** [@Vikas\_Mestry](https://discuss.elastic.co/u/Vikas_Mestry)\
**Replies:** 19\
**Last updated:** [May 30, 2017, 8:42pm UTC](https://discuss.elastic.co/t/heap-errors-on-es-5-2-0/87213 "2017-05-30T20:42:02Z")

</div>

Hello, I am facing java.lang.OutOfMemoryError: Java heap space, errors resulting in cluster crash on ES 5.2.0, below is the log generated from one of the nodes in the cluster. This is a 5 node cluster with minimum 2 …

---

## [Using painless in watcher](https://discuss.elastic.co/t/using-painless-in-watcher/149063)

<div class="topic-metadata">

**Author:** [@nayun\_oh](https://discuss.elastic.co/u/nayun_oh)\
**Replies:** 19\
**Last updated:** [September 28, 2018, 7:58am UTC](https://discuss.elastic.co/t/using-painless-in-watcher/149063 "2018-09-28T07:58:35Z")

</div>

I want to use painless in watcher to add or change data of some fields. But when I added this code in this watcher, "transform": { "script": { "source": "ctx.\_source.period = ctx.\_source.duration/1000", "lang": "pai…

---

## [Filebeat seems not interact with Logstash - Windows](https://discuss.elastic.co/t/filebeat-seems-not-interact-with-logstash-windows/38720)

<div class="topic-metadata">

**Author:** [@john22122015](https://discuss.elastic.co/u/john22122015)\
**Replies:** 11\
**Last updated:** [July 27, 2016, 12:27pm UTC](https://discuss.elastic.co/t/filebeat-seems-not-interact-with-logstash-windows/38720 "2016-07-27T12:27:42Z")

</div>

Hi, Colleagues! I have installed ELK in Windows and runs successfully, creatings all indexes. But it need to be integrate with Filebeat. Then, the structure is FB \> LS \> ES. But, despite of promt says "2016/01/08 11:08…

---

## [Received plaintext http traffic on an https channel, closing connection Netty4HttpChannel](https://discuss.elastic.co/t/received-plaintext-http-traffic-on-an-https-channel-closing-connection-netty4httpchannel/266957)

<div class="topic-metadata">

**Author:** [@Andrea92](https://discuss.elastic.co/u/Andrea92)\
**Replies:** 9\
**Last updated:** [March 16, 2021, 9:26am UTC](https://discuss.elastic.co/t/received-plaintext-http-traffic-on-an-https-channel-closing-connection-netty4httpchannel/266957 "2021-03-16T09:26:04Z")

</div>

Buenas tardes, Soy nueva en estos foros, pero he visto que la mayoría de los problemas que me he encontrado con ELK los he podido solucionar gracias a este foro. Pero este problema lo llevo arrastrando ya más de 1 mes …

---

## [Out of memory? Exception is thrown and service shuts down](https://discuss.elastic.co/t/out-of-memory-exception-is-thrown-and-service-shuts-down/131978)

<div class="topic-metadata">

**Author:** [@MrAnderson](https://discuss.elastic.co/u/MrAnderson)\
**Replies:** 10\
**Last updated:** [May 20, 2018, 12:53pm UTC](https://discuss.elastic.co/t/out-of-memory-exception-is-thrown-and-service-shuts-down/131978 "2018-05-20T12:53:36Z")

</div>

Hello, I ran into issues with elasticsearch and I’m looking for advice or a solution. My Ruby on Rails application implements elasticsearch through elasticsearch-rails gem. Production server info: Intel(R) Xeon(R) CP…

---

## [LogStash:: How To Add a New Field, Then Populate It Based On Another Field's Value?](https://discuss.elastic.co/t/logstash-how-to-add-a-new-field-then-populate-it-based-on-another-fields-value/206193)

<div class="topic-metadata">

**Author:** [@redapplesonly](https://discuss.elastic.co/u/redapplesonly)\
**Replies:** 14\
**Last updated:** [November 7, 2019, 12:41am UTC](https://discuss.elastic.co/t/logstash-how-to-add-a-new-field-then-populate-it-based-on-another-fields-value/206193 "2019-11-07T00:41:10Z")

</div>

Hello Logstash Sorcerers, I am running Logstash v7.4.0 and Elasticsearch v7.4.0 in a nicely-working pipeline. My chain of fruit stores are sending my sales information to Logstash; Logstash then pushes that data to Ela…

---

## [What is HEAD request about?](https://discuss.elastic.co/t/what-is-head-request-about/45377)

<div class="topic-metadata">

**Author:** [@es\_noob](https://discuss.elastic.co/u/es_noob)\
**Replies:** 10\
**Last updated:** [March 24, 2016, 8:47pm UTC](https://discuss.elastic.co/t/what-is-head-request-about/45377 "2016-03-24T20:47:09Z")

</div>

Hi! I ran into two questions during indexing. 1) I saw a lot of HEAD request with 404 Not Found. I tried to find what HEAD request is about, but couldn't \[:frowning:\] 2) The cluster health is in yellow - although all…

---

## [Cannot reach Kibana on browser after installation](https://discuss.elastic.co/t/cannot-reach-kibana-on-browser-after-installation/35564)

<div class="topic-metadata">

**Author:** [@oleksii](https://discuss.elastic.co/u/oleksii)\
**Replies:** 10\
**Last updated:** [August 26, 2016, 11:38am UTC](https://discuss.elastic.co/t/cannot-reach-kibana-on-browser-after-installation/35564 "2016-08-26T11:38:07Z")

</div>

Hello guys. I am not a linux guru - just know how to do simple stuff. But I got a task to setup ELK. I am running Red Hat Enterprise Linux Server release 6.2 What I did so far: Installed Elastisearch, Logstash and K…

---

## [ES cluster with SSH and port forwarding, transport port 9300](https://discuss.elastic.co/t/es-cluster-with-ssh-and-port-forwarding-transport-port-9300/121642)

<div class="topic-metadata">

**Author:** [@Maxclac](https://discuss.elastic.co/u/Maxclac)\
**Replies:** 13\
**Last updated:** [March 21, 2018, 7:53pm UTC](https://discuss.elastic.co/t/es-cluster-with-ssh-and-port-forwarding-transport-port-9300/121642 "2018-03-21T19:53:43Z")

</div>

Hello everyone! I would like to set up an ES cluster consisting of three nodes, i.e. my local machine ('localhost') and two virtual machines in a remote network ('host1' and 'host2') For each of them, I have this very …

---

## [This site can’t be reached xxx.xxx.xx refused to connect](https://discuss.elastic.co/t/this-site-can-t-be-reached-xxx-xxx-xx-refused-to-connect/134293)

<div class="topic-metadata">

**Author:** [@krishnan\_radhakrishn](https://discuss.elastic.co/u/krishnan_radhakrishn)\
**Replies:** 11\
**Last updated:** [June 3, 2018, 12:45pm UTC](https://discuss.elastic.co/t/this-site-can-t-be-reached-xxx-xxx-xx-refused-to-connect/134293 "2018-06-03T12:45:49Z")

</div>

http://public-ip:5601, i get below error This site can’t be reached xxx.xxx.xx refused to connect. please help me to resolve

---

## [Kibana logout not working](https://discuss.elastic.co/t/kibana-logout-not-working/135389)

<div class="topic-metadata">

**Author:** [@Elango-mas](https://discuss.elastic.co/u/Elango-mas)\
**Replies:** 11\
**Last updated:** [June 26, 2018, 8:33am UTC](https://discuss.elastic.co/t/kibana-logout-not-working/135389 "2018-06-26T08:33:15Z")

</div>

Hi Experts, I have Elasticsearch and kibana instances set for SSO with SAML realm setting. #Elasticsearch.yml xpack.security.authc.token.enabled: true xpack.security.authc.realms.saml1: type: saml order: 2 idp.met…

---

## [Filebeat connect with Kafka Kerberos(SASL\_SSL) not working](https://discuss.elastic.co/t/filebeat-connect-with-kafka-kerberos-sasl-ssl-not-working/246160)

<div class="topic-metadata">

**Author:** [@chandramouli\_sriniva](https://discuss.elastic.co/u/chandramouli_sriniva)\
**Replies:** 9\
**Last updated:** [October 15, 2020, 1:41pm UTC](https://discuss.elastic.co/t/filebeat-connect-with-kafka-kerberos-sasl-ssl-not-working/246160 "2020-10-15T13:41:49Z")

</div>

Hi - I am using Filebeat 7.9 version. using filebeat, read data from log file and push to kafka topic. our Kafka use SASL\_SSL with Kerberos mechanism. when I set up with below parms, it errors out. kerberos.enabled: "tr…

---

## [Is Elasticsearch as a primary database better than Oracle?](https://discuss.elastic.co/t/is-elasticsearch-as-a-primary-database-better-than-oracle/236970)

<div class="topic-metadata">

**Author:** [@liron\_gofberg](https://discuss.elastic.co/u/liron_gofberg)\
**Replies:** 12\
**Last updated:** [July 9, 2020, 5:25pm UTC](https://discuss.elastic.co/t/is-elasticsearch-as-a-primary-database-better-than-oracle/236970 "2020-07-09T17:25:04Z")

</div>

Hi, I am a student and my project is about Elastic Stack. the company I work for is currently using oracle for managing its data. they want assess Elasticsearch as a replacement. according to my project success they …

---

## [Add day to datetime field](https://discuss.elastic.co/t/add-day-to-datetime-field/162711)

<div class="topic-metadata">

**Author:** [@jpaz93](https://discuss.elastic.co/u/jpaz93)\
**Replies:** 12\
**Last updated:** [January 10, 2019, 1:42pm UTC](https://discuss.elastic.co/t/add-day-to-datetime-field/162711 "2019-01-10T13:42:45Z")

</div>

Hello, I need help with the following: I need to add days to a datetime field I have different indices with datetime fields: "created\_at": "2018-12-21 15:29:53", "created\_at": "2018-12-21 15:32:11", "created\_at": "…

---

## [Elasticsearch Engineer (On-Demand) : Unable to Access Lab Instructions : 404 Not Found](https://discuss.elastic.co/t/elasticsearch-engineer-on-demand-unable-to-access-lab-instructions-404-not-found/380040)

<div class="topic-metadata">

**Author:** [@limed3](https://discuss.elastic.co/u/limed3)\
**Replies:** 15\
**Last updated:** [July 25, 2025, 8:37pm UTC](https://discuss.elastic.co/t/elasticsearch-engineer-on-demand-unable-to-access-lab-instructions-404-not-found/380040 "2025-07-25T20:37:08Z")

</div>

Course: Elasticsearch Engineer (On-Demand) Version: On-Demand Question: When clicking Labs button in strigo to access lab instructions the page is always 404 Not Found, refreshing does not work to load it. (See screens…

---

## [Shard size, count, how to stay fast and less GC?](https://discuss.elastic.co/t/shard-size-count-how-to-stay-fast-and-less-gc/28180)

<div class="topic-metadata">

**Author:** [@Dinoshauer](https://discuss.elastic.co/u/Dinoshauer)\
**Replies:** 13\
**Last updated:** [October 15, 2015, 6:01pm UTC](https://discuss.elastic.co/t/shard-size-count-how-to-stay-fast-and-less-gc/28180 "2015-10-15T18:01:41Z")

</div>

Hey everybody! We have a "tiered" setup where T1 has the warmest data and T2 keeps the rest. There are 24 data nodes in the cluster with 3 masters (that are not being queried). T1 has 6 machines and T2 has the rest (1…

---

## [CAT api doesn't respond](https://discuss.elastic.co/t/cat-api-doesnt-respond/162596)

<div class="topic-metadata">

**Author:** [@sumanthkumarc](https://discuss.elastic.co/u/sumanthkumarc)\
**Replies:** 11\
**Last updated:** [February 12, 2019, 5:35am UTC](https://discuss.elastic.co/t/cat-api-doesnt-respond/162596 "2019-02-12T05:35:46Z")

</div>

Hi, I have a 4 node elasticsearch cluster on version 5.6.9, all running on containers with persistent backend and with a haproxy load balancer infront. At times there seems to be issue with only CAT api not responding. …

---

## [Basic nested JSON parse failure](https://discuss.elastic.co/t/basic-nested-json-parse-failure/41013)

<div class="topic-metadata">

**Author:** [@Patrick\_Barker](https://discuss.elastic.co/u/Patrick_Barker)\
**Replies:** 10\
**Last updated:** [January 19, 2017, 4:24pm UTC](https://discuss.elastic.co/t/basic-nested-json-parse-failure/41013 "2017-01-19T16:24:14Z")

</div>

Hey, I am new to log stash and surely I must be doing someone wrong. When I sending basic nested json from python 3 it fails: Message=json.dumps({'default': 'default', 'time': 'again', 'this': {'go': 'by'}}) My log s…

---

## [Everyone faced this issue?](https://discuss.elastic.co/t/everyone-faced-this-issue/205576)

<div class="topic-metadata">

**Author:** [@pbona](https://discuss.elastic.co/u/pbona)\
**Replies:** 34\
**Last updated:** [November 1, 2019, 2:13am UTC](https://discuss.elastic.co/t/everyone-faced-this-issue/205576 "2019-11-01T02:13:25Z")

</div>

\[2019-10-28T01:43:36,493\]\[INFO \]\[logstash.agent \] Successfully started Logstash API endpoint {:port=\>9600} \[2019-10-28T01:43:41,249\]\[INFO \]\[logstash.runner \] Logstash shut down. \[2019-10-28T01:44:13,…

---

## [Data loading into ES index is very slow](https://discuss.elastic.co/t/data-loading-into-es-index-is-very-slow/69164)

<div class="topic-metadata">

**Author:** [@udaykirankona](https://discuss.elastic.co/u/udaykirankona)\
**Replies:** 12\
**Last updated:** [January 19, 2017, 9:17am UTC](https://discuss.elastic.co/t/data-loading-into-es-index-is-very-slow/69164 "2017-01-19T09:17:47Z")

</div>

HI, I am trying to load data from Mysql to elasticsearch using logstash, but its loading very slow. 6500/minute into elasticsearch. The following is my Logstash config input { jdbc { type =\> "type" jdbc\_dri…

---

## [Very high disk IO while indexing](https://discuss.elastic.co/t/very-high-disk-io-while-indexing/11199)

<div class="topic-metadata">

**Author:** [@Bruno\_Miranda](https://discuss.elastic.co/u/Bruno_Miranda)\
**Replies:** 9\
**Last updated:** [March 20, 2013, 9:44pm UTC](https://discuss.elastic.co/t/very-high-disk-io-while-indexing/11199 "2013-03-20T21:44:09Z")

</div>

While indexing to our QA environment, 2 nodes (EC2 m1.large) each with 2 CPUs 7.3 GBs RAM I am seeing exceptionally high Disk IO. http://cl.ly/image/371H01382h2O I have about 20 processes indexing simultaneously.…

---

## [Kibana v7.16.1 login issue. Not able to login (ResponseError: version\_conflict\_engine\_exception)](https://discuss.elastic.co/t/kibana-v7-16-1-login-issue-not-able-to-login-responseerror-version-conflict-engine-exception/308670)

<div class="topic-metadata">

**Author:** [@Avinash\_09](https://discuss.elastic.co/u/Avinash_09)\
**Replies:** 35\
**Last updated:** [September 14, 2022, 1:22pm UTC](https://discuss.elastic.co/t/kibana-v7-16-1-login-issue-not-able-to-login-responseerror-version-conflict-engine-exception/308670 "2022-09-14T13:22:29Z")

</div>

Hello, We are on v7.16.1 of Kibana/Elastic and facing issues with Kibana login all of a sudden. It was working fine around couple of hours back When checked in the logs seeing below exceptions. {"type":"log","@times…

---

## [ElasticSearch Indexing question](https://discuss.elastic.co/t/elasticsearch-indexing-question/35845)

<div class="topic-metadata">

**Author:** [@Yorko](https://discuss.elastic.co/u/Yorko)\
**Replies:** 21\
**Last updated:** [December 30, 2015, 11:30pm UTC](https://discuss.elastic.co/t/elasticsearch-indexing-question/35845 "2015-12-30T23:30:32Z")

</div>

Hi, Is there an easy way to index a lot of documents into ES db? i was thinking or using a CMS of sorts that is hooked up to ES.

---

## [Discovery multicast vs unicast](https://discuss.elastic.co/t/discovery-multicast-vs-unicast/6505)

<div class="topic-metadata">

**Author:** [@Wes\_Plunk](https://discuss.elastic.co/u/Wes_Plunk)\
**Replies:** 12\
**Last updated:** [January 27, 2012, 4:21pm UTC](https://discuss.elastic.co/t/discovery-multicast-vs-unicast/6505 "2012-01-27T16:21:39Z")

</div>

multicast discovery or unicast discovery? Would someone explain the differences? Primarily in how flexible the cluster/node design will be. I'm wanting to be able to spin up new nodes without having to require the j…

---

## [Help with conf file to process log with binary data](https://discuss.elastic.co/t/help-with-conf-file-to-process-log-with-binary-data/110734)

<div class="topic-metadata">

**Author:** [@sconrod](https://discuss.elastic.co/u/sconrod)\
**Replies:** 15\
**Last updated:** [December 22, 2017, 11:06pm UTC](https://discuss.elastic.co/t/help-with-conf-file-to-process-log-with-binary-data/110734 "2017-12-22T23:06:05Z")

</div>

Hi I have log files that contains some binary data. For now I just wanted to try to ingest them using stdin and then later build a grok filter. However, it is not ingesting the first log file, no error, it just hangs. M…

---

## [Logstash - how to configure CSV filter for joining 2 CSV files based on a common field and send the joined log to ES](https://discuss.elastic.co/t/logstash-how-to-configure-csv-filter-for-joining-2-csv-files-based-on-a-common-field-and-send-the-joined-log-to-es/167125)

<div class="topic-metadata">

**Author:** [@cheriemilk](https://discuss.elastic.co/u/cheriemilk)\
**Replies:** 28\
**Last updated:** [February 28, 2019, 1:29pm UTC](https://discuss.elastic.co/t/logstash-how-to-configure-csv-filter-for-joining-2-csv-files-based-on-a-common-field-and-send-the-joined-log-to-es/167125 "2019-02-28T13:29:55Z")

</div>

Hi Team, I need your help for my below scenario which I am suffering a lot since last week. I googled a lot but can't figure out a good anwser for my case. My Scenario is I have 2 CVS file which contains a same column …

---

## [Elasticsearch 1.6 reboot problem on ubuntu](https://discuss.elastic.co/t/elasticsearch-1-6-reboot-problem-on-ubuntu/2451)

<div class="topic-metadata">

**Author:** [@arno](https://discuss.elastic.co/u/arno)\
**Replies:** 9\
**Last updated:** [July 28, 2015, 6:41pm UTC](https://discuss.elastic.co/t/elasticsearch-1-6-reboot-problem-on-ubuntu/2451 "2015-07-28T18:41:21Z")

</div>

Hi Everyone, Has anyone here installed the latest version of Elasticsearch on a Ubuntu? If so you might have encountered the elasticsearch PID\_DIT issue when rebooting the Ubuntu server. The file PID file is written…

---

## [Server.basePath redirect loop with Shield](https://discuss.elastic.co/t/server-basepath-redirect-loop-with-shield/46594)

<div class="topic-metadata">

**Author:** [@Jakauppila](https://discuss.elastic.co/u/Jakauppila)\
**Replies:** 11\
**Last updated:** [April 12, 2016, 5:06pm UTC](https://discuss.elastic.co/t/server-basepath-redirect-loop-with-shield/46594 "2016-04-12T17:06:03Z")

</div>

I'm running Kibana 4.5.0 against Elasticsearch 2.3.1 with Shield and am trying to configure multiple Kibana instances on a single URL, to achieve this I was looking at specifying server.basePath within kibana.yml se…

---

## [How to Capture the data from a DB server using a query and visualise in kibana](https://discuss.elastic.co/t/how-to-capture-the-data-from-a-db-server-using-a-query-and-visualise-in-kibana/40349)

<div class="topic-metadata">

**Author:** [@chaitanyap](https://discuss.elastic.co/u/chaitanyap)\
**Replies:** 16\
**Last updated:** [February 16, 2016, 11:54am UTC](https://discuss.elastic.co/t/how-to-capture-the-data-from-a-db-server-using-a-query-and-visualise-in-kibana/40349 "2016-02-16T11:54:48Z")

</div>

Hi All, We have requirement to capture the data from a remote DB server using a DB query/table and visualise that metrics into dash board. Is there any step by step procedure available to get it done? Thanks, Chaita…

---

## [Repository\_verification\_exception while creating new repository in snapshot](https://discuss.elastic.co/t/repository-verification-exception-while-creating-new-repository-in-snapshot/297483)

<div class="topic-metadata">

**Author:** [@Darshil\_Shah](https://discuss.elastic.co/u/Darshil_Shah)\
**Replies:** 14\
**Last updated:** [February 18, 2022, 10:55am UTC](https://discuss.elastic.co/t/repository-verification-exception-while-creating-new-repository-in-snapshot/297483 "2022-02-18T10:55:35Z")

</div>

we are running 3 node Elasticsearch setup where all of the nodes are master in kubernetes . i have installed s3 plugin for Elasticsearch and provided access key and secret key . whenever i create a repository and verif…

---

## [Check Kibana max-old-space-size](https://discuss.elastic.co/t/check-kibana-max-old-space-size/245310)

<div class="topic-metadata">

**Author:** [@VeeT](https://discuss.elastic.co/u/VeeT)\
**Replies:** 9\
**Last updated:** [September 15, 2020, 2:45pm UTC](https://discuss.elastic.co/t/check-kibana-max-old-space-size/245310 "2020-09-15T14:45:13Z")

</div>

Hi, I tried adding --max-old-space-size=2048 into the bin/kibana file under NODE\_OPTIONS. How do I check that this came in effect? Thanks!

[Previous page](https://discuss.elastic.co/top.md?page=51&per_page=50&period=all)

[Next page](https://discuss.elastic.co/top.md?page=53&per_page=50&period=all)
