# Top

**URL:** https://discuss.elastic.co/top.md?page=54&period=all

[Latest](https://discuss.elastic.co/latest.md) · [Categories](https://discuss.elastic.co/categories.md) · [Tags](https://discuss.elastic.co/tags.md)

**Page:** 55

---

## [Nested query error](https://discuss.elastic.co/t/nested-query-error/64310)

<div class="topic-metadata">

**Author:** [@Madhur\_Bhardwaj](https://discuss.elastic.co/u/Madhur_Bhardwaj)\
**Replies:** 17\
**Last updated:** [November 2, 2016, 1:10pm UTC](https://discuss.elastic.co/t/nested-query-error/64310 "2016-11-02T13:10:20Z")

</div>

Hi, I am new to elasticsearch and currently working with nested objects and query... I am able to create a nested object but when trying to query it using nested query syntax getting error in field name ... the error s…

---

## [Fix broken cluster with elasticsearch-node detach-cluster not working](https://discuss.elastic.co/t/fix-broken-cluster-with-elasticsearch-node-detach-cluster-not-working/260070)

<div class="topic-metadata">

**Author:** [@ebuildy](https://discuss.elastic.co/u/ebuildy)\
**Replies:** 17\
**Last updated:** [January 4, 2021, 5:58pm UTC](https://discuss.elastic.co/t/fix-broken-cluster-with-elasticsearch-node-detach-cluster-not-working/260070 "2021-01-04T17:58:28Z")

</div>

I want to fix a broken cluster (when a node cannot join because differente cluster UUID by exemple) without removing all data folder (the dirty solution I can see every time....), currently I am testing it, using officia…

---

## ["There is no data to display" on metric page](https://discuss.elastic.co/t/there-is-no-data-to-display-on-metric-page/185361)

<div class="topic-metadata">

**Author:** [@aqiank](https://discuss.elastic.co/u/aqiank)\
**Replies:** 17\
**Last updated:** [June 15, 2019, 4:20am UTC](https://discuss.elastic.co/t/there-is-no-data-to-display-on-metric-page/185361 "2019-06-15T04:20:22Z")

</div>

I found this message in one of the HTTP requests when loading the metrics page. \[illegal\_argument\_exception\] Fielddata is disabled on text fields by default. Set fielddata=true on \[host.name\] in order to load fielddata …

---

## [How i can calculate the cluster nodes size like RAM, CPU and Disk](https://discuss.elastic.co/t/how-i-can-calculate-the-cluster-nodes-size-like-ram-cpu-and-disk/283933)

<div class="topic-metadata">

**Author:** [@elastic\_dev](https://discuss.elastic.co/u/elastic_dev)\
**Replies:** 9\
**Last updated:** [September 20, 2021, 5:14am UTC](https://discuss.elastic.co/t/how-i-can-calculate-the-cluster-nodes-size-like-ram-cpu-and-disk/283933 "2021-09-20T05:14:56Z")

</div>

HI, I am trying to figure how should I calculate my nodes size, its RAM, CPU, and Disk. If I have data of around 10G. On basis of what I should calculate nodes size. Can anyone guide me, please?

---

## [My elasticsearch doesn't work](https://discuss.elastic.co/t/my-elasticsearch-doesnt-work/32997)

<div class="topic-metadata">

**Author:** [@billy6](https://discuss.elastic.co/u/billy6)\
**Replies:** 22\
**Last updated:** [November 3, 2015, 8:14am UTC](https://discuss.elastic.co/t/my-elasticsearch-doesnt-work/32997 "2015-11-03T08:14:16Z")

</div>

Hello, this morning I have seen that suddenly kibana didn't represent any message. I have seen that the problem is in elasticsearch but the cluster health is yellow (it seems to be OK), however everytime I want to send …

---

## [Data going into wrong index-why](https://discuss.elastic.co/t/data-going-into-wrong-index-why/124869)

<div class="topic-metadata">

**Author:** [@chandukreddi](https://discuss.elastic.co/u/chandukreddi)\
**Replies:** 14\
**Last updated:** [March 21, 2018, 8:34pm UTC](https://discuss.elastic.co/t/data-going-into-wrong-index-why/124869 "2018-03-21T20:34:26Z")

</div>

Hello Experts, Different type of logs going into single index, technically it should go to different new (defined) indexes. I am differentiating 2 different log files with TAG and then applying filter on TAG in logstas…

---

## [Applying SSL to Elasticsearch and Kibana: Connection refused on Kibana](https://discuss.elastic.co/t/applying-ssl-to-elasticsearch-and-kibana-connection-refused-on-kibana/358493)

<div class="topic-metadata">

**Author:** [@riahc3](https://discuss.elastic.co/u/riahc3)\
**Replies:** 55\
**Last updated:** [May 16, 2024, 2:50pm UTC](https://discuss.elastic.co/t/applying-ssl-to-elasticsearch-and-kibana-connection-refused-on-kibana/358493 "2024-05-16T14:50:39Z")

</div>

Hello I just configured Elastic and Kibana to use SSL but Im getting a connection refused and errors about Kibana not being able to connect elasticsearch.yml: # Enable security features xpack.security.enabled: true x…

---

## [Can't connect hosts to the Fleet Server](https://discuss.elastic.co/t/cant-connect-hosts-to-the-fleet-server/286450)

<div class="topic-metadata">

**Author:** [@Dmitriy\_Esin](https://discuss.elastic.co/u/Dmitriy_Esin)\
**Replies:** 17\
**Last updated:** [October 13, 2021, 11:26am UTC](https://discuss.elastic.co/t/cant-connect-hosts-to-the-fleet-server/286450 "2021-10-13T11:26:17Z")

</div>

Hi all! I need your help! I have a self-hosted ELK (not cloud) I've enrolled the Fleet Server for SIEM using this manual for a self-managed server with default parameters in elastic-agent.yml I need to connect hosts …

---

## [Grok in realtime fails but in Debuuger works happy](https://discuss.elastic.co/t/grok-in-realtime-fails-but-in-debuuger-works-happy/552)

<div class="topic-metadata">

**Author:** [@tassa](https://discuss.elastic.co/u/tassa)\
**Replies:** 14\
**Last updated:** [May 20, 2015, 5:58am UTC](https://discuss.elastic.co/t/grok-in-realtime-fails-but-in-debuuger-works-happy/552 "2015-05-20T05:58:30Z")

</div>

Hello Everyone im trying to parse my fotigate firewal logs with Grok Plese help im getting this failure message "grokparsefailuresysloginput" (kibana gui) but Grok debuggr works fine im using logstash 1.5.…

---

## [Elastic Search Result](https://discuss.elastic.co/t/elastic-search-result/33170)

<div class="topic-metadata">

**Author:** [@pranesh002](https://discuss.elastic.co/u/pranesh002)\
**Replies:** 14\
**Last updated:** [November 2, 2015, 4:29pm UTC](https://discuss.elastic.co/t/elastic-search-result/33170 "2015-11-02T16:29:37Z")

</div>

Hi Team, I have a sample user document which i am indexing by userName. While querying instead of retrieving all fields i just need userName and address2, so i added the required fields in my query. It is just returnin…

---

## [Index binary files (PDF, ...)](https://discuss.elastic.co/t/index-binary-files-pdf/4808)

<div class="topic-metadata">

**Author:** [@Frifri](https://discuss.elastic.co/u/Frifri)\
**Replies:** 19\
**Last updated:** [June 2, 2017, 7:36am UTC](https://discuss.elastic.co/t/index-binary-files-pdf/4808 "2017-06-02T07:36:34Z")

</div>

Hey everybody, at the moment I'm testing ES for the use as an indexing and storaging solution. I use the following general settings with analysis-icu and mapper-attachments plugins enabled: curl -XPUT 'http://loc…

---

## [Watcher compare condition not generating any hits](https://discuss.elastic.co/t/watcher-compare-condition-not-generating-any-hits/2192)

<div class="topic-metadata">

**Author:** [@Ajit\_Bhingarkar](https://discuss.elastic.co/u/Ajit_Bhingarkar)\
**Replies:** 21\
**Last updated:** [June 10, 2015, 11:44am UTC](https://discuss.elastic.co/t/watcher-compare-condition-not-generating-any-hits/2192 "2015-06-10T11:44:07Z")

</div>

Hi, I have configured 4 wathes; and see that they get triggered fine. However compare condition is not met and no action is taken. Can you pls advice if anything is wrong with these conditions? I am attaching couple…

---

## [Logstash output creating error](https://discuss.elastic.co/t/logstash-output-creating-error/288161)

<div class="topic-metadata">

**Author:** [@BeMoore](https://discuss.elastic.co/u/BeMoore)\
**Replies:** 25\
**Last updated:** [November 5, 2021, 9:39am UTC](https://discuss.elastic.co/t/logstash-output-creating-error/288161 "2021-11-05T09:39:45Z")

</div>

Hi all, I have a weird error i can't nail down. Running 7.15.1 ES / Logstash I have a simple Logstash conf thats listening on a port for beats data and it should just push it to an index. input { beats { p…

---

## [Custom variables in Kibana Alerts](https://discuss.elastic.co/t/custom-variables-in-kibana-alerts/249986)

<div class="topic-metadata">

**Author:** [@Ankur\_Mahajan](https://discuss.elastic.co/u/Ankur_Mahajan)\
**Replies:** 15\
**Last updated:** [September 30, 2020, 7:35am UTC](https://discuss.elastic.co/t/custom-variables-in-kibana-alerts/249986 "2020-09-30T07:35:31Z")

</div>

I am exploring alerts and connectors in Kibana. I can configure and test them perfectly but I am unable to use the custom variable present in metricbeat, filebeat or any other beat module index. Let me explain this by an…

---

## [Grok filter not extracting fields](https://discuss.elastic.co/t/grok-filter-not-extracting-fields/127960)

<div class="topic-metadata">

**Author:** [@jarnold](https://discuss.elastic.co/u/jarnold)\
**Replies:** 27\
**Last updated:** [April 16, 2018, 3:20pm UTC](https://discuss.elastic.co/t/grok-filter-not-extracting-fields/127960 "2018-04-16T15:20:54Z")

</div>

Hi All, I've created the following grok filter; %{TIMESTAMP\_ISO8601:Date} %{SYSLOG5424SD:Client\_IP} %{WORD:Log\_Level} %{JAVACLASS:Java\_Class} %{GREEDYDATA:Freeform\_Text} Which appears to be working according to the gr…

---

## [Spring MVC project with ElasticSearch integration](https://discuss.elastic.co/t/spring-mvc-project-with-elasticsearch-integration/42379)

<div class="topic-metadata">

**Author:** [@farooqrahu](https://discuss.elastic.co/u/farooqrahu)\
**Replies:** 9\
**Last updated:** [February 24, 2016, 4:34am UTC](https://discuss.elastic.co/t/spring-mvc-project-with-elasticsearch-integration/42379 "2016-02-24T04:34:39Z")

</div>

Hi All, I have created project Spring MVC project with ElasticSearch integration. i am able to save data on elasticsearch-1.7.3 with nested fields now i want to retrieve my lists. here is my code how i work... //…

---

## [Filebeats 6.2.3 system module not sending logs](https://discuss.elastic.co/t/filebeats-6-2-3-system-module-not-sending-logs/125954)

<div class="topic-metadata">

**Author:** [@copenlc](https://discuss.elastic.co/u/copenlc)\
**Replies:** 20\
**Last updated:** [April 2, 2018, 2:54pm UTC](https://discuss.elastic.co/t/filebeats-6-2-3-system-module-not-sending-logs/125954 "2018-04-02T14:54:15Z")

</div>

Hey guys so I am having issues with the System module for Filebeats 6.2.3 not actually uploading the syslog or message log on either Cent or Debian systems. I am getting data from the icinga module on these systems, so …

---

## [How to differentiate the logs in Kibana dashboard](https://discuss.elastic.co/t/how-to-differentiate-the-logs-in-kibana-dashboard/26151)

<div class="topic-metadata">

**Author:** [@abathula](https://discuss.elastic.co/u/abathula)\
**Replies:** 11\
**Last updated:** [December 7, 2016, 11:13am UTC](https://discuss.elastic.co/t/how-to-differentiate-the-logs-in-kibana-dashboard/26151 "2016-12-07T11:13:13Z")

</div>

I have the Requirement like, I have the different types of logs from different service components i.e, 1. AKPOS service log 2. XE Services log 3. Performance Service log Path for input file: Using this path, …

---

## [How to improve the data import speed](https://discuss.elastic.co/t/how-to-improve-the-data-import-speed/120309)

<div class="topic-metadata">

**Author:** [@Eric\_Yin](https://discuss.elastic.co/u/Eric_Yin)\
**Replies:** 10\
**Last updated:** [February 19, 2018, 3:44pm UTC](https://discuss.elastic.co/t/how-to-improve-the-data-import-speed/120309 "2018-02-19T15:44:24Z")

</div>

Dear ELK developers, I use the elasticsearch to store the telecommunication level big data which involve more than 3000 fields and relative more than 1000 formula(scripted). I already use bulk to import the data with n…

---

## [Logstash GROK for single letter](https://discuss.elastic.co/t/logstash-grok-for-single-letter/62018)

<div class="topic-metadata">

**Author:** [@Senz79](https://discuss.elastic.co/u/Senz79)\
**Replies:** 11\
**Last updated:** [October 3, 2016, 5:53am UTC](https://discuss.elastic.co/t/logstash-grok-for-single-letter/62018 "2016-10-03T05:53:23Z")

</div>

i have the below log please help me to parse it as I am not able to go beyond, date and time \[Fri Aug 05 11:32:10 2016\] \[D\] \[17819(139987138922464)\] checking \[/libs/granite/csrf/token.json\]

---

## [How can i add a field to the original message (json) that was sent to logstash?](https://discuss.elastic.co/t/how-can-i-add-a-field-to-the-original-message-json-that-was-sent-to-logstash/130276)

<div class="topic-metadata">

**Author:** [@awatkins](https://discuss.elastic.co/u/awatkins)\
**Replies:** 14\
**Last updated:** [May 3, 2018, 12:18pm UTC](https://discuss.elastic.co/t/how-can-i-add-a-field-to-the-original-message-json-that-was-sent-to-logstash/130276 "2018-05-03T12:18:43Z")

</div>

I have a log message that is a json file. I would like to add a field to that original message within the json structure. I've tried multiple ways of doing it and none of them get the job done. I have trouble with the…

---

## [MS SQL monitoring with Filebeat?](https://discuss.elastic.co/t/ms-sql-monitoring-with-filebeat/252392)

<div class="topic-metadata">

**Author:** [@ManuelF](https://discuss.elastic.co/u/ManuelF)\
**Replies:** 10\
**Last updated:** [October 20, 2020, 8:10pm UTC](https://discuss.elastic.co/t/ms-sql-monitoring-with-filebeat/252392 "2020-10-20T20:10:21Z")

</div>

Hi, Note: - Using ELK 7.9.2 in Debian 10 - MS SQL Server 2016 SP2 Standard in Windows Server 2012 I want to start monitoring my MS SQL Server with Elasticsearch and visualize the data in Kibana. After some research I…

---

## [SSLHandshakeException when using High Level REST Client from Docker](https://discuss.elastic.co/t/sslhandshakeexception-when-using-high-level-rest-client-from-docker/184891)

<div class="topic-metadata">

**Author:** [@Ewoks](https://discuss.elastic.co/u/Ewoks)\
**Replies:** 11\
**Last updated:** [June 13, 2019, 11:26am UTC](https://discuss.elastic.co/t/sslhandshakeexception-when-using-high-level-rest-client-from-docker/184891 "2019-06-13T11:26:24Z")

</div>

I am trying to access 6.x ES instance using High Level REST Client 6.7.2. Access to this ES instance is provided to me via hostname (https://\*\*\*\*.azureedge.net), username & password. My Spring Boot application is getti…

---

## [Wildcard Query within a Span](https://discuss.elastic.co/t/wildcard-query-within-a-span/9607)

<div class="topic-metadata">

**Author:** [@Michael\_Sander](https://discuss.elastic.co/u/Michael_Sander)\
**Replies:** 22\
**Last updated:** [March 18, 2016, 2:09pm UTC](https://discuss.elastic.co/t/wildcard-query-within-a-span/9607 "2016-03-18T14:09:39Z")

</div>

Hi, Is it possible to construct an elasticsearch query (or filter) that detects whether two words with wildcards are within a certain distance of each other. Is this possible with elasticsearch? For example, I …

---

## [Kibana is not running](https://discuss.elastic.co/t/kibana-is-not-running/42842)

<div class="topic-metadata">

**Author:** [@babeesh](https://discuss.elastic.co/u/babeesh)\
**Replies:** 9\
**Last updated:** [March 2, 2016, 4:09am UTC](https://discuss.elastic.co/t/kibana-is-not-running/42842 "2016-03-02T04:09:53Z")

</div>

Installed ELK on AWS ubuntu 14.04. ELK versions : Elasticsearch 2.2.x, Logstash 2.2.x, and Kibana 4.4.x. While checking the status elasticsearch and logstash are running, but kibana is not running. I will share the re…

---

## [New Plugin logstash-input-proc Linux /proc parser](https://discuss.elastic.co/t/new-plugin-logstash-input-proc-linux-proc-parser/2098)

<div class="topic-metadata">

**Author:** [@eperry](https://discuss.elastic.co/u/eperry)\
**Replies:** 11\
**Last updated:** [April 6, 2017, 4:27pm UTC](https://discuss.elastic.co/t/new-plugin-logstash-input-proc-linux-proc-parser/2098 "2017-04-06T16:27:49Z")

</div>

Hi everyone, I wanted to let you know about a new plugin. I wanted to start pulling statistics from the operating system and could not figure out how to get logstash/grock to parse some of the file formats. So, to avoid …

---

## [Shield Authentication Error](https://discuss.elastic.co/t/shield-authentication-error/44185)

<div class="topic-metadata">

**Author:** [@piyush](https://discuss.elastic.co/u/piyush)\
**Replies:** 11\
**Last updated:** [April 5, 2016, 1:02pm UTC](https://discuss.elastic.co/t/shield-authentication-error/44185 "2016-04-05T13:02:58Z")

</div>

Hi, I am using esuser realm and getting auth error, i guess it's not taking esuser as basic realm. Can you suggest what should i try? Create User: /shield/esusers useradd --admin roles admin Error: {"error":{"root\_ca…

---

## [Replace @timestamp in kibana / logstash with time attribute of my log](https://discuss.elastic.co/t/replace-timestamp-in-kibana-logstash-with-time-attribute-of-my-log/94064)

<div class="topic-metadata">

**Author:** [@diooda](https://discuss.elastic.co/u/diooda)\
**Replies:** 21\
**Last updated:** [August 14, 2017, 8:51am UTC](https://discuss.elastic.co/t/replace-timestamp-in-kibana-logstash-with-time-attribute-of-my-log/94064 "2017-08-14T08:51:31Z")

</div>

I want to do replace @timestamp in kibana / logstash, want to change to the time attribute in my logfile ,, what should i do? thank you :slight\_smile:

---

## [Create index fails using 'PUT' over Java's HttpURLConnection](https://discuss.elastic.co/t/create-index-fails-using-put-over-javas-httpurlconnection/180849)

<div class="topic-metadata">

**Author:** [@n2nelastic](https://discuss.elastic.co/u/n2nelastic)\
**Replies:** 26\
**Last updated:** [June 20, 2019, 4:17pm UTC](https://discuss.elastic.co/t/create-index-fails-using-put-over-javas-httpurlconnection/180849 "2019-06-20T16:17:54Z")

</div>

I'm using Java and send a 'PUT' request to create a new index over an HttpURLConnection. The url is: http://localhost:9200/myIndexName I've used 2 content-types: text/plain and application/json I consistently get a 40…

---

## [Filebeat to logstash reading all file from beginning](https://discuss.elastic.co/t/filebeat-to-logstash-reading-all-file-from-beginning/244620)

<div class="topic-metadata">

**Author:** [@elasticforme](https://discuss.elastic.co/u/elasticforme)\
**Replies:** 17\
**Last updated:** [August 14, 2020, 8:16pm UTC](https://discuss.elastic.co/t/filebeat-to-logstash-reading-all-file-from-beginning/244620 "2020-08-14T20:16:09Z")

</div>

I have a filebeat running and properly configure I have logstash running which has input - filter- output. and all works good when I startup problem is when I restart the logstash it reads all the file located in that…

---

## [Limit on # of data nodes?](https://discuss.elastic.co/t/limit-on-of-data-nodes/257912)

<div class="topic-metadata">

**Author:** [@Jesbourne](https://discuss.elastic.co/u/Jesbourne)\
**Replies:** 10\
**Last updated:** [December 7, 2020, 10:41pm UTC](https://discuss.elastic.co/t/limit-on-of-data-nodes/257912 "2020-12-07T22:41:17Z")

</div>

Is there a limit on the number of data nodes or overall amount of data we can have in a cluster? How can we tell when we're nearing that limit? We've been told a few times by elastic employees that our limit is probably…

---

## [Delete by query is not deleting all the docs and still index doc count shows same](https://discuss.elastic.co/t/delete-by-query-is-not-deleting-all-the-docs-and-still-index-doc-count-shows-same/127277)

<div class="topic-metadata">

**Author:** [@kish](https://discuss.elastic.co/u/kish)\
**Replies:** 13\
**Last updated:** [April 10, 2018, 7:27am UTC](https://discuss.elastic.co/t/delete-by-query-is-not-deleting-all-the-docs-and-still-index-doc-count-shows-same/127277 "2018-04-10T07:27:46Z")

</div>

I tried to delete the 2000 docs of particular index. It got deleted but when i try to list then i am able to see the docs count unchanged.. root@kishan\> curl -XPOST 'localhost:9200/cscfcounter/cscfcounter/\_delete\_by\_que…

---

## [LDAP config problem](https://discuss.elastic.co/t/ldap-config-problem/227492)

<div class="topic-metadata">

**Author:** [@Mateuszpk](https://discuss.elastic.co/u/Mateuszpk)\
**Replies:** 23\
**Last updated:** [April 30, 2020, 7:31am UTC](https://discuss.elastic.co/t/ldap-config-problem/227492 "2020-04-30T07:31:25Z")

</div>

Hi I have a problem with LDAP configuration and integration with Acitive directory. I don;t have any response form elastic when I tried to logon using AD user. I activate the DBUG trace for LDAP auth but still ELK log…

---

## [Kibana Apm not showing Spans which are visible in Discover(too many spans?)](https://discuss.elastic.co/t/kibana-apm-not-showing-spans-which-are-visible-in-discover-too-many-spans/171690)

<div class="topic-metadata">

**Author:** [@Wolfram\_Haussig](https://discuss.elastic.co/u/Wolfram_Haussig)\
**Replies:** 15\
**Last updated:** [March 18, 2019, 7:00am UTC](https://discuss.elastic.co/t/kibana-apm-not-showing-spans-which-are-visible-in-discover-too-many-spans/171690 "2019-03-18T07:00:23Z")

</div>

Kibana version: 6.5.4 Elasticsearch version: 6.5.4 APM Server version: 6.5.4 APM Agent language and version: java 1.3.0 APM Agent configuration: active=true instrument=true environment=\[redacted\] service\_name=\[reda…

---

## [Shield AD user is unauthorized only from a different subnet](https://discuss.elastic.co/t/shield-ad-user-is-unauthorized-only-from-a-different-subnet/53977)

<div class="topic-metadata">

**Author:** [@slalomnut](https://discuss.elastic.co/u/slalomnut)\
**Replies:** 22\
**Last updated:** [June 30, 2016, 4:16pm UTC](https://discuss.elastic.co/t/shield-ad-user-is-unauthorized-only-from-a-different-subnet/53977 "2016-06-30T16:16:39Z")

</div>

Apologies if this should be posted in a different location. If so, I'm happy to move it. I have a four node cluster: 3 data nodes and one dedicated master, with configs controlled by puppet. Prior to installing shie…

---

## [Customer Interest Related Keyword search in Elastic Search](https://discuss.elastic.co/t/customer-interest-related-keyword-search-in-elastic-search/235116)

<div class="topic-metadata">

**Author:** [@Sagar\_jain](https://discuss.elastic.co/u/Sagar_jain)\
**Replies:** 40\
**Last updated:** [June 26, 2020, 6:34am UTC](https://discuss.elastic.co/t/customer-interest-related-keyword-search-in-elastic-search/235116 "2020-06-26T06:34:16Z")

</div>

How to create Customer Interest Related Keyword search in Elastic Search? Like "Laptop" keyword Then Laptops should display first, not Laptop Bags first, not laptop stand, and other, these should display in last

---

## [Long JSON number lost precision](https://discuss.elastic.co/t/long-json-number-lost-precision/72124)

<div class="topic-metadata">

**Author:** [@kwu](https://discuss.elastic.co/u/kwu)\
**Replies:** 13\
**Last updated:** [February 3, 2017, 2:40am UTC](https://discuss.elastic.co/t/long-json-number-lost-precision/72124 "2017-02-03T02:40:42Z")

</div>

Elasticsearch Version: v5.0.2 Index Info: GET /\_cat/indices/dblog-2017.01.19?v health status index uuid pri rep docs.count docs.deleted store.size pri.store.size green open dblog-2…

---

## [Metricbeat data not flowing into elasticsearch](https://discuss.elastic.co/t/metricbeat-data-not-flowing-into-elasticsearch/143328)

<div class="topic-metadata">

**Author:** [@Gauti](https://discuss.elastic.co/u/Gauti)\
**Replies:** 14\
**Last updated:** [August 8, 2018, 1:13pm UTC](https://discuss.elastic.co/t/metricbeat-data-not-flowing-into-elasticsearch/143328 "2018-08-08T13:13:47Z")

</div>

Hi All, Got into a small trouble, have installed metric beat in few VM's which was sending data to elasticsearch and was able to view all the dashboards properly, and the VM firewall was turned off. There was a vulnera…

---

## [Filebeat monitoring metrics not visible in ElasticSearch](https://discuss.elastic.co/t/filebeat-monitoring-metrics-not-visible-in-elasticsearch/315596)

<div class="topic-metadata">

**Author:** [@ppine7](https://discuss.elastic.co/u/ppine7)\
**Replies:** 31\
**Last updated:** [October 20, 2022, 2:41am UTC](https://discuss.elastic.co/t/filebeat-monitoring-metrics-not-visible-in-elasticsearch/315596 "2022-10-20T02:41:58Z")

</div>

Hi, I have posted this question on SO but could not get a good answer yet .... Basically I think I have configured Fielbeat + ES according to the docs , to send Filebeat monitored metrics into ES - but nothing is showin…

---

## [Unable to set passwords in elasticsearch with xpack](https://discuss.elastic.co/t/unable-to-set-passwords-in-elasticsearch-with-xpack/175307)

<div class="topic-metadata">

**Author:** [@kishorerv93](https://discuss.elastic.co/u/kishorerv93)\
**Replies:** 9\
**Last updated:** [April 4, 2019, 5:30pm UTC](https://discuss.elastic.co/t/unable-to-set-passwords-in-elasticsearch-with-xpack/175307 "2019-04-04T17:30:58Z")

</div>

ES Version : 6.2.4 Running with configuration path: /home/ubuntu/elasticsearch/config Testing if bootstrap password is valid for https://localhost:9200/\_xpack/security/\_authenticate?pretty Exception in thread "main" ja…

---

## [Windows log forwarding using filebeat](https://discuss.elastic.co/t/windows-log-forwarding-using-filebeat/73523)

<div class="topic-metadata">

**Author:** [@ArjunSISA](https://discuss.elastic.co/u/ArjunSISA)\
**Replies:** 10\
**Last updated:** [February 1, 2017, 2:35pm UTC](https://discuss.elastic.co/t/windows-log-forwarding-using-filebeat/73523 "2017-02-01T14:35:04Z")

</div>

hi everyone I am kind of new to ELK. I am using filebeat to send huge numbers of logs from log servers to logstash machines. I need to know as to how to forward windows audit logs, event logs IIS logs to the server? What…

---

## [Plugin Install fails\`gem install logstash-core -v '6.1.3'\`](https://discuss.elastic.co/t/plugin-install-fails-gem-install-logstash-core-v-6-1-3/118006)

<div class="topic-metadata">

**Author:** [@sarlacpit](https://discuss.elastic.co/u/sarlacpit)\
**Replies:** 15\
**Last updated:** [February 21, 2018, 4:25pm UTC](https://discuss.elastic.co/t/plugin-install-fails-gem-install-logstash-core-v-6-1-3/118006 "2018-02-21T16:25:04Z")

</div>

I am having problems installing plugins: I am running ELK 1.6.3 with an aim to get Netflow data showing in Kibana on Ubuntu 16.04LTS - When trying to install numerous plugins I am getting an error: /usr/share/logstash…

---

## [Request entity too large / error in filebeat](https://discuss.elastic.co/t/request-entity-too-large-error-in-filebeat/254238)

<div class="topic-metadata">

**Author:** [@grynhtjnyuk](https://discuss.elastic.co/u/grynhtjnyuk)\
**Replies:** 9\
**Last updated:** [November 5, 2020, 3:32am UTC](https://discuss.elastic.co/t/request-entity-too-large-error-in-filebeat/254238 "2020-11-05T03:32:58Z")

</div>

I have filebeat installed on kubernetes, and elasticsearch installed on kubernetes also. I got this error and I do not see logs in elasticsearch. Could you please tell me how can I solve the problem: \[elasticsearch\] el…

---

## [Data sent by Filebeat looks garbled](https://discuss.elastic.co/t/data-sent-by-filebeat-looks-garbled/37647)

<div class="topic-metadata">

**Author:** [@renevdm](https://discuss.elastic.co/u/renevdm)\
**Replies:** 9\
**Last updated:** [March 2, 2016, 8:17am UTC](https://discuss.elastic.co/t/data-sent-by-filebeat-looks-garbled/37647 "2016-03-02T08:17:57Z")

</div>

I recently set up Filebeat on a Windows 2008 (R1) machine, to send my Exchange Server Message Tracking Logs to ELK. These are CSV files, which are split by logstash. However, the data only shows garbled lines, like this: …

---

## [ES 5.3 and Java-API 5.3.0 \> java.lang.NullPointerException?](https://discuss.elastic.co/t/es-5-3-and-java-api-5-3-0-java-lang-nullpointerexception/81287)

<div class="topic-metadata">

**Author:** [@mpete](https://discuss.elastic.co/u/mpete)\
**Replies:** 16\
**Last updated:** [May 13, 2017, 1:58am UTC](https://discuss.elastic.co/t/es-5-3-and-java-api-5-3-0-java-lang-nullpointerexception/81287 "2017-05-13T01:58:20Z")

</div>

Hello together, i'm using the Elasticsearch 5.3.0 and my little web service uses the according java-api 5.3.0 for the connection to the ES. Therfore i've added the new maven dependency for "org.elasticsearch.client". T…

---

## [Logstash date filter question](https://discuss.elastic.co/t/logstash-date-filter-question/33663)

<div class="topic-metadata">

**Author:** [@CraigFoote](https://discuss.elastic.co/u/CraigFoote)\
**Replies:** 11\
**Last updated:** [November 9, 2015, 4:23pm UTC](https://discuss.elastic.co/t/logstash-date-filter-question/33663 "2015-11-09T16:23:59Z")

</div>

I'm on the 2.0 stack and am using the JDBC input plugin but a couple DB fields that should be dates are coming in as text, "event\_date" and "event\_timestamp". I'm trying to use the date filter to convert them to dates b…

---

## [SSL handshake fails between Kibana/APMServer and Elasticsearch after custom certificate setting on Elasticsearch](https://discuss.elastic.co/t/ssl-handshake-fails-between-kibana-apmserver-and-elasticsearch-after-custom-certificate-setting-on-elasticsearch/208604)

<div class="topic-metadata">

**Author:** [@Bingu\_Shim](https://discuss.elastic.co/u/Bingu_Shim)\
**Replies:** 21\
**Last updated:** [May 21, 2020, 9:48am UTC](https://discuss.elastic.co/t/ssl-handshake-fails-between-kibana-apmserver-and-elasticsearch-after-custom-certificate-setting-on-elasticsearch/208604 "2020-05-21T09:48:34Z")

</div>

I'm trying to configure our own certificate to the Elasticsearch, Kibana and APM Server, and got ssl handshake errors. I referenced This document for setting. The symptoms and my environments are as follow, and if ther…

---

## [Logstash query template](https://discuss.elastic.co/t/logstash-query-template/95407)

<div class="topic-metadata">

**Author:** [@exocore123](https://discuss.elastic.co/u/exocore123)\
**Replies:** 10\
**Last updated:** [August 4, 2017, 4:47pm UTC](https://discuss.elastic.co/t/logstash-query-template/95407 "2017-08-04T16:47:21Z")

</div>

Change from original question { "query": { "bool": { "must": { "query\_string": { "query": "id=%{id}" } }, "filter": { "range" : { "timestamp" : { …

---

## [Организация безопасного кластера](https://discuss.elastic.co/t/topic/106121)

<div class="topic-metadata">

**Author:** [@IvanTushin](https://discuss.elastic.co/u/IvanTushin)\
**Replies:** 15\
**Last updated:** [November 23, 2017, 8:12am UTC](https://discuss.elastic.co/t/topic/106121 "2017-11-23T08:12:48Z")

</div>

Здравствуйте! Я новичок в эластике, но мы пытаемся внедрить его в наш проект. Сейчас стоит задача о создании безопасной структуры кластера. Я прочитал несколько статей, но не все понятно, не могли бы вы ответить на пар…

---

## [Elastic crash](https://discuss.elastic.co/t/elastic-crash/295791)

<div class="topic-metadata">

**Author:** [@Grace\_A](https://discuss.elastic.co/u/Grace_A)\
**Replies:** 14\
**Last updated:** [February 2, 2022, 7:55pm UTC](https://discuss.elastic.co/t/elastic-crash/295791 "2022-02-02T19:55:16Z")

</div>

Elastic have some issue about java heap size. Elastic, Kibana, and Logstash live on 1 server that has 52 GB RAM. We've also tried change the jvm options for elastic from 1 to 40 Gb. But the elastic always shut down all …

[Previous page](https://discuss.elastic.co/top.md?page=53&per_page=50&period=all)

[Next page](https://discuss.elastic.co/top.md?page=55&per_page=50&period=all)
