# Top

**URL:** https://discuss.elastic.co/top.md?page=7&period=all

[Latest](https://discuss.elastic.co/latest.md) · [Categories](https://discuss.elastic.co/categories.md) · [Tags](https://discuss.elastic.co/tags.md)

**Page:** 8

---

## [Load cassandra data into elasticsearch](https://discuss.elastic.co/t/load-cassandra-data-into-elasticsearch/38590)

<div class="topic-metadata">

**Author:** [@soujanya](https://discuss.elastic.co/u/soujanya)\
**Replies:** 10\
**Last updated:** [March 29, 2017, 5:04pm UTC](https://discuss.elastic.co/t/load-cassandra-data-into-elasticsearch/38590 "2017-03-29T17:04:07Z")

</div>

Hi all, My requirement is to load data from cassandra column family into elasticsearch.For that I have successfully install the plugins(mapper attachments and cassandra-river) required for cassandra integration into elas…

---

## [Retrieving over a million records in Elasticsearch](https://discuss.elastic.co/t/retrieving-over-a-million-records-in-elasticsearch/41339)

<div class="topic-metadata">

**Author:** [@shamak](https://discuss.elastic.co/u/shamak)\
**Replies:** 9\
**Last updated:** [February 27, 2016, 1:00pm UTC](https://discuss.elastic.co/t/retrieving-over-a-million-records-in-elasticsearch/41339 "2016-02-27T13:00:15Z")

</div>

Hello, I believe this is a problem widely talked about in the Elasticsearch community and scan/scroll is a useful method for this problem. However, I am unable to get my targeted results. Problem: I want to be able t…

---

## [Configure Filebeat for All Logs](https://discuss.elastic.co/t/configure-filebeat-for-all-logs/39514)

<div class="topic-metadata">

**Author:** [@naseerudeenmeeajane](https://discuss.elastic.co/u/naseerudeenmeeajane)\
**Replies:** 34\
**Last updated:** [January 28, 2016, 12:22pm UTC](https://discuss.elastic.co/t/configure-filebeat-for-all-logs/39514 "2016-01-28T12:22:12Z")

</div>

Hello, I have installed ELK on my server. So now, I ma trying to use and configure Filebeat to send somme informations to my ELK server, but when I configure filebeat from some tutorial, it does not work. Someone has…

---

## [How to index and store pdf file in elastic search using spring boot?](https://discuss.elastic.co/t/how-to-index-and-store-pdf-file-in-elastic-search-using-spring-boot/220289)

<div class="topic-metadata">

**Author:** [@samanvi\_sweety](https://discuss.elastic.co/u/samanvi_sweety)\
**Replies:** 50\
**Last updated:** [March 24, 2020, 3:08am UTC](https://discuss.elastic.co/t/how-to-index-and-store-pdf-file-in-elastic-search-using-spring-boot/220289 "2020-03-24T03:08:20Z")

</div>

I am new to elastic search. I would like to know how to index and store the pdf files in elastic search using spring boot microservices

---

## [\[match\] query does not support \[type\]](https://discuss.elastic.co/t/match-query-does-not-support-type/111667)

<div class="topic-metadata">

**Author:** [@DiskElemental](https://discuss.elastic.co/u/DiskElemental)\
**Replies:** 15\
**Last updated:** [January 2, 2018, 9:35pm UTC](https://discuss.elastic.co/t/match-query-does-not-support-type/111667 "2018-01-02T21:35:08Z")

</div>

Hey all, After upgrading to a new cluster running Elasticsearch 6.0, from a cluster running 5.4, I'm running into a persistent 400 Error with the message when attempting to run my previously-working Query on the new clu…

---

## [ELK Stack integration with Keycloak](https://discuss.elastic.co/t/elk-stack-integration-with-keycloak/210909)

<div class="topic-metadata">

**Author:** [@sencer](https://discuss.elastic.co/u/sencer)\
**Replies:** 14\
**Last updated:** [December 12, 2019, 2:24pm UTC](https://discuss.elastic.co/t/elk-stack-integration-with-keycloak/210909 "2019-12-12T14:24:01Z")

</div>

Hello, We are trying to add a layer of Authorization into our ELK stack with Keycloak for our commercial product, and stumbled upon a third party plugin called Search Guard. Although Search Guard works pretty well, aft…

---

## [Should dedicated master nodes and data nodes be considered separately?](https://discuss.elastic.co/t/should-dedicated-master-nodes-and-data-nodes-be-considered-separately/75093)

<div class="topic-metadata">

**Author:** [@sumo7](https://discuss.elastic.co/u/sumo7)\
**Replies:** 15\
**Last updated:** [February 14, 2017, 11:17pm UTC](https://discuss.elastic.co/t/should-dedicated-master-nodes-and-data-nodes-be-considered-separately/75093 "2017-02-14T23:17:48Z")

</div>

According to this post, Generally speaking, you'll receive the optimal performance by using the same number of shards as nodes. I have three dedicated master nodes and one data node in my cluster. So I have four nod…

---

## [Kibana dreaded timeout on dashboard](https://discuss.elastic.co/t/kibana-dreaded-timeout-on-dashboard/79453)

<div class="topic-metadata">

**Author:** [@gh0stid](https://discuss.elastic.co/u/gh0stid)\
**Replies:** 23\
**Last updated:** [March 22, 2017, 6:25pm UTC](https://discuss.elastic.co/t/kibana-dreaded-timeout-on-dashboard/79453 "2017-03-22T18:25:09Z")

</div>

Hello, I would like to have help on this "$?$&!!\\\\$#$%@%" problem :smiley: I run ~70gb daily index size.. - 3 shards 1 replica on two server 64gb RAM, 31.94 heap size, 8 core CPU 3ghz YET if I try to go over 12hours…

---

## [Kibana not showing recent Elasticsearch data](https://discuss.elastic.co/t/kibana-not-showing-recent-elasticsearch-data/44184)

<div class="topic-metadata">

**Author:** [@HelpComputer](https://discuss.elastic.co/u/HelpComputer)\
**Replies:** 12\
**Last updated:** [March 18, 2016, 10:06pm UTC](https://discuss.elastic.co/t/kibana-not-showing-recent-elasticsearch-data/44184 "2016-03-18T22:06:20Z")

</div>

Hello, I just upgraded my ELK stack but now I am unable to see all data in Kibana. I see data from a couple hours ago but not from the last 15min or 30min. It's like it just stopped. After the upgrade, I ran into some…

---

## [Painless Scripting Compile Errors](https://discuss.elastic.co/t/painless-scripting-compile-errors/123412)

<div class="topic-metadata">

**Author:** [@Errors](https://discuss.elastic.co/u/Errors)\
**Replies:** 16\
**Last updated:** [March 23, 2018, 4:33pm UTC](https://discuss.elastic.co/t/painless-scripting-compile-errors/123412 "2018-03-23T16:33:04Z")

</div>

I'm writing the following and saving it as a scripted field in elasticsearch for(name in parsed.FIRST\_NAME){ if('Steve' in parsed.FIRST\_NAME){ return parsed.FIRST\_NAME } } This givse me the error: Erro…

---

## [How to grant access to Kibana for specific users?](https://discuss.elastic.co/t/how-to-grant-access-to-kibana-for-specific-users/69059)

<div class="topic-metadata">

**Author:** [@baden0x1](https://discuss.elastic.co/u/baden0x1)\
**Replies:** 13\
**Last updated:** [December 23, 2016, 9:42am UTC](https://discuss.elastic.co/t/how-to-grant-access-to-kibana-for-specific-users/69059 "2016-12-23T09:42:07Z")

</div>

I am hoping to expose the Kibana dashboard for specific user accounts, extending Kibana and offering more options, templated queries, etc., where the logged in user would not be able to access any other users' data. H…

---

## [How to Setup FileBeat with Basic Auth for LogStash Output?](https://discuss.elastic.co/t/how-to-setup-filebeat-with-basic-auth-for-logstash-output/36937)

<div class="topic-metadata">

**Author:** [@kpcool](https://discuss.elastic.co/u/kpcool)\
**Replies:** 18\
**Last updated:** [March 30, 2016, 10:34pm UTC](https://discuss.elastic.co/t/how-to-setup-filebeat-with-basic-auth-for-logstash-output/36937 "2016-03-30T22:34:55Z")

</div>

I plan to use FileBeat for log monitoring and push out the logs to logstash on a central server, which has http basic auth setup, to prevent unauthorized inputs. Without auth, the setup works fine, no issues. However, w…

---

## [How should I use sql\_last\_value in logstash?](https://discuss.elastic.co/t/how-should-i-use-sql-last-value-in-logstash/64595)

<div class="topic-metadata">

**Author:** [@Kulasangar\_Gowrisang](https://discuss.elastic.co/u/Kulasangar_Gowrisang)\
**Replies:** 10\
**Last updated:** [December 5, 2016, 9:45am UTC](https://discuss.elastic.co/t/how-should-i-use-sql-last-value-in-logstash/64595 "2016-12-05T09:45:31Z")

</div>

I'm quite unclear of what sql\_last\_value does when I give my statement as such: statement =\> "SELECT \* from mytable where id \> :sql\_last\_value" I can slightly understand the reason behind using it, where it doesn't br…

---

## [Curl: (60) SSL certificate problem: self signed certificate in certificate chain](https://discuss.elastic.co/t/curl-60-ssl-certificate-problem-self-signed-certificate-in-certificate-chain/347472)

<div class="topic-metadata">

**Author:** [@Dasara\_Saarthak](https://discuss.elastic.co/u/Dasara_Saarthak)\
**Replies:** 17\
**Last updated:** [December 7, 2023, 4:36pm UTC](https://discuss.elastic.co/t/curl-60-ssl-certificate-problem-self-signed-certificate-in-certificate-chain/347472 "2023-12-07T16:36:58Z")

</div>

curl --cacert certs/ca/ca.crt -u elastic:"xyz" 'url' iam getting the below error while trying to execute the above curl command curl: (60) SSL certificate problem: self signed certificate in certificate chain but the…

---

## [Mapper\_parsing\_exception", "reason"=\>"failed to parse \[severity\]"](https://discuss.elastic.co/t/mapper-parsing-exception-reason-failed-to-parse-severity/128781)

<div class="topic-metadata">

**Author:** [@hobakill](https://discuss.elastic.co/u/hobakill)\
**Replies:** 9\
**Last updated:** [April 23, 2018, 1:03pm UTC](https://discuss.elastic.co/t/mapper-parsing-exception-reason-failed-to-parse-severity/128781 "2018-04-23T13:03:55Z")

</div>

full error: \[2018-04-20T00:33:26,274\]\[WARN \]\[logstash.outputs.elasticsearch\] Could not index event to Elasticsearch. {:status=\>400, :action=\>\["index", {:\_id=\>nil, :\_index=\>"logstash-2018.04.20-ea1", :\_type=\>"doc", :\_r…

---

## [License Expired](https://discuss.elastic.co/t/license-expired/141872)

<div class="topic-metadata">

**Author:** [@Sulaiman](https://discuss.elastic.co/u/Sulaiman)\
**Replies:** 12\
**Last updated:** [July 27, 2018, 7:46am UTC](https://discuss.elastic.co/t/license-expired/141872 "2018-07-27T07:46:27Z")

</div>

Recently I have faced issue with ElasticSearch License, I am getting below listed error while restarting, I had basic account. 2018-07-27T10:01:57,936\]\[ERROR\]\[o.e.x.s.a.f.SecurityActionFilter\] \[aYBc70q\] blocking \[cluste…

---

## [Elastic search fails after some time](https://discuss.elastic.co/t/elastic-search-fails-after-some-time/39965)

<div class="topic-metadata">

**Author:** [@ambarishrh](https://discuss.elastic.co/u/ambarishrh)\
**Replies:** 25\
**Last updated:** [May 4, 2017, 8:50am UTC](https://discuss.elastic.co/t/elastic-search-fails-after-some-time/39965 "2017-05-04T08:50:10Z")

</div>

Hello, We have elasticsearch installed and configured to work with ActiveCollab on CentOS7 64 bit with 8GB RAM. ElasticSearch starts successfully but fails after some time. The status message shows: elasticsearch.ser…

---

## [Default index (.kibana) not created](https://discuss.elastic.co/t/default-index-kibana-not-created/135836)

<div class="topic-metadata">

**Author:** [@ajit](https://discuss.elastic.co/u/ajit)\
**Replies:** 73\
**Last updated:** [June 27, 2018, 4:01am UTC](https://discuss.elastic.co/t/default-index-kibana-not-created/135836 "2018-06-27T04:01:45Z")

</div>

Hi, we have installed 6.2.4 elasticsearch and kibana. But .kibana index not present in elasticsearch. Why it is not created. I have started both the applications but index not found. please provide solution on this.

---

## [Browserslist: caniuse-lite is outdated. Please run next command \`npm update caniuse-lite browserslist](https://discuss.elastic.co/t/browserslist-caniuse-lite-is-outdated-please-run-next-command-npm-update-caniuse-lite-browserslist/189216)

<div class="topic-metadata">

**Author:** [@mhsh64](https://discuss.elastic.co/u/mhsh64)\
**Replies:** 21\
**Last updated:** [July 11, 2019, 12:31am UTC](https://discuss.elastic.co/t/browserslist-caniuse-lite-is-outdated-please-run-next-command-npm-update-caniuse-lite-browserslist/189216 "2019-07-11T00:31:56Z")

</div>

Hi all, Is the following a bug? Jul 06 10:38:46 vm1.local.com systemd\[1\]: Started Kibana. Jul 06 10:40:42 vm1.local.com kibana\[5454\]: {"type":"log","@timestamp":"2019-07-06T14:40:42Z","tags":\["info","optimize"\],"pid":5…

---

## [Elasticsearch 6.6.2 constantly failing with Out Of Memory Errors](https://discuss.elastic.co/t/elasticsearch-6-6-2-constantly-failing-with-out-of-memory-errors/173669)

<div class="topic-metadata">

**Author:** [@Sai\_Birada](https://discuss.elastic.co/u/Sai_Birada)\
**Replies:** 21\
**Last updated:** [March 26, 2019, 9:03am UTC](https://discuss.elastic.co/t/elasticsearch-6-6-2-constantly-failing-with-out-of-memory-errors/173669 "2019-03-26T09:03:20Z")

</div>

I had a 7 node cluster, with 4 data nodes and 3 master eligible nodes. Each data node is of 64GB Ram configured with 30GB heapsize, 8 cpu and 2TB SSD Disk. All the 4 data nodes are going down, after few hours of restar…

---

## [Can I copy a dashboard and its associated visulizations?](https://discuss.elastic.co/t/can-i-copy-a-dashboard-and-its-associated-visulizations/94311)

<div class="topic-metadata">

**Author:** [@KeithTt](https://discuss.elastic.co/u/KeithTt)\
**Replies:** 16\
**Last updated:** [July 27, 2017, 8:53am UTC](https://discuss.elastic.co/t/can-i-copy-a-dashboard-and-its-associated-visulizations/94311 "2017-07-27T08:53:12Z")

</div>

ELK Version: 5.4.1 There some similar projects, and they could use same dashboard.

---

## [Input JSON file to elasticsearch via logstash](https://discuss.elastic.co/t/input-json-file-to-elasticsearch-via-logstash/72437)

<div class="topic-metadata">

**Author:** [@gutasaputra](https://discuss.elastic.co/u/gutasaputra)\
**Replies:** 13\
**Last updated:** [January 23, 2017, 10:01am UTC](https://discuss.elastic.co/t/input-json-file-to-elasticsearch-via-logstash/72437 "2017-01-23T10:01:42Z")

</div>

hi, im facing an issue with logstash while inserting json data to elasticsearch. here is my logstash config file input { file { codec =\> multiline { pattern =\> '^{' negate =\> true what =\> previous } pa…

---

## [Elasticsearch stop working after enable x-pack](https://discuss.elastic.co/t/elasticsearch-stop-working-after-enable-x-pack/194955)

<div class="topic-metadata">

**Author:** [@Ayush\_Verma](https://discuss.elastic.co/u/Ayush_Verma)\
**Replies:** 46\
**Last updated:** [August 19, 2019, 5:56am UTC](https://discuss.elastic.co/t/elasticsearch-stop-working-after-enable-x-pack/194955 "2019-08-19T05:56:22Z")

</div>

I want kibana to ask for the password every time i use it, so i came up with this x-pack thing and tried to enable x-pack in elasticsearch, my bin folder haver x-pack-env, x-pack-security-env, x-pack-watcher-env i did ch…

---

## [ElasticSearch Service Failure status=78/n/a](https://discuss.elastic.co/t/elasticsearch-service-failure-status-78-n-a/129461)

<div class="topic-metadata">

**Author:** [@thompsonlau](https://discuss.elastic.co/u/thompsonlau)\
**Replies:** 17\
**Last updated:** [April 27, 2018, 8:37am UTC](https://discuss.elastic.co/t/elasticsearch-service-failure-status-78-n-a/129461 "2018-04-27T08:37:03Z")

</div>

I have installed ElasticSearch v6.2.4 on CentOS 7.0 I have done all necessary configurations. When I run it, I got the following messages in system. Apr 25 18:24:18 QVELKSRH01 systemd\[1\]: elasticsearch.service: main pr…

---

## [Install filebeat on windows](https://discuss.elastic.co/t/install-filebeat-on-windows/81946)

<div class="topic-metadata">

**Author:** [@Sam67000](https://discuss.elastic.co/u/Sam67000)\
**Replies:** 19\
**Last updated:** [April 12, 2017, 8:33am UTC](https://discuss.elastic.co/t/install-filebeat-on-windows/81946 "2017-04-12T08:33:18Z")

</div>

Hello everybody, I'm trying to install filebeat on a windows server. But when I run it from the command prompt it shows me this : Can anyone help me ? Thannnks !

---

## [Fail start Elastic](https://discuss.elastic.co/t/fail-start-elastic/598)

<div class="topic-metadata">

**Author:** [@trungmv](https://discuss.elastic.co/u/trungmv)\
**Replies:** 19\
**Last updated:** [September 23, 2016, 1:45pm UTC](https://discuss.elastic.co/t/fail-start-elastic/598 "2016-09-23T13:45:19Z")

</div>

Hello experts, I have plan forward rsyslog to elasticsearch. I also installation Rsyslog v8 and Elastic v1.5.2 both on same server. But when start Elastic with error message: bin/elasticsearch start Failed to configure…

---

## [Search elasticsearch with java client using JSON query](https://discuss.elastic.co/t/search-elasticsearch-with-java-client-using-json-query/74329)

<div class="topic-metadata">

**Author:** [@anisen](https://discuss.elastic.co/u/anisen)\
**Replies:** 17\
**Last updated:** [February 17, 2017, 3:09pm UTC](https://discuss.elastic.co/t/search-elasticsearch-with-java-client-using-json-query/74329 "2017-02-17T15:09:56Z")

</div>

Hi, I am using ElasticSearch 5.1.1 I am using the below java code to fetch data from ES : SearchResponse response = client.prepareSearch() .setIndices("myindex01") .setTypes("iis-log") .setQuery(QueryB…

---

## [Is there any best way to update existing index without re-indexing and creating alias of index?](https://discuss.elastic.co/t/is-there-any-best-way-to-update-existing-index-without-re-indexing-and-creating-alias-of-index/207622)

<div class="topic-metadata">

**Author:** [@Devang\_Prajapati](https://discuss.elastic.co/u/Devang_Prajapati)\
**Replies:** 10\
**Last updated:** [November 14, 2019, 6:17am UTC](https://discuss.elastic.co/t/is-there-any-best-way-to-update-existing-index-without-re-indexing-and-creating-alias-of-index/207622 "2019-11-14T06:17:59Z")

</div>

I've to re-index the data if there is little change in the existing index. I've already done reindexing with creating an alias of the index but in that , I've to wait while reindexing the data from one index to another.…

---

## [Upgraded from ES2.3.5 to 2.4.0, seeing: Transport response handler not found of id](https://discuss.elastic.co/t/upgraded-from-es2-3-5-to-2-4-0-seeing-transport-response-handler-not-found-of-id/59742)

<div class="topic-metadata">

**Author:** [@teebu](https://discuss.elastic.co/u/teebu)\
**Replies:** 21\
**Last updated:** [January 30, 2017, 5:14pm UTC](https://discuss.elastic.co/t/upgraded-from-es2-3-5-to-2-4-0-seeing-transport-response-handler-not-found-of-id/59742 "2017-01-30T17:14:09Z")

</div>

I just upgraded to ES2.4.0 and I'm noticing these errors every time ES starts. What does this mean? 2016-09-04 04:03:38,655\]\[WARN \]\[transport \] \[caste\] Transport response handler not found of id \[238\] \[…

---

## [Elasticsearch unable to start](https://discuss.elastic.co/t/elasticsearch-unable-to-start/23824)

<div class="topic-metadata">

**Author:** [@neethal](https://discuss.elastic.co/u/neethal)\
**Replies:** 10\
**Last updated:** [June 21, 2017, 1:38pm UTC](https://discuss.elastic.co/t/elasticsearch-unable-to-start/23824 "2017-06-21T13:38:29Z")

</div>

Hello, I am not able to start the elasticsearch 1.4.5 in linux. i get the below error. log4j:ERROR setFile(null,true) call failed. java.io.FileNotFoundException: /var/log/elasticsearch/elasticsearch.log (Permission de…

---

## [Create Monitor - Define extraction query](https://discuss.elastic.co/t/create-monitor-define-extraction-query/189369)

<div class="topic-metadata">

**Author:** [@ben.sharp](https://discuss.elastic.co/u/ben.sharp)\
**Replies:** 11\
**Last updated:** [July 29, 2019, 2:27pm UTC](https://discuss.elastic.co/t/create-monitor-define-extraction-query/189369 "2019-07-29T14:27:06Z")

</div>

Hello, I am attempting to create a monitor in Kibana using the "Define using extraction query" option. However I am struggling to form the query. I am trying to monitor the last hour of logs, and look for the field "a…

---

## [How to Query for length with elasticsearch (KQL)](https://discuss.elastic.co/t/how-to-query-for-length-with-elasticsearch-kql/259815)

<div class="topic-metadata">

**Author:** [@Elasticnewbie1](https://discuss.elastic.co/u/Elasticnewbie1)\
**Replies:** 15\
**Last updated:** [January 12, 2021, 4:53pm UTC](https://discuss.elastic.co/t/how-to-query-for-length-with-elasticsearch-kql/259815 "2021-01-12T16:53:44Z")

</div>

Hey there, im new to this elk world and im currently working on a threat hunting project with ELK/Zeek. My problem is, that i want for example to query for DNS.Length \> 75 within zeek data. I know that its easy to do i…

---

## [Elasticsearch- Single Index vs Multiple Indexes](https://discuss.elastic.co/t/elasticsearch-single-index-vs-multiple-indexes/164265)

<div class="topic-metadata">

**Author:** [@pranav24](https://discuss.elastic.co/u/pranav24)\
**Replies:** 44\
**Last updated:** [February 6, 2019, 8:15am UTC](https://discuss.elastic.co/t/elasticsearch-single-index-vs-multiple-indexes/164265 "2019-02-06T08:15:57Z")

</div>

Hi I have more than 4000 different fields in one of my index. And that number can grow larger with time. As Elasticsearch give default limit of 1000 field per index. There must be some reason. Now, I am thinking that …

---

## [Data missing after ES restart](https://discuss.elastic.co/t/data-missing-after-es-restart/28154)

<div class="topic-metadata">

**Author:** [@Tigryss](https://discuss.elastic.co/u/Tigryss)\
**Replies:** 26\
**Last updated:** [February 11, 2016, 5:11am UTC](https://discuss.elastic.co/t/data-missing-after-es-restart/28154 "2016-02-11T05:11:36Z")

</div>

After ES restart I can't see the old data in kibana anymore, just the data after restart and the saved dashboards, visualizes and queries are also gone. I started elasticsearch already with debug level, but there is no e…

---

## [Logstash Update a document in elasticsearch](https://discuss.elastic.co/t/logstash-update-a-document-in-elasticsearch/74039)

<div class="topic-metadata">

**Author:** [@banu](https://discuss.elastic.co/u/banu)\
**Replies:** 10\
**Last updated:** [February 6, 2017, 11:16am UTC](https://discuss.elastic.co/t/logstash-update-a-document-in-elasticsearch/74039 "2017-02-06T11:16:45Z")

</div>

Trying to update a specific field in elasticsearch through logstash. Is it possible to update only a set of fields through logstash ? Please find the code below, filter { csv { separator =\> "|…

---

## [Filebeat can not publishing events](https://discuss.elastic.co/t/filebeat-can-not-publishing-events/37349)

<div class="topic-metadata">

**Author:** [@Adria\_Garcia\_Alzorri](https://discuss.elastic.co/u/Adria_Garcia_Alzorri)\
**Replies:** 14\
**Last updated:** [October 26, 2016, 8:48pm UTC](https://discuss.elastic.co/t/filebeat-can-not-publishing-events/37349 "2016-10-26T20:48:12Z")

</div>

Howdy, I'm trying the ELK stack under CentOS 6 machines, following https://www.digitalocean.com/community/tutorials/how-to-install-elasticsearch-logstash-and-kibana-elk-stack-on-centos-7. Every service is running in …

---

## [Error - The signal HUP is in use by the JVM and will not work correctly on this platform](https://discuss.elastic.co/t/error-the-signal-hup-is-in-use-by-the-jvm-and-will-not-work-correctly-on-this-platform/47128)

<div class="topic-metadata">

**Author:** [@Amit2015](https://discuss.elastic.co/u/Amit2015)\
**Replies:** 13\
**Last updated:** [October 5, 2016, 1:14pm UTC](https://discuss.elastic.co/t/error-the-signal-hup-is-in-use-by-the-jvm-and-will-not-work-correctly-on-this-platform/47128 "2016-10-05T13:14:37Z")

</div>

Hi, I am trying command in LogStash: logstash -e 'input { stdin { } } output { elasticsearch { host =\> localhost } }' Getting error like - io/console not supported; tty will not be manipulated The signal HUP is in …

---

## [Increasing elasticsearch indexing rate](https://discuss.elastic.co/t/increasing-elasticsearch-indexing-rate/74071)

<div class="topic-metadata">

**Author:** [@Zeeshan\_Alam](https://discuss.elastic.co/u/Zeeshan_Alam)\
**Replies:** 13\
**Last updated:** [February 9, 2017, 2:41pm UTC](https://discuss.elastic.co/t/increasing-elasticsearch-indexing-rate/74071 "2017-02-09T14:41:35Z")

</div>

I have created a 3 node cluster, 1 Master Node, 1 Coordinating Node and 1 Data Node. I am using Logstash 2.4, Elasticsearch 5.2 and Kibana 5.2. Logstash is reading data from Kafka and sending it to the ingest node. I a…

---

## [Elastic search is not starting](https://discuss.elastic.co/t/elastic-search-is-not-starting/124520)

<div class="topic-metadata">

**Author:** [@prahlad574](https://discuss.elastic.co/u/prahlad574)\
**Replies:** 24\
**Last updated:** [March 20, 2018, 12:15pm UTC](https://discuss.elastic.co/t/elastic-search-is-not-starting/124520 "2018-03-20T12:15:49Z")

</div>

root@:/# service elasticsearch start Starting Elasticsearch Server \[ OK \] root@:/# service elasticsearch status elasticsearch is not running this is the issue i am facing. earlier port 9200 is to be in close wait sta…

---

## [Error "type": "query\_shard\_exception" while running below query in dev tools](https://discuss.elastic.co/t/error-type-query-shard-exception-while-running-below-query-in-dev-tools/186666)

<div class="topic-metadata">

**Author:** [@pyerunka](https://discuss.elastic.co/u/pyerunka)\
**Replies:** 11\
**Last updated:** [June 26, 2019, 6:08am UTC](https://discuss.elastic.co/t/error-type-query-shard-exception-while-running-below-query-in-dev-tools/186666 "2019-06-26T06:08:00Z")

</div>

Hello, I am running below query: GET new\_master\_query/\_search { "query": { "multi\_match": { "query": "Geosolutions", "fields": \[ "contentid^4", "title^3","object\_summary^2","submitted\_for\_name"\] } } } and …

---

## [Validation failed: 1 :Mapping type is missing](https://discuss.elastic.co/t/validation-failed-1-mapping-type-is-missing/231938)

<div class="topic-metadata">

**Author:** [@Matish\_Bhuyan](https://discuss.elastic.co/u/Matish_Bhuyan)\
**Replies:** 11\
**Last updated:** [May 12, 2020, 3:15am UTC](https://discuss.elastic.co/t/validation-failed-1-mapping-type-is-missing/231938 "2020-05-12T03:15:41Z")

</div>

Hi I am a newbie to Elastic search I have created an index which source field is bit lengthy and i am suspecting that the ignore\_above is restricting to visualize my data in Kibana. So i went on trying to change the I…

---

## [Could not index event to Elasticsearch:cannot be changed from type \[float\] to \[long\]:](https://discuss.elastic.co/t/could-not-index-event-to-elasticsearch-cannot-be-changed-from-type-float-to-long/138838)

<div class="topic-metadata">

**Author:** [@Akhilesh-Tiwari](https://discuss.elastic.co/u/Akhilesh-Tiwari)\
**Replies:** 9\
**Last updated:** [July 13, 2018, 6:01am UTC](https://discuss.elastic.co/t/could-not-index-event-to-elasticsearch-cannot-be-changed-from-type-float-to-long/138838 "2018-07-13T06:01:35Z")

</div>

Hi Team, I have an issue in creating index using my database table data through logstash JDBC. The issue is. \[2018-07-06T12:37:24,587\]\[WARN \]\[logstash.outputs.elasticsearch\] Could not index event to Elasticsearch. {:s…

---

## [Keeping global variables in LS?!](https://discuss.elastic.co/t/keeping-global-variables-in-ls/39908)

<div class="topic-metadata">

**Author:** [@jjdepaul](https://discuss.elastic.co/u/jjdepaul)\
**Replies:** 22\
**Last updated:** [April 7, 2017, 11:48pm UTC](https://discuss.elastic.co/t/keeping-global-variables-in-ls/39908 "2017-04-07T23:48:50Z")

</div>

Is there a way to keep variables at a global level?! Here is an excerpt from the log file that we are processing. As you can see there is data about CustomerAccountNumber, and ContractNumber. The trouble is that …

---

## [Cannot connect to remote ElasticSearch server](https://discuss.elastic.co/t/cannot-connect-to-remote-elasticsearch-server/173308)

<div class="topic-metadata">

**Author:** [@Miao](https://discuss.elastic.co/u/Miao)\
**Replies:** 42\
**Last updated:** [March 26, 2019, 2:14pm UTC](https://discuss.elastic.co/t/cannot-connect-to-remote-elasticsearch-server/173308 "2019-03-26T14:14:39Z")

</div>

I am aware that a similar question was posted back in 2015, but the answers there unfortunately do not help me. On my remote Windows 10 server (on which Elasticsearch 6.6.2 is installed), I have added an inbound securit…

---

## [Aggregations in 2.1.0 much slower than 1.6.0](https://discuss.elastic.co/t/aggregations-in-2-1-0-much-slower-than-1-6-0/38056)

<div class="topic-metadata">

**Author:** [@symos](https://discuss.elastic.co/u/symos)\
**Replies:** 33\
**Last updated:** [January 19, 2016, 2:47pm UTC](https://discuss.elastic.co/t/aggregations-in-2-1-0-much-slower-than-1-6-0/38056 "2016-01-19T14:47:53Z")

</div>

Hi guys We're in the process of migrating servers and thought we'd also upgrade Elasticsearch in the process. However, when installing Elasticsearch 2.1.0 on the new servers (which are much more powerful than the old…

---

## [Nonstop Lumberjack pipeline is blocked messages](https://discuss.elastic.co/t/nonstop-lumberjack-pipeline-is-blocked-messages/25246)

<div class="topic-metadata">

**Author:** [@JeremyinNC](https://discuss.elastic.co/u/JeremyinNC)\
**Replies:** 11\
**Last updated:** [February 9, 2016, 8:05am UTC](https://discuss.elastic.co/t/nonstop-lumberjack-pipeline-is-blocked-messages/25246 "2016-02-09T08:05:18Z")

</div>

I recently upgraded Logstash from 1.4 to 1.5.1 and now I am constantly seeing the following in my logstash log: {:timestamp=\>"2015-07-09T15:10:03.559000+0000", :message=\>"Lumberjack input: the pipeline is blocked, tem…

---

## [Elasticsearch Kibana ECONNRESET - SOLVED](https://discuss.elastic.co/t/elasticsearch-kibana-econnreset-solved/130097)

<div class="topic-metadata">

**Author:** [@hadi](https://discuss.elastic.co/u/hadi)\
**Replies:** 16\
**Last updated:** [May 6, 2018, 11:54am UTC](https://discuss.elastic.co/t/elasticsearch-kibana-econnreset-solved/130097 "2018-05-06T11:54:41Z")

</div>

Hi, I am seeing this page and I am not sure what causes it. Please let me know if you have any idea what can be the reason? \[11111111111111111a\] Kibana is pointing to the same machine that is hosted on. cat /etc/kiba…

---

## [Timing out while indexing](https://discuss.elastic.co/t/timing-out-while-indexing/4486)

<div class="topic-metadata">

**Author:** [@Ian\_Eure](https://discuss.elastic.co/u/Ian_Eure)\
**Replies:** 29\
**Last updated:** [June 10, 2011, 12:30am UTC](https://discuss.elastic.co/t/timing-out-while-indexing/4486 "2011-06-10T00:30:24Z")

</div>

I'm evaluating ElasticSearch as a replacement for Solr, as my data is getting too large for Solr to cope with comfortably. I'm importing ~19m documents, each of which is ~512 bytes. I'm using a two-node ElasticSearc…

---

## [What to do with non utf8 characters](https://discuss.elastic.co/t/what-to-do-with-non-utf8-characters/6163)

<div class="topic-metadata">

**Author:** [@vineeth\_mohan](https://discuss.elastic.co/u/vineeth_mohan)\
**Replies:** 17\
**Last updated:** [May 10, 2016, 1:00am UTC](https://discuss.elastic.co/t/what-to-do-with-non-utf8-characters/6163 "2016-05-10T01:00:46Z")

</div>

Hi , I am taking some text from the web and giving it to elasticSearch. my problem is that , there are so many non utf8 characters in the text lile �,“ã etc. Now i used java's utf8 convertion thing but its replacin…

---

## [How to verify filebeat parsed log data count](https://discuss.elastic.co/t/how-to-verify-filebeat-parsed-log-data-count/62055)

<div class="topic-metadata">

**Author:** [@sarathymv](https://discuss.elastic.co/u/sarathymv)\
**Replies:** 15\
**Last updated:** [October 17, 2016, 11:09am UTC](https://discuss.elastic.co/t/how-to-verify-filebeat-parsed-log-data-count/62055 "2016-10-17T11:09:37Z")

</div>

All, We are using logstash to parse our application log and index to elastic search. Following is the high level architecture Webserver with file beat -----\> Logstash ----\> Elastic search ------\> kibana. We instal…

[Previous page](https://discuss.elastic.co/top.md?page=6&per_page=50&period=all)

[Next page](https://discuss.elastic.co/top.md?page=8&per_page=50&period=all)
