# Top

**URL:** https://discuss.elastic.co/top.md?page=914&period=all

[Latest](https://discuss.elastic.co/latest.md) · [Categories](https://discuss.elastic.co/categories.md) · [Tags](https://discuss.elastic.co/tags.md)

**Page:** 915

---

## [Disabling xpack in development env](https://discuss.elastic.co/t/disabling-xpack-in-development-env/178478)

<div class="topic-metadata">

**Author:** [@ENG618](https://discuss.elastic.co/u/ENG618)\
**Replies:** 2\
**Last updated:** [April 26, 2019, 3:19pm UTC](https://discuss.elastic.co/t/disabling-xpack-in-development-env/178478 "2019-04-26T15:19:59Z")

</div>

I'm building a plugin the runs in an es/kibana oss container. I can't figure out how to completely disable xpack in my development server for accurate testing. I've tried adding the following to the kibana.yml, but it …

---

## [Create alias using filter to exclude certain value](https://discuss.elastic.co/t/create-alias-using-filter-to-exclude-certain-value/123126)

<div class="topic-metadata">

**Author:** [@reswob](https://discuss.elastic.co/u/reswob)\
**Replies:** 2\
**Last updated:** [April 3, 2018, 1:31pm UTC](https://discuss.elastic.co/t/create-alias-using-filter-to-exclude-certain-value/123126 "2018-04-03T13:31:20Z")

</div>

According to Aliases API | Elasticsearch Guide \[8.11\] | Elastic, I can create an alias for certain events in an index, like all events with a certain tag. I would like to create an alias for all events in an index WITHO…

---

## [How to map LDAP users with roles in kibana](https://discuss.elastic.co/t/how-to-map-ldap-users-with-roles-in-kibana/103222)

<div class="topic-metadata">

**Author:** [@ajit](https://discuss.elastic.co/u/ajit)\
**Replies:** 2\
**Last updated:** [October 11, 2017, 11:31am UTC](https://discuss.elastic.co/t/how-to-map-ldap-users-with-roles-in-kibana/103222 "2017-10-11T11:31:52Z")

</div>

I have implemented x pack as well as LDAP security in elasticsearch. But I am not able to assign roles for particular user (Existing users in LDAP active directory.) How to assign roles for existing users in kibana. Plea…

---

## [Trim all text fields when indexing](https://discuss.elastic.co/t/trim-all-text-fields-when-indexing/191761)

<div class="topic-metadata">

**Author:** [@Ayala](https://discuss.elastic.co/u/Ayala)\
**Replies:** 3\
**Last updated:** [July 30, 2019, 12:28pm UTC](https://discuss.elastic.co/t/trim-all-text-fields-when-indexing/191761 "2019-07-30T12:28:00Z")

</div>

Hi, I would like all text fields to be SAVED in elastic without leading and trailing spaces. (That is, in \_source) Pipeline didn't work, but also is not good enough, because I don't want to add each field to it. How …

---

## [Kibana not loading](https://discuss.elastic.co/t/kibana-not-loading/182079)

<div class="topic-metadata">

**Author:** [@chandukreddi](https://discuss.elastic.co/u/chandukreddi)\
**Replies:** 3\
**Last updated:** [May 21, 2019, 7:37pm UTC](https://discuss.elastic.co/t/kibana-not-loading/182079 "2019-05-21T19:37:13Z")

</div>

hello Experts, Kiabna is not loading after restart, log says ready but page keep spinning. log prints: {"type":"log","@timestamp":"2019-05-21T18:05:07Z","tags":\["status","plugin:kibana@6.7.1","info"\],"pid":12158,"st…

---

## [Kibanaのエラーメッセージについて（Ver6.4）](https://discuss.elastic.co/t/kibana-ver6-4/146597)

<div class="topic-metadata">

**Author:** [@yamamotoh](https://discuss.elastic.co/u/yamamotoh)\
**Replies:** 3\
**Last updated:** [September 11, 2018, 6:56am UTC](https://discuss.elastic.co/t/kibana-ver6-4/146597 "2018-09-11T06:56:29Z")

</div>

Ver6.4のELKで、KibanaのDashboard画面上で下記を実施しました。 1．Add a filterでフィルターを定義 2．その後ダッシュボードの1つでマウスにより範囲指定を実施しさらにフィルター実施 3．2．でフィルターを行った画面をフルスクリーンにしようとした。 その結果 IndexSizeError: Index or size is negative or greater than the allowed…

---

## [How to fetch hierarchical data using elastic search](https://discuss.elastic.co/t/how-to-fetch-hierarchical-data-using-elastic-search/128631)

<div class="topic-metadata">

**Author:** [@preetidashore](https://discuss.elastic.co/u/preetidashore)\
**Replies:** 3\
**Last updated:** [April 24, 2018, 8:54am UTC](https://discuss.elastic.co/t/how-to-fetch-hierarchical-data-using-elastic-search/128631 "2018-04-24T08:54:49Z")

</div>

I want to fetch hierarchical data using elastic search I have tried 'has\_parent' ,'has\_child' and 'term- aggregation' but it is returning hierarchy only up to 1 level. But I want to get complete hierarchy for specific o…

---

## [Packet decode failed with: TCP data offset greater than packet length](https://discuss.elastic.co/t/packet-decode-failed-with-tcp-data-offset-greater-than-packet-length/92487)

<div class="topic-metadata">

**Author:** [@kartalkoushik123](https://discuss.elastic.co/u/kartalkoushik123)\
**Replies:** 3\
**Last updated:** [July 13, 2017, 6:03pm UTC](https://discuss.elastic.co/t/packet-decode-failed-with-tcp-data-offset-greater-than-packet-length/92487 "2017-07-13T18:03:43Z")

</div>

When trying to start packetbeat on the host servers, a new packetbeat index is not getting created. This is what i get at the host logs INFO Connected to Elasticsearch version 5.5.0 INFO Trying to load template for c…

---

## [Operation/Listener Threading](https://discuss.elastic.co/t/operation-listener-threading/14029)

<div class="topic-metadata">

**Author:** [@Alex\_Clark](https://discuss.elastic.co/u/Alex_Clark)\
**Replies:** 3\
**Last updated:** [October 21, 2013, 9:00am UTC](https://discuss.elastic.co/t/operation-listener-threading/14029 "2013-10-21T09:00:32Z")

</div>

Hello all, I’m looking for clarity on the intended behavior of the setOperationThreaded(…) and listenerThreaded(…) methods in the Java APIs that interact with an embedded cluster. I’ve pieced together some a…

---

## [ElasticApm class not found after configuration (Laravel)](https://discuss.elastic.co/t/elasticapm-class-not-found-after-configuration-laravel/328759)

<div class="topic-metadata">

**Author:** [@Thiago\_Medeiros](https://discuss.elastic.co/u/Thiago_Medeiros)\
**Replies:** 7\
**Last updated:** [March 31, 2023, 12:18pm UTC](https://discuss.elastic.co/t/elasticapm-class-not-found-after-configuration-laravel/328759 "2023-03-31T12:18:53Z")

</div>

I did what Elastic PHP agent tutorial says and have: elastic\_apm plugin shown in php info :white\_check\_mark: can use ElasticApm class :x: when I import ElasticApm class with use Elastic\\Apm\\ElasticApm I'm getting C…

---

## [Filter Plugin - "Tried to load a plugin's code, but failed."](https://discuss.elastic.co/t/filter-plugin-tried-to-load-a-plugins-code-but-failed/259216)

<div class="topic-metadata">

**Author:** [@smm](https://discuss.elastic.co/u/smm)\
**Replies:** 1\
**Last updated:** [December 21, 2020, 6:34am UTC](https://discuss.elastic.co/t/filter-plugin-tried-to-load-a-plugins-code-but-failed/259216 "2020-12-21T06:34:57Z")

</div>

Hi there, there is a logstash filter plugin called elapsed. I put (also) this into a config: elapsed { unique\_id\_field =\> "reqid" start\_tag =\> "TranBegin" end\_tag =\> "TranEnd" new\_event\_on\_match =\> false } a…

---

## [How to format aggregation output in kibana visualization](https://discuss.elastic.co/t/how-to-format-aggregation-output-in-kibana-visualization/253769)

<div class="topic-metadata">

**Author:** [@Adriann](https://discuss.elastic.co/u/Adriann)\
**Replies:** 7\
**Last updated:** [October 30, 2020, 1:44pm UTC](https://discuss.elastic.co/t/how-to-format-aggregation-output-in-kibana-visualization/253769 "2020-10-30T13:44:04Z")

</div>

I want to format output in Overall Average of Average system.cpu.total.norm.pct to percentage I red that I can use painless script in kibana vizulization creator. I could now found the proper syntax. How can I…

---

## [Kibana Date histogram - interpretation](https://discuss.elastic.co/t/kibana-date-histogram-interpretation/227745)

<div class="topic-metadata">

**Author:** [@nages](https://discuss.elastic.co/u/nages)\
**Replies:** 7\
**Last updated:** [April 24, 2020, 10:46pm UTC](https://discuss.elastic.co/t/kibana-date-histogram-interpretation/227745 "2020-04-24T22:46:24Z")

</div>

I am looking at the demo dashboard - https://demo.elastic.co/app/kibana#/visualize/edit/37cc8650-b882-11e8-a6d9-e546fe2bba5f?\_g=(refreshInterval:(pause:!f,value:900000),time:(from:'2020-03-25T11:15:07.466Z',to:'2020-04…

---

## [Heat Map with Date on one axis and time of the day on the other axis](https://discuss.elastic.co/t/heat-map-with-date-on-one-axis-and-time-of-the-day-on-the-other-axis/161584)

<div class="topic-metadata">

**Author:** [@stalwar1](https://discuss.elastic.co/u/stalwar1)\
**Replies:** 4\
**Last updated:** [December 20, 2018, 1:51pm UTC](https://discuss.elastic.co/t/heat-map-with-date-on-one-axis-and-time-of-the-day-on-the-other-axis/161584 "2018-12-20T13:51:55Z")

</div>

Hi All - I am very new to Kibana (2nd day) and I am trying to build a heat map where I can use date and time of the day on each of the axes. Currently, this is what I have X-Axis Aggregation -\> Date Histogram Interv…

---

## [Logstash/Elasticsearch Slow CSV Import](https://discuss.elastic.co/t/logstash-elasticsearch-slow-csv-import/22565)

<div class="topic-metadata">

**Author:** [@guardianmoon](https://discuss.elastic.co/u/guardianmoon)\
**Replies:** 4\
**Last updated:** [June 8, 2016, 8:57am UTC](https://discuss.elastic.co/t/logstash-elasticsearch-slow-csv-import/22565 "2016-06-08T08:57:20Z")

</div>

I'm testing out the ELK stack on my desktop (ie 1 node) and thought I'd start by pulling a flat file, having logstash parse and output it to Elasticsearch. The setup was easy, but working through the flat file is …

---

## [JDBC input plugin installed by default](https://discuss.elastic.co/t/jdbc-input-plugin-installed-by-default/33559)

<div class="topic-metadata">

**Author:** [@CraigFoote](https://discuss.elastic.co/u/CraigFoote)\
**Replies:** 6\
**Last updated:** [November 6, 2015, 8:07pm UTC](https://discuss.elastic.co/t/jdbc-input-plugin-installed-by-default/33559 "2015-11-06T20:07:01Z")

</div>

Any chance of anytime soon the JDBC Logstash input plugin being installed by default? https://rubygems.org/gems/logstash-input-jdbc

---

## [Understanding search-as-you-type Fields](https://discuss.elastic.co/t/understanding-search-as-you-type-fields/346661)

<div class="topic-metadata">

**Author:** [@safakkbilici](https://discuss.elastic.co/u/safakkbilici)\
**Replies:** 2\
**Last updated:** [November 9, 2023, 4:36pm UTC](https://discuss.elastic.co/t/understanding-search-as-you-type-fields/346661 "2023-11-09T16:36:43Z")

</div>

Hello community, I am using ES on my local machine with version of 8.10.4 I was experimenting with search-as-you-type lately and I am confused by ".\_2gram" and ".\_3gram" fields. I created a basic index as PUT autosugg…

---

## [Add AWS Cognito to Elastic Cloud hosted Elasticsearch and self-hosted Kibana](https://discuss.elastic.co/t/add-aws-cognito-to-elastic-cloud-hosted-elasticsearch-and-self-hosted-kibana/209508)

<div class="topic-metadata">

**Author:** [@firabby](https://discuss.elastic.co/u/firabby)\
**Replies:** 2\
**Last updated:** [November 26, 2019, 1:32pm UTC](https://discuss.elastic.co/t/add-aws-cognito-to-elastic-cloud-hosted-elasticsearch-and-self-hosted-kibana/209508 "2019-11-26T13:32:51Z")

</div>

I am very new to Elastic Stack. So, please forgive my ignorance. I am using version 7.4 What I want to achieve is, Integrate AWS cognito to kibana. Cognito user-pool has two user groups. Admin and User When a user si…

---

## [Elasticsearch 5.X unstable nodes on VMWare](https://discuss.elastic.co/t/elasticsearch-5-x-unstable-nodes-on-vmware/78306)

<div class="topic-metadata">

**Author:** [@olivier974](https://discuss.elastic.co/u/olivier974)\
**Replies:** 2\
**Last updated:** [March 13, 2017, 7:12am UTC](https://discuss.elastic.co/t/elasticsearch-5-x-unstable-nodes-on-vmware/78306 "2017-03-13T07:12:55Z")

</div>

Hello, we are facing a strange issue regarding the stability of data nodes. Here is our architecture : 3 data nodes (master set to false ) ingesting data from logstash without any processing pipeline 1 master node ( d…

---

## [Way to send RDS mysql logs to Elastic](https://discuss.elastic.co/t/way-to-send-rds-mysql-logs-to-elastic/204987)

<div class="topic-metadata">

**Author:** [@akki2208](https://discuss.elastic.co/u/akki2208)\
**Replies:** 1\
**Last updated:** [October 25, 2019, 9:03am UTC](https://discuss.elastic.co/t/way-to-send-rds-mysql-logs-to-elastic/204987 "2019-10-25T09:03:04Z")

</div>

Hello Elastic Team, I am working with filebeat's MySQL module for a long time. but I can see that similar logs are generated at AWS rds also. So after the 7.4 beat release(s3 as input), I want to ingest those rds logs…

---

## [Looking for complex scripting examples using Painless / Is this possible?](https://discuss.elastic.co/t/looking-for-complex-scripting-examples-using-painless-is-this-possible/100122)

<div class="topic-metadata">

**Author:** [@patuww](https://discuss.elastic.co/u/patuww)\
**Replies:** 0\
**Last updated:** [September 11, 2017, 7:27pm UTC](https://discuss.elastic.co/t/looking-for-complex-scripting-examples-using-painless-is-this-possible/100122 "2017-09-11T19:27:59Z")

</div>

Where is the best place to find good examples and documentation on painless (preferred) or java (if needed)? I am new to Elasticsearch and I am trying to find out if I am trying to do something possible? I am trying to…

---

## [How use translate in json object?](https://discuss.elastic.co/t/how-use-translate-in-json-object/108421)

<div class="topic-metadata">

**Author:** [@kar](https://discuss.elastic.co/u/kar)\
**Replies:** 5\
**Last updated:** [November 21, 2017, 7:45am UTC](https://discuss.elastic.co/t/how-use-translate-in-json-object/108421 "2017-11-21T07:45:09Z")

</div>

Hello This is my json: {"serial\_number":"36307","time":"2017-11-20 08:10:40.340 +03:00","transaciton\_id":"","card\_hash":"","component":"READER","level":"DEBUG","message":"Request": SrvOpen: SrvOpenRequest: {"TgComName…

---

## [\[ANNOUNCE\] es-sql 1.0.1 Query Elasticsearch using SQL](https://discuss.elastic.co/t/announce-es-sql-1-0-1-query-elasticsearch-using-sql/43015)

<div class="topic-metadata">

**Author:** [@taowen](https://discuss.elastic.co/u/taowen)\
**Replies:** 1\
**Last updated:** [February 29, 2016, 9:41pm UTC](https://discuss.elastic.co/t/announce-es-sql-1-0-1-query-elasticsearch-using-sql/43015 "2016-02-29T21:41:20Z")

</div>

https://github.com/taowen/es-monitor We love SQL and want to leverage the full power of elasticsearch. Using syntax like $ cat \<\< EOF | ./es\_query.py http://127.0.0.1:9200 WITH SELECT MAX(market\_cap) AS max\_all\_…

---

## [How to create/update fields to URL format?](https://discuss.elastic.co/t/how-to-create-update-fields-to-url-format/290730)

<div class="topic-metadata">

**Author:** [@brian661](https://discuss.elastic.co/u/brian661)\
**Replies:** 3\
**Last updated:** [December 3, 2021, 5:09am UTC](https://discuss.elastic.co/t/how-to-create-update-fields-to-url-format/290730 "2021-12-03T05:09:47Z")

</div>

I am trying to build my Kibana and automating the creation of the index patterns. For all of the index pattern, I want to update a field to format=URL, and set up the link on it, But I am not able to find the api I sho…

---

## [Parse nested JSON data into logstash](https://discuss.elastic.co/t/parse-nested-json-data-into-logstash/283039)

<div class="topic-metadata">

**Author:** [@Magesh\_02](https://discuss.elastic.co/u/Magesh_02)\
**Replies:** 3\
**Last updated:** [September 2, 2021, 1:05pm UTC](https://discuss.elastic.co/t/parse-nested-json-data-into-logstash/283039 "2021-09-02T13:05:31Z")

</div>

New to ELK stack, trying to import my JSON data into elastic serach, but its fails, since my json input is nested types. I have tried many solution but still i could not able to get. here is my input { "Folders": \[ …

---

## [It is possible to change the bulk\_max\_size and workers on a fleet managed agent?](https://discuss.elastic.co/t/it-is-possible-to-change-the-bulk-max-size-and-workers-on-a-fleet-managed-agent/324380)

<div class="topic-metadata">

**Author:** [@leandrojmp](https://discuss.elastic.co/u/leandrojmp)\
**Replies:** 4\
**Last updated:** [February 3, 2023, 3:50pm UTC](https://discuss.elastic.co/t/it-is-possible-to-change-the-bulk-max-size-and-workers-on-a-fleet-managed-agent/324380 "2023-02-03T15:50:33Z")

</div>

Hello, I'm using Elastic Agent with the AWS Cloudwatch integration to consume some logs, the volume of logs are pretty high and I'm trying to improve the performance of the Elastic Agent. Filebeat per default uses just…

---

## [Multi\_match on multiple indexes](https://discuss.elastic.co/t/multi-match-on-multiple-indexes/91327)

<div class="topic-metadata">

**Author:** [@naoko](https://discuss.elastic.co/u/naoko)\
**Replies:** 4\
**Last updated:** [July 10, 2017, 1:52pm UTC](https://discuss.elastic.co/t/multi-match-on-multiple-indexes/91327 "2017-07-10T13:52:57Z")

</div>

I have 2 indexes that I want to multi\_match fields each indexes has different fields (schema) for instance, idx1 has "subject" and "html\_body" and idex2 has "subject" and "detail". I have query like this { …

---

## [New EK install with Filebeat - 5.4 Stack](https://discuss.elastic.co/t/new-ek-install-with-filebeat-5-4-stack/85581)

<div class="topic-metadata">

**Author:** [@smulpuri](https://discuss.elastic.co/u/smulpuri)\
**Replies:** 4\
**Last updated:** [May 16, 2017, 3:34pm UTC](https://discuss.elastic.co/t/new-ek-install-with-filebeat-5-4-stack/85581 "2017-05-16T15:34:40Z")

</div>

I have installed Elasticsearch, Kibana and Filebeat along with x-Pack. This is all a 5.4 stack with basic license. At this point it is a standalone install and enabled parsing secure, messages, audit.log, apache access a…

---

## [Max retries exceeded with url: /pmc/documents.json.bz2 SSLCertVerificationError \[SSL: CERTIFICATE\_VERIFY\_FAILED\]](https://discuss.elastic.co/t/max-retries-exceeded-with-url-pmc-documents-json-bz2-sslcertverificationerror-ssl-certificate-verify-failed/335708)

<div class="topic-metadata">

**Author:** [@Swathi\_Kakumanu](https://discuss.elastic.co/u/Swathi_Kakumanu)\
**Replies:** 7\
**Last updated:** [July 5, 2023, 3:51pm UTC](https://discuss.elastic.co/t/max-retries-exceeded-with-url-pmc-documents-json-bz2-sslcertverificationerror-ssl-certificate-verify-failed/335708 "2023-07-05T15:51:39Z")

</div>

Hi, I am facing an issue with SSL Verification of esrally for rally-tracks.elastic.co', port=443 , however curl request and openssl works fine. FYI, internet works on the rally VM. Command used to run: esrally race -…

---

## [How to perform full text search for a numberic field?](https://discuss.elastic.co/t/how-to-perform-full-text-search-for-a-numberic-field/146467)

<div class="topic-metadata">

**Author:** [@betty](https://discuss.elastic.co/u/betty)\
**Replies:** 1\
**Last updated:** [August 29, 2018, 12:57pm UTC](https://discuss.elastic.co/t/how-to-perform-full-text-search-for-a-numberic-field/146467 "2018-08-29T12:57:06Z")

</div>

Hi experts, As the title described, I need to perform full-text search for a field with type "long". For example: {id: 100009078} I need to get it when I search for "78". Since the mapping cannot be changed once cre…

---

## [Unable to unpack kibana (6.2.2)](https://discuss.elastic.co/t/unable-to-unpack-kibana-6-2-2/123736)

<div class="topic-metadata">

**Author:** [@Rahul\_Lao](https://discuss.elastic.co/u/Rahul_Lao)\
**Replies:** 1\
**Last updated:** [March 14, 2018, 3:39am UTC](https://discuss.elastic.co/t/unable-to-unpack-kibana-6-2-2/123736 "2018-03-14T03:39:50Z")

</div>

I am trying to installing the complete ELK stack but facing issues with unpacking kibana 6.2.2 I am installing this on a VM using vagrant. My host machine is windows 7 sp1. VM os is ubuntu/trusty64. Vagrant version 2.0…

---

## [Multi language](https://discuss.elastic.co/t/multi-language/102905)

<div class="topic-metadata">

**Author:** [@TeMPOConsult](https://discuss.elastic.co/u/TeMPOConsult)\
**Replies:** 1\
**Last updated:** [October 6, 2017, 1:22am UTC](https://discuss.elastic.co/t/multi-language/102905 "2017-10-06T01:22:32Z")

</div>

Hi all does Kibana support localization, I mean to be able to select a specific language for the interface like French or Spanish ? Regards

---

## [Detected ambiguous Field Reference. How to fix it exactly?](https://discuss.elastic.co/t/detected-ambiguous-field-reference-how-to-fix-it-exactly/175076)

<div class="topic-metadata">

**Author:** [@jcaballero](https://discuss.elastic.co/u/jcaballero)\
**Replies:** 2\
**Last updated:** [April 2, 2019, 9:33pm UTC](https://discuss.elastic.co/t/detected-ambiguous-field-reference-how-to-fix-it-exactly/175076 "2019-04-02T21:33:55Z")

</div>

Hi LogStash 6.6.2 I see several topics with similar questions, but answers are unclear to me. So I ask again. In my filters, I have this mutate { add\_field =\> { "executionhost" =\> "%{host\[name\]}" } } mutate { sp…

---

## [How does filebeat (or logstash) converts single line of log to json data?](https://discuss.elastic.co/t/how-does-filebeat-or-logstash-converts-single-line-of-log-to-json-data/86243)

<div class="topic-metadata">

**Author:** [@Mohan\_Mahajan](https://discuss.elastic.co/u/Mohan_Mahajan)\
**Replies:** 2\
**Last updated:** [May 18, 2017, 12:43pm UTC](https://discuss.elastic.co/t/how-does-filebeat-or-logstash-converts-single-line-of-log-to-json-data/86243 "2017-05-18T12:43:29Z")

</div>

We already have a ELK cluster running. I wanted to understand how the single log (line) gets converted into json data in elasticsearch. Looking for pointers or explanation. Thanks! Mohan

---

## [Alert Variables in email action - EQL](https://discuss.elastic.co/t/alert-variables-in-email-action-eql/264695)

<div class="topic-metadata">

**Author:** [@jancodenew](https://discuss.elastic.co/u/jancodenew)\
**Replies:** 3\
**Last updated:** [February 22, 2021, 5:32pm UTC](https://discuss.elastic.co/t/alert-variables-in-email-action-eql/264695 "2021-02-22T17:32:42Z")

</div>

Hello, Can someone please help to add additional field to the alert variable? I have mentioned the Detection EQL rule logic below. sequence with maxspan=5m \[authentication where event.type == "authentication\_failure"\]…

---

## [Automatic alerting on forcast (machine learning)](https://discuss.elastic.co/t/automatic-alerting-on-forcast-machine-learning/260248)

<div class="topic-metadata">

**Author:** [@Landry](https://discuss.elastic.co/u/Landry)\
**Replies:** 3\
**Last updated:** [January 6, 2021, 12:59pm UTC](https://discuss.elastic.co/t/automatic-alerting-on-forcast-machine-learning/260248 "2021-01-06T12:59:28Z")

</div>

Hello, How can we automate machine learning forcast execution in order to notify customers when some unusual events will occurs in the next days. We have a machine learning job that detect anomalies on our datas. Actua…

---

## [Kibana Alerts - closing alert - impossible?](https://discuss.elastic.co/t/kibana-alerts-closing-alert-impossible/317734)

<div class="topic-metadata">

**Author:** [@xonicman](https://discuss.elastic.co/u/xonicman)\
**Replies:** 3\
**Last updated:** [October 30, 2022, 3:57pm UTC](https://discuss.elastic.co/t/kibana-alerts-closing-alert-impossible/317734 "2022-10-30T15:57:01Z")

</div>

Good day to all of you! I'm interacting with the Elastic 8.1 free version. Some alert rules are created that way, that alerts will be active forever I would like to close such alerts manually - for example, an alert i…

---

## [CVE-2021-45105 and CVE-2020-9488 vulnerabilities with java apm agent 1.28.4](https://discuss.elastic.co/t/cve-2021-45105-and-cve-2020-9488-vulnerabilities-with-java-apm-agent-1-28-4/294766)

<div class="topic-metadata">

**Author:** [@vin89](https://discuss.elastic.co/u/vin89)\
**Replies:** 3\
**Last updated:** [January 19, 2022, 7:53am UTC](https://discuss.elastic.co/t/cve-2021-45105-and-cve-2020-9488-vulnerabilities-with-java-apm-agent-1-28-4/294766 "2022-01-19T07:53:23Z")

</div>

After we upgraded to java apm agent version to 1.28.4 from 1.23.0 there were 2 vulnerabilities newly added And as I see in 1.28.4 version i could see log4j version being used is 2.12.4, so is there any plan to upgrad…

---

## [Elastic node fetchs all data from master on restart](https://discuss.elastic.co/t/elastic-node-fetchs-all-data-from-master-on-restart/50643)

<div class="topic-metadata">

**Author:** [@Dekel](https://discuss.elastic.co/u/Dekel)\
**Replies:** 3\
**Last updated:** [June 14, 2016, 12:37am UTC](https://discuss.elastic.co/t/elastic-node-fetchs-all-data-from-master-on-restart/50643 "2016-06-14T00:37:31Z")

</div>

I have a cluster with one master and several nodes, all nodes have complete replica of the data. The status of the cluster is green. When I'm doing stop/start of the service on one of the nodes in the cluster - that no…

---

## [Kubernetes + ELK + NGINX Ingress Controller](https://discuss.elastic.co/t/kubernetes-elk-nginx-ingress-controller/110809)

<div class="topic-metadata">

**Author:** [@Senthil\_Kumar1](https://discuss.elastic.co/u/Senthil_Kumar1)\
**Replies:** 1\
**Last updated:** [December 15, 2017, 11:48am UTC](https://discuss.elastic.co/t/kubernetes-elk-nginx-ingress-controller/110809 "2017-12-15T11:48:55Z")

</div>

Does anyone can give the document for ELK ( Elastic search, logstash, kibana and file beat ) with kubernetes. Specifically yaml files

---

## [Running into Guice creation errors (No implementation for org.elasticsearch.client.Client was bound.)](https://discuss.elastic.co/t/running-into-guice-creation-errors-no-implementation-for-org-elasticsearch-client-client-was-bound/42428)

<div class="topic-metadata">

**Author:** [@rahulcse](https://discuss.elastic.co/u/rahulcse)\
**Replies:** 1\
**Last updated:** [February 22, 2016, 9:49pm UTC](https://discuss.elastic.co/t/running-into-guice-creation-errors-no-implementation-for-org-elasticsearch-client-client-was-bound/42428 "2016-02-22T21:49:30Z")

</div>

I am trying to access a plugin created by me, using a transport client and I keep running into following error: Exception in thread "main" org.elasticsearch.common.inject.CreationException: Guice creation errors: 1) …

---

## [Soar in elastic](https://discuss.elastic.co/t/soar-in-elastic/334425)

<div class="topic-metadata">

**Author:** [@searchwithme](https://discuss.elastic.co/u/searchwithme)\
**Replies:** 4\
**Last updated:** [June 27, 2023, 5:25pm UTC](https://discuss.elastic.co/t/soar-in-elastic/334425 "2023-06-27T17:25:21Z")

</div>

I understand there is a way to create a case and assign to someone when an alert is triggered. But SOAR means automatic remediation. The documentation says 'Easily automate your team’s security incident response with Ela…

---

## [Grok fails on a valid regex](https://discuss.elastic.co/t/grok-fails-on-a-valid-regex/231781)

<div class="topic-metadata">

**Author:** [@konart](https://discuss.elastic.co/u/konart)\
**Replies:** 1\
**Last updated:** [May 9, 2020, 4:50pm UTC](https://discuss.elastic.co/t/grok-fails-on-a-valid-regex/231781 "2020-05-09T16:50:57Z")

</div>

Log: \[logstash.javapipeline \]\[main\] Pipeline aborted due to error {:pipeline\_id=\>"main", :exception=\>#\<RegexpError: unmatched close parenthesis: /(?\<loglevel\>DBG|INF|WRN)(?(?=(?:.\*(?:X-Request-Id|CorrelationId)))…

---

## [Error trying to create a repository in Azure ("No implementation for org.elasticsearch.repositories.Repository was bound")](https://discuss.elastic.co/t/error-trying-to-create-a-repository-in-azure-no-implementation-for-org-elasticsearch-repositories-repository-was-bound/48077)

<div class="topic-metadata">

**Author:** [@casieowen](https://discuss.elastic.co/u/casieowen)\
**Replies:** 4\
**Last updated:** [April 27, 2016, 6:00pm UTC](https://discuss.elastic.co/t/error-trying-to-create-a-repository-in-azure-no-implementation-for-org-elasticsearch-repositories-repository-was-bound/48077 "2016-04-27T18:00:46Z")

</div>

Hi, We're trying to create an azure repo. We're getting: D:\\data\\EsStaging\\casieotemp\>curl -XPUT "http://xxxxx:9200/\_snapshot/stgdevsnapshots" -d "{""type"": ""azure""}" {"error":"RemoteTransportException\[\[server…

---

## [Duplicate an existing graph/chart for another index](https://discuss.elastic.co/t/duplicate-an-existing-graph-chart-for-another-index/35989)

<div class="topic-metadata">

**Author:** [@Mohammed\_Abdul\_Khali](https://discuss.elastic.co/u/Mohammed_Abdul_Khali)\
**Replies:** 4\
**Last updated:** [December 1, 2015, 9:19am UTC](https://discuss.elastic.co/t/duplicate-an-existing-graph-chart-for-another-index/35989 "2015-12-01T09:19:01Z")

</div>

Hi, I have created a dashboard in kibana which has around 10-15 graphs which uses an index1 say for enviornment1. I have another similar index2 for env2 and i want to create dashboard2 but this time pointing to the …

---

## [Geoip stopped consolidating coordinates after logstash upgrade to 8.0](https://discuss.elastic.co/t/geoip-stopped-consolidating-coordinates-after-logstash-upgrade-to-8-0/298067)

<div class="topic-metadata">

**Author:** [@Shreesh\_Narayanan](https://discuss.elastic.co/u/Shreesh_Narayanan)\
**Replies:** 2\
**Last updated:** [February 23, 2022, 6:46pm UTC](https://discuss.elastic.co/t/geoip-stopped-consolidating-coordinates-after-logstash-upgrade-to-8-0/298067 "2022-02-23T18:46:22Z")

</div>

My logstash for geo tagging IPs are failing after logstash upgrade 8.0. Here's a snippet , i get the lat and lon values , but cant seem to get into the "destlocation" field "Dest\_IP" =\> { "geo" =\> { …

---

## [What is the best way to increase storage capacity?](https://discuss.elastic.co/t/what-is-the-best-way-to-increase-storage-capacity/225489)

<div class="topic-metadata">

**Author:** [@Travis](https://discuss.elastic.co/u/Travis)\
**Replies:** 2\
**Last updated:** [March 30, 2020, 4:43pm UTC](https://discuss.elastic.co/t/what-is-the-best-way-to-increase-storage-capacity/225489 "2020-03-30T16:43:48Z")

</div>

Hello Elasticians ! I need to add more data to Elastic and didn't found clear information on Google or forums So, what is for you the best way to achieve this and what are the impact ? extend actual disk ? attach…

---

## [Regex for path command](https://discuss.elastic.co/t/regex-for-path-command/61952)

<div class="topic-metadata">

**Author:** [@Tim\_James](https://discuss.elastic.co/u/Tim_James)\
**Replies:** 2\
**Last updated:** [October 3, 2016, 9:25am UTC](https://discuss.elastic.co/t/regex-for-path-command/61952 "2016-10-03T09:25:17Z")

</div>

Hi, Apologies for a newbie question. I want to store data from a log file withe a name like ctc-2016-09-30.0.log but in the same directory there are many other log files I don't want, including one that is called ctc…

---

## [Problem disk usage index (to large)](https://discuss.elastic.co/t/problem-disk-usage-index-to-large/84513)

<div class="topic-metadata">

**Author:** [@Beuhlet\_Reseau](https://discuss.elastic.co/u/Beuhlet_Reseau)\
**Replies:** 7\
**Last updated:** [May 10, 2017, 2:44pm UTC](https://discuss.elastic.co/t/problem-disk-usage-index-to-large/84513 "2017-05-10T14:44:48Z")

</div>

Hello, I have problem with my elasticsearch when i upload data to ES. Intput log file : - 26 Go - 174 871 772 lines in log file Output (index in ES) : - 48 Go (Increase of 12 Go) - same lines (its ok) Here an e…

---

## [Snapshot restore across versions?](https://discuss.elastic.co/t/snapshot-restore-across-versions/41218)

<div class="topic-metadata">

**Author:** [@Megha\_Meshram](https://discuss.elastic.co/u/Megha_Meshram)\
**Replies:** 1\
**Last updated:** [February 10, 2016, 2:11am UTC](https://discuss.elastic.co/t/snapshot-restore-across-versions/41218 "2016-02-10T02:11:06Z")

</div>

Is it possible to restore snapshots to a different version of ES cluster? Is this a recommended strategy for doing version upgrades to a standby cluster and using restore snapshots on it?

[Previous page](https://discuss.elastic.co/top.md?page=913&per_page=50&period=all)

[Next page](https://discuss.elastic.co/top.md?page=915&per_page=50&period=all)
