APM Agent does not start


Kibana version: 7.9

Elasticsearch version: 7.9

APM Server version: 7.9.2

APM Agent language and version: elastic-apm-agent-1.18.1.jar

Browser version: Chrome Versión 86.0.4240.75 (Build oficial) (64 bits)

Original install method (e.g. download page, yum, deb, from source, etc.) and version: yum

Fresh install or upgraded from other version? not

Is there anything special in your setup? not.

Description of the problem including expected versus actual behavior. Please include screenshots (if relevant):

Steps to reproduce:
Generic JVM arguments:

Errors in browser console (if relevant):not

Provide logs and/or server output (if relevant):

WAS native_stderr.log:
*Error: Could not find or load main class *
ERROR IndyBootstrap null
at java.nio.channels.spi.AbstractInterruptibleChannel.end(AbstractInterruptibleChannel.java:220)
at sun.nio.ch.FileChannelImpl.size(FileChannelImpl.java:327)
at com.sun.nio.zipfs.ZipFileSystem.findEND(ZipFileSystem.java:975)
at com.sun.nio.zipfs.ZipFileSystem.initCEN(ZipFileSystem.java:1042)
at com.sun.nio.zipfs.ZipFileSystem.(ZipFileSystem.java:142)
at com.sun.nio.zipfs.ZipFileSystemProvider.newFileSystem(ZipFileSystemPr

.WAS native_stdout.log:
Listening for transport dt_socket at address: 7779
2020-10-10 11:39:00,493 [main] INFO co.elastic.apm.agent.util.JmxUtils - Found JVM-specific OperatingSystemMXBean interface: com.ibm.lang.management.OperatingSystemMXBean
2020-10-10 11:39:00,781 [main] INFO co.elastic.apm.agent.configuration.StartupInfo - Starting Elastic APM 1.18.1 as - on Java 1.8.0_261 Runtime version: - pxa6480sr6fp15ifix-20200820_01(SR6 FP15+IJ26443) VM version: 2.9 (IBM Corporation) Linux 3.10.0-1160.2.1.el7.x86_64
2020-10-10 11:39:00,783 [main] WARN co.elastic.apm.agent.configuration.StartupInfo - To enable all features and decrease startup time, please configure application_packages
2020-10-10 11:39:08,265 [main] INFO co.elastic.apm.agent.impl.ElasticApmTracer - Tracer switched to RUNNING state
2020-10-10 11:39:08,339 [elastic-apm-init-instrumentation-shutdown-hook] INFO co.elastic.apm.agent.impl.ElasticApmTracer - Tracer switched to STOPPED state
2020-10-10 11:39:08,700 elastic-apm-remote-config-poller ERROR No Log4j 2 configuration file found. Using default configuration (logging only errors to the console), or user programmatically provided configurations. Set system property 'log4j2.debug' to show Log4j 2 internal initialization logging. See https://logging.apache.org/log4j/2.x/manual/configuration.html for instructions on how to configure Log4j 2
"native_stdout.log" 101L, 16237C

Java SDK:
SO: RHEL7.9 - 64bits

Java WAS:
[root@wasdev bin]# /opt/IBM/WebSphere/AppServer/java_1.8_64/jre/bin/java -version
java version "1.8.0_261"
Java(TM) SE Runtime Environment (build - pxa6480sr6fp15ifix-20200820_01(SR6 FP15+IJ26443))
IBM J9 VM (build 2.9, JRE 1.8.0 Linux amd64-64-Bit Compressed References 20200729_452626 (JIT enabled, AOT enabled)
OpenJ9 - 43296bc
OMR - 08b0594
IBM - 70917a2)
JCL - 20200720_01 based on Oracle jdk8u261-b13

Please provide the full log, or at least the full related stack trace.
Also, does it happens consistently every time you start the app or only occasionally?

Thank you very much for answering, I already solved it, the problem was something very silly.
In the JVM arguments I took out the \ (Backslash) and it worked perfect.

-javaagent:/opt/AgentAPMElastic/elastic-apm-agent-1.18.1.jar "\"
-Delastic.apm.service_name=BankIn123 "\"
-Delastic.apm.server_urls=http://192.x.x.x:8200 "\"


Thank you

Huh, good to know! Thanks for reporting :pray:
How does it work for you? Are you getting the insights you expected for? We don't test continuously on WAS, so it would be nice to get feedback on that.

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.