Cannot Start Logstash

I cannot install logstash successfully.

  1. I tried to do this

sudo /usr/share/logstash/bin/system-install /etc/logstash/startup.options systemd

The output is

Using provided startup.options file: /etc/logstash/startup.options
Manually creating startup for specified platform: systemd
Java HotSpot(TM) 64-Bit Server VM warning: INFO: os::commit_memory(0x00000000c53 30000, 986513408, 0) failed; error='Cannot allocate memory' (errno=12)
/usr/share/logstash/bin/system-install: line 88: #: command not found
Unable to install system startup script for Logstash.

  1. I tried to do this


The output is

/usr/share/logstash/bin/system-install: line 45: : No such file or directory

Does any solution please?


The error is not logstash specific. It is a java error.

have a read here it might help.

I try to do this trick

But I can not extract the file.tar.gz

Hi Achmad,

There are no tricks in IT :slight_smile: The error clearly says what the problem is. You dont have java installed on the machine your trying to install logstash.

I am not sure how and what and why but mabey a clear guide can help.

Please have a read here and I think this will push you in the right direction..


It maybe the RAM is too small, I will upgrade the RAM

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.