Invalid Config File

Once I deleted the previous index and re-ran logstash config file. I now don't have a time-field name field being displayed in the configure index pattern section. How do I fix this in order to visualize the data? Thanks

What's the mapping of the @timestamp field (use the get mapping API)? Have you refreshed the field list in Kibana?

Here is the result:

{"test2": {"aliases":{}, mappings, settings, : {"index":{"creation_date":"147...", "number_of_shards": "5", "number_of_replicas":"1",
"uuid":"QF...", "version":{"created":"203.."}}}, "warmers":}}}

But that's not valid JSON. I'm only asking about the @timestamp field so please making sure information about it is included.

Sorry I'm not following I ran cURL -XGET 'http://localhost:9200/test2/'

I am not seeing mapping of @timestamp in the field if you see above that was my results

Logstash always adds a @timestamp field to all events so unless you explicitly delete it the @timestamp field will have a mapping defined. Do you have any events in your index?

My template.json is as follows

     "template" : "test2"
     "settings" : {
                   "index.refresh_interval" : "5s"
       "mappings" : {
                            "_default_" : {
                           "_all_" : { "enabled" : true, "omit_norms" : true },
                           "properties" : {
                          "@timestamp" : { "type" :  "date", "doc_values" : true},
                          "location" : {
                                      "type" :  "geo_point",
                                      "dynamic" : true,
                                       "properties" : {
                                       "latitude" : { "type" : "float", "doc_values" : true },
                                        "longitude: : {"type" : "float", "doc_values" : true }

Do i need to run anything with cURL to get this to work like previously. For example I ran XPUT 'http://localhost:9200/test' after I ran -XDELETE as it was not finding any indexes.

Please answer my questions. Do you have any events in your index?

Not sure what you mean. I don't have events written in my json file.

I'm talking about your Elasticsearch index where you intend to add events. If you haven't yet added anything to your newly created index I'm not sure Kibana will display any fields in the pattern configuration screen.

Where am I looking for the elasticsearch index? I have the logstash config file reading a csv, pulling the longitude/latitude => writing it to Elasticsearch, I want to be able to view that in Kibana. What steps are needed to complete this part?

Right now I have the

  1. config file in logstash
  2. json template in Elastic search template folder

Previously I was able to view the data on Kibana but not able to map the geodata.
Once I ran XDELETE now I can't view the timestamp index pattern.

Sorry, but I'm out of patience. Maybe someone else can help out.