Logstash V.7.0 RC 2 installation with Java 11 fails

Hi Logstash dev's and friends,

Centos 7 64 Bit (latest all updates) (Virtual Machine)
Installation of Elasticsearch and Kibana on the same machine successfull. Tried first to install without Java but installation of Logstash V.7.0 RC 2 failed because it's need java. So I installed Java 11:

// Java 11 Installation
wget --no-cookies --no-check-certificate --header "Cookie: oraclelicense=accept-securebackup-cookie"   "http://download.oracle.com/otn-pub/java/jdk/11.0.2+9/f51449fcd52f4d52b93a989c5c56ed3c/jdk-11.0.2_linux-x64_bin.rpm"

yum localinstall jdk-11.0.2_linux-x64_bin.rpm

java -version

export JAVA_HOME=/usr/java/jdk-11.0.2
export PATH=$PATH:/usr/java/jdk-11.0.2/bin

Error after reinstalling packe Logstash:

Downloading packages:
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
  Installieren     : 1:logstash-7.0.0~rc2-1.noarch                                                                                                          1/1
Using provided startup.options file: /etc/logstash/startup.options
Java HotSpot(TM) 64-Bit Server VM warning: Option UseConcMarkSweepGC was deprecated in version 9.0 and will likely be removed in a future release.
WARNING: An illegal reflective access operation has occurred
WARNING: Illegal reflective access by org.jruby.util.SecurityHelper to field java.lang.reflect.Field.modifiers
WARNING: Please consider reporting this to the maintainers of org.jruby.util.SecurityHelper
WARNING: Use --illegal-access=warn to enable warnings of further illegal reflective access operations
WARNING: All illegal access operations will be denied in a future release
NoMethodError: undefined method `split' for nil:NilClass
   detect_systemd at /usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/pleaserun-0.0.30/lib/pleaserun/detector.rb:33
  detect_platform at /usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/pleaserun-0.0.30/lib/pleaserun/detector.rb:24
           detect at /usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/pleaserun-0.0.30/lib/pleaserun/detector.rb:18
   setup_defaults at /usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/pleaserun-0.0.30/lib/pleaserun/cli.rb:153
          execute at /usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/pleaserun-0.0.30/lib/pleaserun/cli.rb:119
              run at /usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/clamp-0.6.5/lib/clamp/command.rb:67
              run at /usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/pleaserun-0.0.30/lib/pleaserun/cli.rb:114
              run at /usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/clamp-0.6.5/lib/clamp/command.rb:132
           <main> at /usr/share/logstash/lib/systeminstall/pleasewrap.rb:12
/usr/share/logstash/bin/system-install: Zeile 88: systemd: Kommando nicht gefunden.
Unable to install system startup script for Logstash.
chmod: Zugriff auf „/etc/default/logstash“ nicht möglich: Datei oder Verzeichnis nicht gefunden
Warnung: %post(logstash-1:7.0.0~rc2-1.noarch) Scriptlet fehlgeschlagen, Beenden-Status 1
Non-fatal POSTIN scriptlet failure in rpm package 1:logstash-7.0.0~rc2-1.noarch
  Überprüfung läuft: 1:logstash-7.0.0~rc2-1.noarch                                                                                                          1/1

  logstash.noarch 1:7.0.0~rc2-1

[root@SVGWMA-ELK-TEST-01 ~]# sudo systemctl enable logstash
Failed to execute operation: No such file or directory

Any help, ideas :)? This is just a testinstallation so slow-down and take it easy.


A couple of folks have complained recently that the 6.7 install does not work with Java 11. Downgrading to Java 8 for the install helped them to get started, they ran the installed product with 11.

Yes with Java 8 it works fine and I can start Logstash. I run it now on Java 8. But that shouldn't be the end-solution.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.