Support Needed on Metricbeat setup issue


(Luke) #21

I realized my Logstash 's log having some errors, referring to some Permission denied errors to these files in /var/lob/logstash/ ..... but when I do ls command, I cant really see the files within it, even with root account?


(Tek Chand) #22

Can you please paste some error log and check the file with below command:

ls -lah

Thanks.


(Luke) #23

Hi, so far no error when I run the command.

image


(Luke) #24

I realized the service is not running:


(Tek Chand) #25

@skyluke.1987,

is your problem fixed or still your metricbeat service is showing not running?

Thanks.


(Luke) #26

Hi @Tek_Chand, I am able to start the service without much error. But when I went to check the service status, it shows me the errors above in my previous comment. "Failed to start Matricbeat is a lightweight shipper for metrics...."


(Tek Chand) #27

@skyluke.1987,

Can you please check the error log in /var/log/metricbeat/metricbeat or /var/log/syslog if you are using ubuntu machine else check in another file according to your OS.

Logs can be useful to fix the issue.

Thanks.


(Luke) #28

In the log, I do see this error. So is it that I need to enable the settings under elasticsearch.yml configuration file?
Exiting: Template loading requested but the Elasticsearch output is not configured/enabled


(Luke) #29

Hi all, may i know what is causing this issue? Kindly assist thanks


(Tek Chand) #30

@skyluke.1987,

To setup metricbeat you need to enable the elasticsearch output once in your metricbeat.yml file.

You need to enable the logstash output as well at same time then run the below commands:

metricbeat setup -e \
  -E output.logstash.enabled=false \
  -E output.elasticsearch.hosts=['your_elasticsearch_server_ip:9200'] \
  -E setup.kibana.host=your_kibana_server_ip:5601

It will fix your issue.

Thanks.


(Tek Chand) #31

@skyluke.1987,

You need to enable kibana setup as well so filebeat dashboard can be loaded.

setup.kibana:

  # Kibana Host
  # Scheme and port can be left out and will be set to the default (http and 5601)
  # In case you specify and additional path, the scheme is required: http://localhost:5601/path
  # IPv6 addresses should always be defined as: https://[2001:db8::1]:5601
  host: "your_kibana_server_IP:5601"

Thanks.


(Luke) #32

Thanks, I have manage to run the Metricbeat service already. Thanks


(system) closed #33

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.