Access Denied error with s3 plugin


(Amogh Desai) #1

I am trying to use the s3 plugin and I get below error:

 [[main]<s3] ERROR logstash.pipeline - A plugin had an unrecoverable error. Will restart this plugin.
  Plugin: <LogStash::Inputs::S3 bucket=>"xxxxxx", access_key_id=>"xxxxxxxxxxxx", secret_access_key=>"xxxxxxxxxxxxxxxxx/xxxx", delete=>false, codec=><LogStash::Codecs::CloudTrail id=>"cloudtrail_c79a87d9-s7t5-435a-a3ss-eecd3978526f", enable_metric=>true, charset=>"UTF-8">, type=>"AWS-cloudtrail", temporary_directory=>"/usr/share/logstash/data/", interval=>60, id=>"aace806f9c895bd9683b2bc8d4183df5e567df2d-11", enable_metric=>true, region=>"us-east-1">
  Error: Access Denied

This is my input:

 s3 {
   bucket => "xxxxxxxx"
   access_key_id => "xxxxxxxxxx"
   secret_access_key => "xxxxxx/xx"
   region => "us-east-1"
   prefix => "AWSLogs/xxxxxxx/CloudTrail/us-east-1/"
   sincedb_path => "/usr/share/logstash/data/cloudtrail_s3_sincedb"
   delete => false
  #  add_field => { source => gzfiles }
   codec => "cloudtrail"
   type => "AWS-cloudtrail"
   temporary_directory => "/usr/share/logstash/data/"
   interval => 60
  }

Have tried commenting region, sincedb, temp path.
Tried giving full access on those directories, also tried commenting codec.
Access key im using has full access to S3 (not just that bucket.)

Please help.


(system) #2

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.