Adding a date filter to CSV

hi magnus,
I am new to ELk.i have used the same date filter but index file is not generating in elastic search and am unable to see data in kibana. here is my config file
and my input is date, count
sep 03 2016,55

Please don't use screenshots. Use copy/paste.

Are you getting anything into ES?


Then your problem has nothing to do with the date filter.

Two likely root causes:

  • The input file is older than 24 hours and is ignored. Adjust the file input's ignore_older option.
  • Logstash is tailing the log file. Delete the sincedb file and/or set the file input's sincedb_path option to "nul" to effectively disable sincedb.

This is an extremely common problem for beginners so there's tons of material in the forum archives.

Thank you magnus!!