Apm econnrefused

Error: connect ECONNREFUSED <host>:8200
at Object._errnoException (util.js:992:11)
at _exceptionWithHostPort (util.js:1014:20)
at TCPConnectWrap.afterConnect [as oncomplete] (net.js:1186:14)

Trying to setup and connect to APM server on Azure ELK Stack. I installed APM on the kibana VM with the APM server configured to listen on localhost:8200.

I'm testing my NodeJS locally on a server and getting the error above, with host replaced with the public ip. Attempting to change the APM host to the public IP results in a 'too many colons in address' error.

On the VM I have port 8200 open inbound and outbound.

Any help would be appreciated.


Hi Scott,

Thanks for trying out Elastic APM. If you are running the NodeJS app on a different machine from the APM Server, you'll need to get APM Server to listen on a public interface. You can do that by starting APM Server with a configuration setting like so:

./apm-server -E apm-server.host=

You can also edit the apm-server.yml to achieve the same:

  host: localhost:8200

You'll want to familiarize yourself with the security implications of opening up a port to the world: https://www.elastic.co/guide/en/apm/get-started/master/install-and-run.html#secure-api-access

best of luck!


The resolution was to mimic the Kibana yml (auto generated with the Azure ELK stack template) and set the following:

    host: <Private IP>:8200

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.