[apm java agnet]Why did I specify apm.server_urls but still request localhost

Kibana version:
Elasticsearch version:
APM Server version:
APM Agent language and version:
java 1.35.0
Browser version:

Good question, from this screenshot I can't say why...
Try to play a bit with your command line, see that you can pass any arbitrary system property through -D and verify that it is accessible through your Java program. Once you are able to do that, you should do the same passing system properties to be used by the agent.
Otherwise, use a elasticapm.properties file to configure the agent instead of the command line (see documentation).

-D works after I set the VM option for idea, but not in cmd

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.