APM Sercurity Index priviliges error when starting


I am getting a security index privilege error when attempting to start APM in Kibana. I do not have any security enabled.

Kibana version:

Elasticsearch version:

APM Server version:

APM Agent language and version:

Browser version:
Chrome 81.0.4044.138 (64 bit)

Original install method (e.g. download page, yum, deb, from source, etc.) and version:

Fresh install or upgraded from other version?
upgrade 7.x

Is there anything special in your setup? For example, are you using the Logstash or Kafka outputs? Are you using a load balancer in front of the APM Servers? Have you changed index pattern, generated custom templates, changed agent configuration etc.
No, I do not have any security enabled, this is a basic install.

Description of the problem including expected versus actual behavior. Please include screenshots (if relevant):

Steps to reproduce:

  1. Try to start APM console

Errors in browser console (if relevant):

Provide logs and/or server output (if relevant):

Hi Barry,

Apologies for this issue. The error is annoying but isn't indicative of any real problem - only that security is disabled.
The bug has already been addressed and will be released in 7.8.

1 Like

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.