APM - UI transactions page is emtpy

Hello there,

I am trying to monitor my JBOSS Java7_80 server with APM.
I already tried to do so with the apm-server versions 7.9, 7.8, 7.7 and 7.6. Regarding the java attached agent, I have only used the version 1.17.
I cannot use the version 1.18 of the agent because it crashes the JVM due to a bug which has not been fixed. More information: JVM Crash with APM

The problem is that even though the apm-server and apm-agent seem to establish a connection successfully, the transaction page of the APM view is empty.

Kibana version : 7.9.0

Elasticsearch version : 7.9.2

APM Server version : 7.9.2

APM Agent language and version : Java 7_80

Browser version : Google Chrome 80.0.3987.149

Fresh install or upgraded from other version? Fresh install

Is there anything special in your setup? The communication between the agent and the APM server is plain within an internal network. The problem is the agent won't attach to the Java VM, so it has nothing to do with a communication issue with APM server.


The apm-server configuration is the following:

[root@SRVHIDS1 ~]# cat /etc/apm-server/apm-server.yml | grep -v '#' | sed -r '/^\s*$/d'
  host: ""
  setup.kibana.host: ""
  setup.dashboards.enabled: true
  logging.level: info
  logging.to_files: false
    enabled: false
    enabled: true
    host: ""
  hosts: [""]

Is it a compatibility issue? What would you say?

Thanks in advance!

Hi there,

That sounds odd. This should only happen if no transactions exist for the given service. You can try running the following query in Kibana Dev Tools to verify whether you have transactions or not:

GET apm-*/_search
  "query": {
    "bool": {
      "filter": [
          "term": {
            "service.name": "comerzzia-pre"
          "range": {
            "@timestamp": {
              "gte": "2020-10-01T00:00:00",
              "lte": "2020-10-10T00:00:00",
          "terms": {
            "processor.event": [

Hello, I have tried the API query you sent, you will find the result in the following pastebin link: https://pastebin.com/d3K45PCW

Do you see any problem?

Thanks in advance,

Okay, that's interesting. What is the response from this endpoint?


Btw. can you try expanding the time range in the UI to "Last 30 days" to see if there's data in the past. Could be that ingestion has stopped.


After querying the apm-server the result was a 404 http error:

[root@SRVHIDS1 ~]# curl "" -vvv
* About to connect() to port 8200 (#0)
*   Trying
* Connected to ( port 8200 (#0)
> GET /api/apm/services/comerzzia-pre/agent_name?start=2020-10-01T00%3A00%3A00.000Z&end=2020-10-10T00%3A00%3A00.000Z HTTP/1.1
> User-Agent: curl/7.29.0
> Host:
> Accept: */*
< HTTP/1.1 404 Not Found
< Content-Type: application/json
< X-Content-Type-Options: nosniff
< Date: Thu, 08 Oct 2020 10:54:02 GMT
< Content-Length: 36
  "error": "404 page not found"
* Connection #0 to host left intact

When I expand the range time I can see the data of the agent 1.18. Still, the apm java agent does not seem to report anything interesting. Do you think the issue could be related to compatibility version problem?

After querying the apm-server the result was a 404 http error:

Oh, sorry, I should have made it clear that it is an API in kibana. So more something like:


Okay, so you've actually started seeing data in the ui? What do you mean it's not interesting? Can you share a screenshot of it?

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.