Auto_flush_interval not working inside my TCP plugin

I'm using Multiline codec, along with my TCP input plugin.

And the problem I've is logstash is not processing the last line (it waits for the next line always).

Tried using auto_flush_interval option as well. But didn't help.

Any suggestions is appreciated.

Logstash version - 6.5.3

Take a look at this issue, and some others it links to (e.g. #57). Basically a multiline codec is not a good match for a tcp input.

Any other alternatives to that ?

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.