Azure Filebeat Module - 412 error


I recently used the filebeat module from Azure and it seems that I receive the logs extremely hard. They are delayed and when they finally come, they come in a bulk. Do you know why this is happening? As an analyst this is complicating my job a lot.
Also, when I try to restart the filebeat from my filebeat server, I receive the following error (print screen). The error 412 that there was a lease on the blob and the blob ID was not specified. I tried to delete the blob and restart the filebeat again and that worked, but this

is not normal. I shouldn't delete and then restart the filebeat module every time I do not receive the logs in time.
Is there any possibility that the module can be modified or updated so I don't receive this error anymore?
On the internet I didn't find anything specific regarding this error or even if I do find, it's outdated.
Thank you!

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.