Beats v8.12.0 use with ELK v8.0.0

Hi Team,

Could anyone help on below scenario.

I am using elasticsearch and Kibana of v8.0.0 docker image and wanted to use beats of v8.12.0 of windows (not docker)

I do have docker images for beats on few linux machine where the v8.12.0 of beats (i.e is docker) works with v8.0.0 of ELK via using "allow_older_version: true"

But when i use same "allow_older_version" for windows beatsv8.12.0 it won't work with elk v8.0.0

How can i make v8.12.0 of windows beats work with ELK 8.12.0

Hi @Gaurav_kr,

Welcome to the community! Can you share what you mean by it won't work? Are you seeing a particular error in your metricbeat or elasticsearch logs?

Is there a particular reason you want to use a later version of beats? Is upgrading your ELK stack an option? As listed in the documentation, ideally you would be on the same or higher version of Metricbeat:

For optimal experience, Metricbeat only connects to instances that are at least on the same version as the Beat. The check can be disabled by setting output.elasticsearch.allow_older_versions .

Let us know the error and we'll do our best to help!

1 Like

Thanks @carly.richmond for reply. It is working with the allow_older_version check I might have done something wrong earlier. Thanks again

1 Like