Beta issues

Guess that's why they call it a beta :wink: Per first-event

[07:07:33 @tester:/usr/share/logstash$] bin/logstash -e 'input { stdin { } } output { stdout {} }'
ArgumentError: Path "/usr/share/logstash/data" is not a directory or not writable.
  initialize at /usr/share/logstash/logstash-core/lib/logstash/settings.rb:372
        call at org/jruby/
    validate at /usr/share/logstash/logstash-core/lib/logstash/settings.rb:174
  initialize at /usr/share/logstash/logstash-core/lib/logstash/settings.rb:127
  initialize at /usr/share/logstash/logstash-core/lib/logstash/settings.rb:368
    LogStash at /usr/share/logstash/logstash-core/lib/logstash/environment.rb:18
      (root) at /usr/share/logstash/logstash-core/lib/logstash/environment.rb:9
     require at org/jruby/
      (root) at /usr/share/logstash/logstash-core/lib/logstash/runner.rb:1
     require at org/jruby/
      (root) at /usr/share/logstash/lib/bootstrap/environment.rb:67

so let's try as user logstash:

[07:09:22 @tester:/usr/share/logstash$] sudo -u logstash bin/logstash -e 'input { stdin { } } output { stdout {} }'
INFO: Logstash has a new settings file which defines start up time settings. This file is typically located in $LS_HOME/config or /etc/logstash. If you installed Logstash through a package and are starting it manually please specify the location to this settings file by passing in "--path.settings=/path/.." in the command line options
ERROR: Failed to load settings file from "path.settings". Aborting... path.setting=/usr/share/logstash/config, exception=Errno::ENOENT, message=>No such file or directory - /usr/share/logstash/config/logstash.yml about with path info?

[07:08:40 @tester:/usr/share/logstash$] sudo -u logstash bin/logstash --path.settings=/etc/logstash -e 'input { stdin { } } output { stdout {} }'
[07:09:22 @tester:/usr/share/logstash$] 

it starts finally, but then exits without waiting for input. Even all the below debug commands come up with empty responses:

[07:18:26 @tester:/usr/share/logstash$] sudo -u logstash bin/logstash --path.settings=/etc/logstash --log.level=trace --config.debug
[07:19:59 @tester:/usr/share/logstash$] sudo -u logstash bin/logstash --path.settings=/etc/logstash --log.level=debug --config.debug
[07:21:36 @tester:/usr/share/logstash$] sudo -u logstash bin/logstash --path.settings=/etc/logstash --log.level=debug -t
[07:23:05 @tester:/usr/share/logstash$] sudo -u logstash bin/logstash --path.settings=/etc/logstash --log.level=debug -t -f /home/logstash-test.conf 

Looks like I won't bet doing any more testing this weekend. This is with Ubuntu 16.04 64 bit using oracle-java8-installer 8u101+8u101arm-1~webupd8~2

How did you install it?

sudo dpkg -i logstash-5.0.0-beta1.deb


 new debian package, version 2.0.
 size 106279368 bytes: control archive=293977 bytes.
      83 bytes,     3 lines      conffiles            
     316 bytes,    11 lines      control              
 1332377 bytes, 10391 lines      md5sums              
     449 bytes,    12 lines   *  postinst             #!/bin/sh
     291 bytes,    12 lines   *  preinst              #!/bin/sh
     974 bytes,    38 lines   *  prerm                #!/bin/sh
 Package: logstash
 Version: 1:5.0.0~beta1-1
 License: Apache 2.0
 Vendor: Elasticsearch
 Architecture: all
 Maintainer: <vagrant@packer-virtualbox-iso-1468515721>
 Installed-Size: 193649
 Section: default
 Priority: extra
 Description: An extensible logging pipeline

As always thanks Mark.


....Though I will say, having a topic like "Beta a complete disaster" isn't a good way to go about asking for help from the developers :wink:

Very true....but at this stage...yeesh. I've tried this on two different linux boxes...some thing...kinda shot my morning down :frowning:

I even nuked java9, since it's no workie with logstash and installed 8. I scraped my entire functional elk 2.4.1/2.4.0/4.6.1 testlab since I figured the 5. betas will be released by the time I go production ya know? Just frustrating to make all these changes and then get stopped at this spot. Anyway thanks Mark...guess I'll just wait it out.

Long story short: with beta it appears that even during initial testing you MUST have a conf file in /etc/logstash/conf.d or otherwise you won't get any all.