Block in start_input

Hi,
This is my conf file:
input {
file {
path => "/Users/Parm/cars.csv"
start_position => "beginning"
sincedb_path => "/dev/null"
}
}

filter { csv {
separator => ","
columns => [ "maker", "model", "mileage", "manufacture_year", "engine_displacement",
"engine_power", "body_type", "color_slug", "stk_year", "tranmission", "door_count",
"seat_count", "fuel_type", "date_created", "date_last_seen", "price_eur" ]
}
mutate {convert => ["mileage", "integer"]}
mutate {convert => ["price_eur", "float"]}
mutate {convert => ["engine_power", "integer"]}
mutate {convert => ["door_count", "integer"]}
mutate {convert => ["seat_count", "integer"]}
}
output {
elasticsearch {
hosts => "localhost"
index => "cars"
document_type => "sold_cars"
}
stdout {}
}

I am getting this error when trying to upload to Kibana via logstash:

Watch with file and sincedb collections
[2020-07-31T17:10:24,002][ERROR][logstash.javapipeline ][main][25037192ef873c7bf18963c1adc495f35247161f16dda4bda89d7088a2027048] A plugin had an unrecoverable error. Will restart this plugin.
Pipeline_id:main
Plugin: <LogStash::Inputs::File start_position=>"beginning", path=>["/Users/Parm/cars.csv"], id=>"25037192ef873c7bf18963c1adc495f35247161f16dda4bda89d7088a2027048", sincedb_path=>"/dev/null", enable_metric=>true, codec=><LogStash::Codecs::Plain id=>"plain_64fb0f18-321b-4a94-96b5-62f8596a3ec1", enable_metric=>true, charset=>"UTF-8">, stat_interval=>1.0, discover_interval=>15, sincedb_write_interval=>15.0, delimiter=>"\n", close_older=>3600.0, mode=>"tail", file_completed_action=>"delete", sincedb_clean_after=>1209600.0, file_chunk_size=>32768, file_chunk_count=>140737488355327, file_sort_by=>"last_modified", file_sort_direction=>"asc", exit_after_read=>false, check_archive_validity=>false>
Error: Permission denied - Permission denied
Exception: Errno::EACCES
Stack: org/jruby/RubyFile.java:1267:in utime' uri:classloader:/META-INF/jruby.home/lib/ruby/stdlib/fileutils.rb:1133:in block in touch'
org/jruby/RubyArray.java:1809:in each' uri:classloader:/META-INF/jruby.home/lib/ruby/stdlib/fileutils.rb:1130:in touch'
/Users/Parm/logstash-7.8.1/vendor/bundle/jruby/2.5.0/gems/logstash-input-file-4.1.18/lib/filewatch/sincedb_collection.rb:22:in initialize' /Users/Parm/logstash-7.8.1/vendor/bundle/jruby/2.5.0/gems/logstash-input-file-4.1.18/lib/filewatch/observing_base.rb:62:in build_watch_and_dependencies'
/Users/Parm/logstash-7.8.1/vendor/bundle/jruby/2.5.0/gems/logstash-input-file-4.1.18/lib/filewatch/observing_base.rb:56:in initialize' /Users/Parm/logstash-7.8.1/vendor/bundle/jruby/2.5.0/gems/logstash-input-file-4.1.18/lib/logstash/inputs/file.rb:345:in start_processing'
/Users/Parm/logstash-7.8.1/vendor/bundle/jruby/2.5.0/gems/logstash-input-file-4.1.18/lib/logstash/inputs/file.rb:361:in run' /Users/Parm/logstash-7.8.1/logstash-core/lib/logstash/java_pipeline.rb:374:in inputworker'
/Users/Parm/logstash-7.8.1/logstash-core/lib/logstash/java_pipeline.rb:365:in `block in start_input'


I have given myself all rwx permissions and still get this error

The permissions error occurs when trying to touch the sincedb. The default path for the sincedb is under <path.data>/plugins/inputs/file. Make sure the user running logstash has write access to that directory.

If I recall correctly you can enable '--log.level debug' and it will give you the exact path of the sincedb.