Can not be updated Lostash plugin if it is via a proxy

I try Logstash update 6.5.4 → 6.6.0.(Via proxy)
The following error message will fail and fail.


Error Bundler::HTTPError, retrying 1/10
Could not fetch specs from

But It will succeed if it does not go through the proxy.

Check the following and both 「HTTPS_PROXY=http://」and 「HTTP_PROXY=http://」 settings are done.

Also, Elasticsearch has successfully updated plugins via a similar proxy.

Is there any procedure or mistake?

Is there a question here?

Oh!I forgot to write.
「Is there any procedure or mistake?」add


I am unsure what you mean here but I'll give it a go anyway.

Assuming your using linux, you open a terminal and you type:

export http_proxy=<your proxy server>
export https_proxy=<your proxy server>

That should be enough to connect to the outside world.
Please notice the lowercase of http_proxy and https_proxy.

In the same terminal you execute your upgrade commands.

I hope this helps,

1 Like


I have all 4 combinations setup, http_proxy, https_proxy, HTTP_PROXY, HTTPS_PROXY.
But Update failed.
I can do curl/wget properly with the proxy.........

I also found a question of a similar event.

It seems like a problem not solved here as well.

I have confirmed that the procedure is not wrong, so I will check the proxy settings.

You can try the following, edit the file


and where the line says export JRUBY append the following

-J-Dhttp.proxyHost=<proxy.server> -J-Dhttp.proxyPort=<proxy.port>

That could work as well..


Thank you very much!!!
Once export to JRUBY_OPTS, it succeeded.

This problem was solved. Thanks!!

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.