Cannot install logstash-input-salesforce

After a fresh install of logstash

# /usr/share/logstash/bin/logstash-plugin install --version 3.0.5 --no-verify logstash-input-salesforce
Installing logstash-input-salesforce
Plugin version conflict, aborting
ERROR: Installation Aborted, message: Bundler could not find compatible versions for gem "faraday":
  In snapshot (Gemfile.lock):
    faraday (= 0.15.4)

  In Gemfile:
    logstash-input-rss java was resolved to 3.0.5, which depends on
      faraday java

    logstash-input-salesforce (= 3.0.5) java was resolved to 3.0.5, which depends on
      restforce (~> 2.4.2) java was resolved to 2.4.2, which depends on
        faraday (~> 0.9.0) java

    octokit (~> 4) java was resolved to 4.14.0, which depends on
      sawyer (>= 0.5.3, ~> 0.8.0) java was resolved to 0.8.2, which depends on
        faraday (> 0.8, < 2.0) java

Running `bundle update` will rebuild your snapshot from scratch, using only
the gems in your Gemfile, which may resolve the conflict.

I am not really sure what the conflict is here. It seems that logstash wants a version of faraday that is greater than 0.8, and less than 2.0; which 0.15 fulfills.

All I can find indicates this is a problem with the way logstash is built, that the devs must change. That information is almost 2 years old at this point.

My understanding is that a ~ dependency only allows you to change the last field of the specified version. So ~> 0.9.0 can be any version of 0.9. 0.15.4 does not satisfy that dependency, although it would satisfy ~> 0.9

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.