Can't modify the default index name

Hi,

I am just trying to setup FileBeat to push logs from file to ElasticSearch Index. Here is my config. I'm expecting the data to be indexed to dummy-2019.07.11, but No matter what I change, Data is always being indexed to default index name filebeat-7.2.0-2019.07.11-000001. Could you please check and correct me If there is anything wrong in the below conf.

filebeat.inputs:
- type: log
  enabled: true
  paths:
    - /training/log/*

filebeat.config.modules:
  path: ${path.config}/modules.d/*.yml
  reload.enabled: false
setup.template.name: "dummy"
setup.template.pattern: "dummy-*"
setup.template.settings:
  index.number_of_shards: 1

setup.kibana:

output.elasticsearch:

  hosts: ["localhost:9500"]
  index: "dummy-%{+YYYY.MM.dd}"

  protocol: "http"
  username: "elastic"
  password: "changeme"

processors:
  - add_host_metadata: ~
  - add_cloud_metadata: ~

Added below to my config and it resolved the issue. By default it's true

setup.ilm.enabled: false