Can't rename index

Good day! i using elasticsearch & kibana & filebeat agent latest versions, and i can't setup index name, every time the index call "filebeat-7.6.2" and i don't understand why... i tried setup my agent from the documentation or elastic discus topics.... help please, my config filebeat is:

- type: log

# Change to true to enable this input configuration.
  enabled: true

# Paths that should be crawled and fetched. Glob based paths.
    - /var/log/*.log
  # Glob pattern for configuration loading
  path: ${path.config}/modules.d/*.yml

  # Set to true to enable config reloading
  reload.enabled: false

  # Period on which files under path should be checked for changes
  #reload.period: 10s

#Elasticsearch template setting

  index.number_of_shards: 1
  #index.codec: best_compression
  #_source.enabled: false

  host: ""

#Elasticsearch output
  # Array of hosts to connect to.
  hosts: [""]
  output.elasticsearch.index:: "postgresql-fb-%{+yyyy.MM.dd}" "postgresql-fb"
  setup.template.pattern: "postgresql-fb-*"
  setup.template.enabled: true
1 Like

@My_Google_Account, the "postgresql-fb"
      setup.template.pattern: "postgresql-fb-*"
      setup.template.enabled: true

should be outside the output.elasticsearch config option.
Also, line:
output.elasticsearch.index:: "postgresql-fb-%{+yyyy.MM.dd}"
should be
index:: "postgresql-fb-%{+yyyy.MM.dd}"
Can you try now?

i tryed, but again, same name filebeat-7.6.2

i saw in output after service started:
INFO [index-management] idxmgmt/std.go:182 Set output.elasticsearch.index to 'filebeat-7.6.2' as ILM is enabled.

i tryed disable ILM ... but same name again .... filebeat-7.6.2 or created with this name filebeat-7.6.2-2020.04.23-000001

i steel need help please!

1 Like

I can confirm this behaviour

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.