Changing Logstash Configuration to solve OutofMemoryError


(rpazhyannur) #1

Hello..

I get the following logstash error

Specify -J-Xmx####m to increase it (#### = cap size in MB).
Specify -w for full OutOfMemoryError stack trace"

I am not sure which configuration file I should change.
Currently, I run logstash using
systemctl start logstash

I am running on Centos and I can't locate logstash.yml or jvm.options.

thanks in advance for your help

best

Rajesh


(rpazhyannur) #2

Looks like the config was in

/etc/sysconfig/logstash.

Arguments to pass to java

LS_HEAP_SIZE="2g"
#LS_JAVA_OPTS="-Djava.io.tmpdir=$HOME"


(system) #3

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.