Class loading failure with Logstash 2.1.0: oracle.sql.STRUCT


(Jukka Rahkonen) #1

Hi,

I have installed Logstash 2.1.0 on Windows from the zip file and I have tried to read data from Oracle through the input-jdbc plugin. I got it almost to work thanks to this discussion Logstash JDBC input Oracle settings.

However, I can't write data into ElasticSearch. This is the beginning of the error message:

Failed to load class 'oracle.sql.STRUCT$Access4JacksonDeserializerffec0bcb'
: com.fasterxml.jackson.module.afterburner.ser.BeanPropertyAccessor {:class=>"Jr
Jackson::ParseError", :backtrace=>["com/jrjackson/JrJacksonBase.java:78:in `gene
rate'",

Am I missing something from my installation?


(Jukka Rahkonen) #2

Problem solved. I had placed ojdbc6.jar into \bin directory as

jdbc_driver_library => "ojdbc6.jar"

Logstash.bat that is also in \bin did find ojdbc6.jar and process started, but later when the Jackson parser was needing oracle.sql.STRUCT class from ojdbc6.jar it was not found. Using absolute path solved the issue

jdbc_driver_library => "c:/logstash-2.0.0/bin/ojdbc6.jar"


(system) #3