Connect to ElasticSearch with HTTPS

Hello guys,

We are using HTTPS for connection to ElasticSearch. However We are trying to configurate metricbeat in Windows10 and we cant connect to elastic. We have the next configuracion en metricbeat.yml:

=================================== Kibana ===================================

Kibana Host

Scheme and port can be left out and will be set to the default (http and 5601)

host: "https://172.16.10.35:5601"
username: "elastic"
password: "xxxxxxx"

---------------------------- Elasticsearch Output ----------------------------

output.elasticsearch:

Array of hosts to connect to.

hosts: ["https://172.16.10.35:9200"]

Protocol - either http (default) or https.

#protocol: "https"

username: "elastic"
password: "xxxxxxxx"

Howerver we can run command setup we see the next error:

PS C:\Program Files\Metricbeat> .\metricbeat.exe setup
Overwriting ILM policy is disabled. Set setup.ilm.overwrite:true for enabling.

Index setup finished.
Loading dashboards (Kibana must be running and reachable)
Exiting: error connecting to Kibana: fail to get the Kibana version: HTTP GET request to http://localhost:5601/api/status fails: fail to execute the HTTP GET request: Get http://localhost:5601/api/status: dial tcp [::1]:5601: connectex: No se puede establecer una conexión ya que el equipo de destino denegó expresamente dicha conexión.. Response: .
PS C:\Program Files\Metricbeat>

PS C:\Program Files\Metricbeat> .\metricbeat.exe setup
Exiting: couldn't connect to any of the configured Elasticsearch hosts. Errors: [error connecting to Elasticsearch at https://172.16.10.35:9200:9200: Get https://172.16.10.35:9200: x509: certificate signed by unknown authority]
PS C:\Program Files\Metricbeat>

Any advice?

I believe you need to use certificates that are signed by a trusted authority or configure one as trusted (self-signed certificates). You might be missing this step.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.