Connecting Filebeat to Azure Redis

I'm trying to use Filebeat to connect to Azure Redis. Filebeat version is 6.0, and azure redis (platform service) is version 3.2.7 as I see in azure. But, I'm not able to successfully ship any data to redis cache.

When I read filebeat documentation for redis output (, my understanding is that it cannot use http(s) based connection to redis.

I tried using socks proxy from my local machine and also tried from my a machine in azure. Both the cases, it cannot connect. I'm receiving below error.

ERR Failed to connect: read tcp IP:Port->IP:Port: i/o timeout

IP resolution is done with, but not connecting.

I;m not able to figure out what the reason is and is blocked.

Any help is appreciated.

Didn't get any reply.

Any help is appreciated.

Redis is not based upon HTTP(S). Redis implements it's own protocol. I haven't used the Azure Redis Cache service myself, but it seems the HTTP REST API is only for setting up/managing redis instances. The sample documentation on using redis-cache from you applications referes to plain redis clients.

For example the python tutorial gives you some intro on setting up a Redis Cache instance + uses the plain redis client libraries (no extra magic). In the tutorial SSL/TLS is disabled. This is cause TLS/SSL is by default not available with redis (Microsoft seems to add TLS support) and client libs (stunnel is often used with redis). For testing purposes you can try with SSL disabled first, but beats provides SSL support (which you also need to configure properly).

Thanks steffen. I could connect to azure redis. I didn't add ssl.enabled to the configuration.

Yes, as you specified http rest apis are for setting up/managing.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.