Curator while deleting the old snapshots, times out in middle of operation


#1

Hi,

We are storing snapshots in a NETAPP S3 bucket and while deleting the old snapshots using curator, it is required to at least 10 min to delete a single snapshot on the NETAPP S3 bucket. We have a lot of older snapshots in the bucket and while deleting snapshots older than 45 days, the operation gets timed out.

PFB the configuration file.

curator-action.yml:

actions:
  1:
    action: delete_snapshots
    description: >-
      Delete snapshots from the selected repository older than 45 days
      (based on creation_date), for 'curator-' prefixed snapshots.
    options:
      ignore_empty_list: True
      timeout_override:
      continue_if_exception: False
      repository: elasticsearch_backups
      retry_interval: 120
      retry_count: 3
      disable_action: False
      wait_for_completion: True
    filters:
    - filtertype: pattern
      kind: prefix
      value: curator-2017
      exclude:
    - filtertype: age
      source: creation_date
      direction: older
      unit: days
      unit_count: 45 

curator.yml:

client:
  hosts:
    - X.X.X.X
  port: 9200
  url_prefix:
  use_ssl: False
  certificate:
  client_cert:
  client_key:
  ssl_no_validate: False
  http_auth:
  timeout: 120
  master_only: True
logging:
  loglevel: DEBUG
  logfile:
  logformat: default
  blacklist: ['elasticsearch', 'urllib3'] 

To surpass the timeout we are currently changing the timeouts to a bigger value.

Could you please help us if there is any other way to overcome the timeout.

Many thanks.


(Aaron Mildenstein) #2

Please format your code, logs or configuration files using </> icon as explained in this guide and not the citation button. It will make your post more readable.

Or use markdown style like:

```
CODE
```

There's a live preview panel for exactly this reasons.

Lots of people read these forums, and many of them will simply skip over a post that is difficult to read, because it's just too large an investment of their time to try and follow a wall of badly formatted text.
If your goal is to get an answer to your questions, it's in your interest to make it as easy to read and understand as possible.
Please update your post.


#3

@theuntergeek i made the changes, can you please have a look


(Aaron Mildenstein) #4

Is it timing out at exactly the 120 second mark? You can use the timeout_override option to override the timeout specifically for that particular action.

For the pending Curator 5.5 release, a higher default timeout for the delete_snapshots action is coming. Regardless, it is uncommon for this to be needed, except when the remote filesystem is exceptionally slow to respond.


(system) closed #5

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.