Deprecation.logstash.codecs.plain

How do I solve this. Logstash is working but the message is repeating all the time

[deprecation.logstash.codecs.plain] Relying on default value of pipeline.ecs_compatibility, which may change in a future maj or release of Logstash. To avoid unexpected changes when upgrading Logstash, please explicitly declare your desired ECS Compatibility mode.

You need to explicitly set the value for pipeline.ecs_compatibility.

To avoid unexpected changes when upgrading Logstash, please explicitly declare your desired ECS Compatibility mode.

You can set it per pipeline in the pipelines.yml file or globally in the logstash.yml file.

Here is the documentation on how to configure it.