Did Logstash 1.5.3 version is compatible with Solaris 11.3 version


(Yogesh) #1

The logstash 1.5.3 version is working fine in the Solaris 10.x version.
After OS version migrated to 11.3 we are not able to start the logstash service?

which version of Logstah can be used on Solaris 11.3 - it has to output lumberjack to Logstash 1.4.2 (server side)?

I see there is some issue in the ruby script setting up the environment details:
/apps/apache/logstash-1.5.3/lib/bootstrap/environment.rb ,bundler.rb

when I have checked with logstash 2.3 and logstash 5.4 ,I see same issue?

could you one suggest regarding this issue?


(Magnus Bäck) #2

I see there is some issue in the ruby script setting up the environment details:

Show the full error message.


(Yogesh) #3

Hi Mangus,

Thanks for looking into the issue.

Here is the exception message when I am debugging through the echo statement in servers.

Please let me know in case of any details need.

TypeError: can't convert nil into String
join at org/jruby/RubyFile.java:1962
join at org/jruby/RubyFile.java:858
logstash_gem_home at /apps/apache/logstash-1.5.3/lib/bootstrap/environment.rb:40
setup! at /apps/apache/logstash-1.5.3/lib/bootstrap/bundler.rb:38
(root) at /apps/apache/logstash-1.5.3/lib/bootstrap/environment.rb:51

Regards,
Yogesh


(Yogesh) #4

Magnus / ES Team,

is there any update on this request ?

Regards,
Yogesh


(Magnus Bäck) #5

No, I don't know what's up.


(system) #6

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.