Difficulty with zeromq input plugin

I am trying to use logstash with the zeromq input plugin. Whenever I start logstash with my configuration, I get the following error:

Unable to load this gem. The libzmq library (or DLL) could not be found.
If this is a Windows platform, make sure libzmq.dll is on the PATH.
If the DLL was built with mingw, make sure the other two dependent DLLs,
libgcc_s_sjlj-1.dll and libstdc++6.dll, are also on the PATH.
For non-Windows platforms, make sure libzmq is located in this search path:

Here there is a long list of paths, including the following:

["[...]/elk/logstash-2.3.3/vendor/bundle/jruby/1.9/bin/libzmq.so", [...]]

I added a symlink with the above name that points to a libzmq.so that can be found in another directory. (Note that I have no root access.)

This, however, did not solve the problem, and I keep getting the same error whenever I launch logstash with my config.

Any ideas how to fix this?
(for reference, here is the same error posted on github: https://github.com/elastic/logstash/issues/2426)

I have the same problem,any ideas how to fix this?