Disable retry for some elasticsearch outputs


#1

Hello,

I have a logstash cluster which get logs from redis and then send them to several elasticsearch instances. One of them isn't under my management.
My problem is when this one is faulty (retrying failed action with response code: 503 ({"type"=>"unavailable_shards_exception"), logstash keeps retrying. It slows down my entire pipeline, so the redis databases get full and I loose logs.

Is there a way to tell logstash to not retry for this output ?
I looked at the docs, but I found no suitable option of the elasticsearch output plugin.

Thank you


(system) #2

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.