Dissector mapping, pattern not found in Logstash

Hi Team,

After a long time I am getting below error in my logstash config.

["beats_input_codec_plain_applied", "_dissectfailure"], "input"=>{"type"=>"log"}}}
[2021-01-15T04:02:07,055][WARN ][org.logstash.dissect.Dissector][main][a13e39ceae461b00fbc60afacbad1eb76827033d9d2d6e00f6435027b6e06994] Dissector mapping, pattern not found {"field"=>"message", "pattern"=>"%{DATETIME}|%{LOGLEVEL}|%{LOGSOURCE}|%{Id}|%{Name}|%{JobId}|%{Type}|%{RequestType}|%{LOGMESSAGE}"

Earlier it works fine for me without %{RequestType} field, After added |%{RequestType} fields, My logstash doesn't work & gives me an error abobe.

filter using in logstash.config below:

dissect {mapping => {"message"=>'%{DATETIME}| %{LOGLEVEL} |%{LOGSOURCE} |%{Id} %{Name} |%{JobId} |%{Type}
%{RequestType} |%{LOGMESSAGE}' } }

Also tried with below tag : 'config.support_escapes:' true, but still not work. followed the below link, but it doesn't help me to resolve my issue.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.