Don't see transactions for backend

Hello, I am .NET developer at ASP NET Core project. My task is to connect my backend and frontend services to APM and see them in Kibana.
I am using Elastic APM .NET Agent: . The project is using .NET 6.

So the problem is that the transactions don't go to my space in Kibana for backend.
I am using the sandbox server from my company.
My frontend configuration, in the top of the tag:

<script src="~/js/rum.umd.js" crossorigin></script>
        serviceName: 'shipment-lab-ui',
        serverUrl: '',
        serviceVersion: '1.0.0',
        active: true,
        environment: 'development',
        breakdownMetrics: true,
        transactionSampleRate: 0.2,
        serverUrlPrefix: '/rum-events'
        'project': 'ship',
        'service_type': 'ui'

My backend config:

""ElasticApm": {
  "ServerUrl": "",
  "ServiceName": "shipment-lab-app",
  "ServiceVersion": "1.0.0",
  "Environment": "development",
  "TransactionSampleRate": "0.2",
  "GlobalLabels": "project=ship,service_type=app"

As you can see in the screenshots the latency for shipment-lab-app is not null, but in overview of this backend service I can't see any transactions and can't choose any option for the transaction.

So what can be the source of this problem?

Hi @Andrii29

For elastic apm, you would need to instrument at top level of your code (i.e. before application calling main function), so that apm able to capture underlaying functions calling, and code.

I presume your backend is using .net core, maybe you can give a try:
.Net Core APM Setup

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.