ECS compatibility target info message

Hello, i'm using logstash in v8.1.3 and since the upgrade in v8 i have this info message:

logstash_1  | [2022-05-09T09:57:59,861][INFO ][logstash.codecs.jsonlines] ECS compatibility is enabled but `target` option was not specified. This may cause fields to be set at the top-level of the event where they are likely to clash with the Elastic Common Schema. It is recommended to set the `target` option to avoid potential schema conflicts (if your data is ECS compliant or non-conflicting, feel free to ignore this message)
logstash_1  | [2022-05-09T09:58:02,427][INFO ][logstash.codecs.json     ][main] ECS compatibility is enabled but `target` option was not specified. This may cause fields to be set at the top-level of the event where they are likely to clash with the Elastic Common Schema. It is recommended to set the `target` option to avoid potential schema conflicts (if your data is ECS compliant or non-conflicting, feel free to ignore this message)

i don't want to disable esc_compatibility, but i'm searching a way to configure all properly to don't have this message.
Here is one of my pipeline containing json codec:

 input {
   http {
     host => "${LS_INPUT_HTTP_HOST:0.0.0.0}" # default: 0.0.0.0
     port => "${LS_INPUT_HTTP_PORT:8080}" # default: 8080
     additional_codecs =>{"application/json-seq"=>"json_lines" }
   }
 }

i checked the documentation

i don't want to specify other target than root/toplevel. What should i do ?
Thanks :slight_smile:

You can ignore that message. Also, see this.

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.