Elastic agent in a docker container TLS error

Good afternoon, I am trying to make a docker container with elastic-agent, packetbeat and metricbeat. I am going to add other components later however I want to get these working first. When I try to install elastic-agent with apt-get, I get a TLS error from the elastic repository. This doesnt happen with packetbeat or metricbeat. I assume that this error is simply caused by the repo not being correctly configured however some comformation would be nice.

Here is the dockerfile im using

FROM debian:latest

WORKDIR /usr/var

RUN apt-get update
RUN apt-get install wget gnupg -y
RUN wget -qO - https://artifacts.elastic.co/GPG-KEY-elasticsearch | apt-key add -
RUN apt-get update
RUN apt-get install apt-transport-https -y
RUN echo "deb https://artifacts.elastic.co/packages/7.x/apt stable main" | tee -a /etc/apt/sources.list.d/elastic-7.x.list
RUN apt-get update
RUN apt-get install elastic-agent packetbeat metricbeat -y

and here is the error message I recieve
Failed to fetch https://artifacts.elastic.co/packages/7.x/apt/pool/main/e/elastic-agent/elastic-agent-7.14.0-amd64.deb Could not handshake: The TLS connection was non-properly terminated.

I just tried to build this Dockerfile on my machine and it worked. I wonder if this maybe was a temporary error? Could you try again?

Good Morning,

It is now working for me also, it appears to have been a tempoary issue. :slightly_smiling_face:

All the best

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.