Elastic.Apm.NetCoreAll how to ignore transaction of OPTIONS http method?

If you are asking about a problem you are experiencing, please use the following template, as it will help us help you. If you have a different problem, please delete all of this text :slight_smile:

TIP 1: select at least one tag that further categorizes your topic. For example server for APM Server related questions, java for questions regarding the Elastic APM Java agent, or ui for questions about the APM App within Kibana.

TIP 2: Check out the troubleshooting guide first. Not only will it help you to resolve common problems faster but it also explains in more detail which information we need before we can properly help you.

Kibana version: 8.8.0

Elasticsearch version: 8.8.0

APM Server version: 8.8.0

APM Agent language and version: .Net Core 7 C# 1.22.0

Browser version:

Original install method (e.g. download page, yum, deb, from source, etc.) and version: Nuget

Fresh install or upgraded from other version? Fresh

Is there anything special in your setup? For example, are you using the Logstash or Kafka outputs? Are you using a load balancer in front of the APM Servers? Have you changed index pattern, generated custom templates, changed agent configuration etc.

Description of the problem including expected versus actual behavior. Please include screenshots (if relevant):

Steps to reproduce:

Errors in browser console (if relevant):

Provide logs and/or server output (if relevant):

You can use the filter API: Public API | APM .NET Agent Reference [1.x] | Elastic

Just return null from that function in case Transaction.Context.Request.Method is OPTIONS. You could also cache the id of such transactions and drop spans within the transaction similarly with a span filter.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.