Elastic Stack 6.2.4 and 5.6.9 security update


(Josh Bressers) #1

X-Pack Machine Learning XSS vulnerability (ESA-2018-06)
X-Pack Machine Learning versions before 6.2.4 and 5.6.9 had a cross-site scripting (XSS) vulnerability. Users with manage_ml permissions could create jobs containing malicious data as part of their configuration that could allow the attacker to obtain sensitive information from or perform destructive actions on behalf of other ML users viewing the results of the jobs.

Affected Versions
All versions of X-Pack Machine Learning

Solutions and Mitigations
Users should upgrade to Elasticsearch version 6.2.4 or 5.6.9.

CVE ID: CVE-2018-3823


X-Pack Machine Learning XSS vulnerability (ESA-2018-08)
X-Pack Machine Learning versions before 6.2.4 and 5.6.9 had a cross-site scripting (XSS) vulnerability. If an attacker is able to inject data into an index that has a ML job running against it, then when another user views the results of the ML job it could allow the attacker to obtain sensitive information from or perform destructive actions on behalf of that other ML user.

Affected Versions
All versions of X-Pack Machine Learning

Solutions and Mitigations
Users should upgrade to Elasticsearch version 6.2.4 or 5.6.9.

CVE ID: CVE-2018-3824