Elasticsearch fails very shortly after launch

Running Ubuntu 18.04.2 LTS, fresh install.
Some output from terminal:

user@guest:~$ java --version
openjdk 11.0.3 2019-04-16
OpenJDK Runtime Environment (build 11.0.3+7-Ubuntu-1ubuntu218.04.1)
OpenJDK 64-Bit Server VM (build 11.0.3+7-Ubuntu-1ubuntu218.04.1, mixed mode, sharing)

user@guest:~$ ls /usr/lib/jvm
default-java  java-1.11.0-openjdk-amd64  java-11-openjdk-amd64

user@guest:~$ echo $JAVA_HOME

user@guest:~$ service elasticsearch status
● elasticsearch.service - Elasticsearch
   Loaded: loaded (/usr/lib/systemd/system/elasticsearch.service; disabled; vendor preset: enabled)
   Active: failed (Result: exit-code) since Sat 2019-07-20 01:09:57 CEST; 6s ago
     Docs: http://www.elastic.co
  Process: 5407 ExecStart=/usr/share/elasticsearch/bin/elasticsearch -p ${PID_DIR}/elasticsearch.pid --quiet (code=
 Main PID: 5407 (code=exited, status=1/FAILURE)

lug 20 01:09:36 guest systemd[1]: Started Elasticsearch.
lug 20 01:09:37 guest elasticsearch[5407]: OpenJDK 64-Bit Server VM warning: Option UseConcMarkSweepGC was deprecat
lug 20 01:09:57 guest systemd[1]: elasticsearch.service: Main process exited, code=exited, status=1/FAILURE
lug 20 01:09:57 guest systemd[1]: elasticsearch.service: Failed with result 'exit-code'.

Installation process: Step 2 described here https://tecadmin.net/setup-elasticsearch-on-ubuntu/.
I haven't edited any configuration file.
Content of var/log/elasticsearch: https://pastebin.com/raw/JnqNhJPK.

I followed this guide (https://www.elastic.co/guide/en/elasticsearch/reference/current/getting-started-install.html) on a new Ubuntu 18.04.2 LTS install on VirtualBox. I did not install anything else other than what showed in that link. Still after running
this is what I get on terminal: https://pastebin.com/raw/K4LAwv1n.
How do I get Elasticsearch to work?

SO you followed 2 different install guides? I've seen lots of problems when people use install guides other than the vendors guide for the version they are installing.

But, from the error, does the /tmp/elasticsearch-xxx.xxx/ directory exist?

No, the folder does not exist.
The first attempt follows the guide linked in the OP while the second follows the official guide from the website (https://www.elastic.co/guide/en/elasticsearch/reference/current/getting-started-install.html).
Both using a clean install of 18.04.2 LTS, and the second attempt on VirtualBox.
First log on the first post and second log on the second post.

I tried to install it on an old laptop and it worked at my first attempt, using the guide from the ES website.
I think that my desktop CPU is even older:

Memory: 9,3 GiB
Processor: AMD® Phenom(tm) ii x4 955 (2009)
OS type: 64-bit
Disk: 116,6 GB

It does not support SSE4.2 which I've seen mentioned here: Failed to start Machine Learning on Elasticsearch 7.0.0.
But I can't get to work older version of ES either.
See the log of version 5.2.0: https://pastebin.com/raw/8kfj4KVM.
Attempt with 6.8.1:

user@guest:~/elasticsearch-6.8.1$ cd distribution/src/bin
user@guest:~/elasticsearch-6.8.1/distribution/src/bin$ ./elasticsearch
Error: Could not find or load main class org.elasticsearch.tools.java_version_checker.JavaVersionChecker
Caused by: java.lang.ClassNotFoundException: org.elasticsearch.tools.java_version_checker.JavaVersionChecker

Maybe try a downloaded appliance to get around the install problems.. https://bitnami.com/stack/elasticsearch/virtual-machine

I can install it but not run it.
I give up and maybe check it out later on when I have a new computer.
Sucks because Ubuntu/Mint is quite snappy on this machine.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.