Elasticsearch run error


(Hyeon Seung Choi) #1

My machine : Raspberry pi

Elasticsearch log:

[2019-03-02T08:44:25,497][WARN ][o.e.b.Natives            ] [unknown] unable to load JNA native support library, native methods will be disabled.
java.lang.UnsatisfiedLinkError: Native library (com/sun/jna/linux-arm/libjnidispatch.so) not found in resource path ([file:/usr/share/elasticsearch/lib/spatial4j-0.7.jar, file:/usr/share/elasticsearch/lib/lucene-spatial-7.6.0.jar, file:$
        at com.sun.jna.Native.loadNativeDispatchLibraryFromClasspath(Native.java:962) ~[jna-4.5.1.jar:4.5.1 (b0)]
        at com.sun.jna.Native.loadNativeDispatchLibrary(Native.java:922) ~[jna-4.5.1.jar:4.5.1 (b0)]
        at com.sun.jna.Native.<clinit>(Native.java:190) ~[jna-4.5.1.jar:4.5.1 (b0)]
        at java.lang.Class.forName0(Native Method) ~[?:1.8.0_181]
        at java.lang.Class.forName(Class.java:264) ~[?:1.8.0_181]
        at org.elasticsearch.bootstrap.Natives.<clinit>(Natives.java:45) [elasticsearch-6.6.1.jar:6.6.1]
        at org.elasticsearch.bootstrap.Bootstrap.initializeNatives(Bootstrap.java:102) [elasticsearch-6.6.1.jar:6.6.1]
        at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:170) [elasticsearch-6.6.1.jar:6.6.1]
        at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:333) [elasticsearch-6.6.1.jar:6.6.1]
        at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:159) [elasticsearch-6.6.1.jar:6.6.1]
        at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:150) [elasticsearch-6.6.1.jar:6.6.1]
        at org.elasticsearch.cli.EnvironmentAwareCommand.execute(EnvironmentAwareCommand.java:86) [elasticsearch-6.6.1.jar:6.6.1]
        at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:124) [elasticsearch-cli-6.6.1.jar:6.6.1]
        at org.elasticsearch.cli.Command.main(Command.java:90) [elasticsearch-cli-6.6.1.jar:6.6.1]
        at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:116) [elasticsearch-6.6.1.jar:6.6.1]
        at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:93) [elasticsearch-6.6.1.jar:6.6.1]
[2019-03-02T08:44:25,533][WARN ][o.e.b.Natives            ] [unknown] cannot check if running as root because JNA is not available
[2019-03-02T08:44:25,534][WARN ][o.e.b.Natives            ] [unknown] cannot install system call filter because JNA is not available
[2019-03-02T08:44:25,536][WARN ][o.e.b.Natives            ] [unknown] cannot register console handler because JNA is not available
[2019-03-02T08:44:26,107][WARN ][o.e.b.Natives            ] [unknown] cannot getrlimit RLIMIT_NPROC because JNA is not available
[2019-03-02T08:44:26,108][WARN ][o.e.b.Natives            ] [unknown] cannot getrlimit RLIMIT_AS because JNA is not available
[2019-03-02T08:44:26,108][WARN ][o.e.b.Natives            ] [unknown] cannot getrlimit RLIMIT_FSIZE because JNA is not available
[2019-03-02T08:44:27,263][INFO ][o.e.e.NodeEnvironment    ] [CuMY4l4] using [1] data paths, mounts [[/ (/dev/root)]], net usable_space [50.7gb], net total_space [58.6gb], types [ext4]
[2019-03-02T08:44:27,264][INFO ][o.e.e.NodeEnvironment    ] [CuMY4l4] heap size [247.5mb], compressed ordinary object pointers [unknown]
[2019-03-02T08:44:27,271][INFO ][o.e.n.Node               ] [CuMY4l4] node name derived from node ID [CuMY4l4iTGec_u7-kx21YQ]; set [node.name] to override
[2019-03-02T08:44:27,272][INFO ][o.e.n.Node               ] [CuMY4l4] version[6.6.1], pid[3773], build[default/deb/1fd8f69/2019-02-13T17:10:04.160291Z], OS[Linux/4.14.70-v7+/arm], JVM[Oracle Corporation/OpenJDK Client VM/1.8.0_181/25.18$
[2019-03-02T08:44:27,273][INFO ][o.e.n.Node               ] [CuMY4l4] JVM arguments [-Xms256M, -Xmx256M, -XX:+UseConcMarkSweepGC, -XX:CMSInitiatingOccupancyFraction=75, -XX:+UseCMSInitiatingOccupancyOnly, -Des.networkaddress.cache.ttl=6$
[2019-03-02T08:44:44,128][INFO ][o.e.p.PluginsService     ] [CuMY4l4] loaded module [aggs-matrix-stats]
[2019-03-02T08:44:44,128][INFO ][o.e.p.PluginsService     ] [CuMY4l4] loaded module [analysis-common]
[2019-03-02T08:44:44,129][INFO ][o.e.p.PluginsService     ] [CuMY4l4] loaded module [ingest-common]
[2019-03-02T08:44:44,129][INFO ][o.e.p.PluginsService     ] [CuMY4l4] loaded module [lang-expression]
[2019-03-02T08:44:44,129][INFO ][o.e.p.PluginsService     ] [CuMY4l4] loaded module [lang-mustache]
[2019-03-02T08:44:44,129][INFO ][o.e.p.PluginsService     ] [CuMY4l4] loaded module [lang-painless]

Please...Help me...! : (

I am writing a translator because I can not speak English.
I cut the log a bit because of the character limit.


(Hyeon Seung Choi) #2
● elasticsearch.service - Elasticsearch
   Loaded: loaded (/usr/lib/systemd/system/elasticsearch.service; enabled; vendor preset: enabled)
   Active: failed (Result: exit-code) since Sat 2019-03-02 08:46:38 UTC; 20min ago
     Docs: http://www.elastic.co
  Process: 3912 ExecStart=/usr/share/elasticsearch/bin/elasticsearch -p ${PID_DIR}/elasticsearch.pid --quiet (code=exited, status=1/FAILURE)
 Main PID: 3912 (code=exited, status=1/FAILURE)

Mar 02 08:45:45 raspberrypi systemd[1]: Started Elasticsearch.
Mar 02 08:46:38 raspberrypi systemd[1]: elasticsearch.service: Main process exited, code=exited, status=1/FAILURE
Mar 02 08:46:38 raspberrypi systemd[1]: elasticsearch.service: Unit entered failed state.
Mar 02 08:46:38 raspberrypi systemd[1]: elasticsearch.service: Failed with result 'exit-code'.

java -version
openjdk version "1.8.0_181"
OpenJDK Runtime Environment (build 1.8.0_181-8u181-b13-2~deb9u1-b13)
OpenJDK Client VM (build 25.181-b13, mixed mode)


(David Pilato) #3

Please format your code, logs or configuration files using </> icon as explained in this guide and not the citation button. It will make your post more readable.

Or use markdown style like:

```
CODE
```

This is the icon to use if you are not using markdown format:

There's a live preview panel for exactly this reasons.

Lots of people read these forums, and many of them will simply skip over a post that is difficult to read, because it's just too large an investment of their time to try and follow a wall of badly formatted text.
If your goal is to get an answer to your questions, it's in your interest to make it as easy to read and understand as possible.
Please update your post.

See also #in-your-native-tongue for the other languages you can ask help with. May be this one? https://discuss.elastic.co/c/in-your-native-tongue/korean


(Hyeon Seung Choi) #4

Thanks! I learn a lot.


(system) closed #5

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.