Enable debug logging on metricbeat using a docker CMD

If I'm running metricbeat in docker, how can I enable debug logging?

So far I've tried

  1. ./metricbeat setup -E logging.level="debug" && ./metricbeat
  2. ./metricbeat -d "*"

but I can't get it to work.

I'm expecting the logs to appear in stdout when running in docker (so they're visible using docker logs command). Is that incorrect?

Turns out you need the -e flag to write to stdout.