Error creating new beat

I've created beats in the past using the old method by invoking Python. This is the first time I've tried generating one using mage GenerateCustomBeat.

I have the beats repo checked out in the right place and pulled latest from master. All other dev dependencies seem correct but when I run mage GenerateCustomBeat, I get the following error:

No .go files marked with the mage build tag in this directory.

I've followed the new documentation and I'm running the command from my user directory in $GOPATH/src/github.com/{USER}.

There's probably something I've missed but I can't figure out what it is. Any help appreciated.

Thanks in advance.

Never mind. I was following the docs but the docs are horribly wrong.

Instead of running mage GenerateCustomBeat from the user's github home directory (${GOPATH}/src/github.com/{user}), it has to be run from ${GOPATH}/src/github.com/elastic/beats.

I found this instruction in a comment in a Github issue: https://github.com/elastic/beats/issues/14409

I ran it from the beats directory then got another issue, which appears to be a known problem with a fix hopefully on the way.

I hate to be negative but this is really bad form. That issue is five months old and the docs are still wrong to the point where you can't even start building a beat without having to search for issues and find workarounds. I've contributed docs (and am in the process of contributing code to libbeat) but this lack of commitment from Elastic really saps my motivation to continue.

Again, sorry to moan, but it's really important to get the basics right.

I'll try and make some time to fix the docs to say to run mage GenerateCustomBeat from the correct place.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.