Error file logstash configuration

Hello everybody,
I'm using logstash to connect with my database sql server
the purpose is to send all data in my table to elasticsearch
see below my logstash.conf
input {
jdbc {
jdbc_driver_library => "c:\program files (x86)\microsoft jdbc driver 4.0 for sql server\sqljdbc_4.0\fra\sqljdbc4.jar"
jdbc_driver_class => ""
jdbc_connection_string => "jdbc:sqlserver://localhost:1433;user=***;password=***;databaseName=base1"
jdbc_user => "***"
jdbc_password => "***"
statement => "select *
from tb_elastic_search"
filter {
output {
elasticsearch {
host => ""
index => "moderatus"
document_type => "tb_elastic_search"
document_id => "%{int_content_id}"
protocol => "http"
stdout { codec => rubydebug }
when i run /bin>logstash -f logstash.config
I get the error below :
reason=>"The setting host in plugin elasticsearch is obsolete and is no longer available.
Please use the 'hosts' setting instead. You can specify multiple entries separated by comma in 'host:port' format. If you have any questions about this, you are invited to visit and ask.", :level=>:error}←[0m
The signal HUP is in use by the JVM and will not work correctly on this platform

If someone has an idea to help me, it's very gratefull slight_smile:

thank you so much

This error message seem quite clear to me. All the configuration parameters available for the current version of the plugin are further described in the documentation.

thank you for your reply
I change host to hosts with array value i.e hosts => [""] but i get the same error
if you have an idea wink:
I am a beginner for logstash, elasticsearch, if someone could help me :wink:

Are you running on Windows? Try

hosts => ["localhost:9200" ]

I have had problems using the loopback address on Windows.