Error Ignoring the 'pipelines.yml' file because modules or command line options are specified

when i chargin my postgres in elastic with my file.conf error like:Ignoring the 'pipelines.yml' file because modules or command line options are specified any suggestion please ?

input {
  jdbc {
 jdbc_connection_string => "jdbc:postgresql://localhost:5432/postgres"
            jdbc_validate_connection => true
            #jdbc_driver_library => "/Users/inveniet/Desktop/logstash-7.4.0/config/postgresql-42.2.8.jar"
            jdbc_driver_class => "org.postgresql.Driver"
            jdbc_user => "postgres"
            jdbc_password => "1234"
            use_column_value => true
            tracking_column_type => "timestamp"
        
            statement => "select * from E-ANOMAL "
        
	
   
 }
}
output {
 elasticsearch {
	hosts => ["localhost:9200"]
	index => "postgres"
	document_id => "%{id}"
 }

That message is not an error it just states since you probably started logstash with the -f option command pipelines.yml will be ignored. That is normal operation.

What is the actual issue / what is or is not actually working?

You data is not loading?
Failing connection to the DB?

It's always better to show us the command you ran and more complete logs so that we can help.

1 Like