Error "Kibana server is not ready yet"


#21

This worked for me!!


#22

Hi,

I have the same issue, did you have solde this problem ?

Regards,


(Génesis) #24

Yes, but I solved it by going back to the version I had before. I tried to upgrade from 6.4.3 to 6.5.0. Luckily, after upgrading to 6.5.0 I saved all the older versions files in another folder, so at the end I solved it by running both older versions of elasticsearch and kibana (I don't use logstash).

So, in a few words, I decided not to run the new version for the moment.
I think it's better to use the snapshot and restore feature before upgrading (I didn't do it though).


(Thomas Walter) #25

Is this fixed in 6.5.1 / can we remove the addition role and user that we had to add for the temporary fix?


(Ryan Downey) #26

We've got 6.5.1 installed and I just ran into this issue. Balu, I'm working in an environment where I can't download Cerebro as of right now. Would you mind posting the curl commands you were using to see if mine are somewhat close to the right thing. It wouldnt surprise me if I have some syntax thats incorrect. I've been using variations of this to no availe:

curl -X POST -d {"indices":[{"names":[".tasks"],"privileges":["all"]}]} http://localhost:9200/_xpack/security/role/tasks_bugfix -H 'Content-Type: application/json'

Was the [globbing] nested braces not supported issue what you ran into?


(Thomas Walter) #27

I'm sorry, I didn't get the curl commands to work which is why I used Cerebro instead. The error messages I got was more about a wrong path than braces or similar though IIRC.

Have you tried single quotes around your "-d" option? I'd guess your shell is evaluating the braces...

I thought the problem itself was fixed in 6.5.1, so you shouldn't have run into it?


(lowid) #28

Delete all 4 index and a restart resolved my problem